Ubuntu

TI SD Card reader doesn't work on LG laptop

Reported by sasha on 2007-06-04
14
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

Ok, I have seen a lot of bugs related to the SD Card reader problems. But I haven't found solution for my case and my case seems to be unique than others. I have an internal SD Card Reader from Texas Instruments on LG LM40 laptop. In WinXP I see two devices under PCMCIA adapters:

- TI CardBus Controller with FlashMedia
- TI PCI7410 CardBus Controller

I have tried a lot of tricks with modprobe, tifm_* and mmc_* modules but without any success. There weren't even any mentions in dmesg about SD Card Reader when I tried to load modules.

Here is output of lspci:

00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 21)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 21)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M9+ 5C63 [Radeon Mobility 9200 (AGP)] (rev 01)
02:00.0 CardBus bridge: Texas Instruments Unknown device ac49 (rev 01)
02:00.1 CardBus bridge: Texas Instruments Unknown device ac4b (rev 01)
02:00.2 FireWire (IEEE 1394): Texas Instruments PCI7410,7510,7610 OHCI-Lynx Controller
02:00.3 System peripheral: Texas Instruments PCI7410,7510,7610 PCI Firmware Loading Function
02:02.0 Network controller: Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 04)
02:06.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better.
Please include as attachments the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

Changed in linux-source-2.6.20:
assignee: nobody → brian-murray
status: New → Incomplete
Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in linux-source-2.6.20:
status: Incomplete → Invalid
Mahardhika (mahardhika) wrote :

Hi,
i experienced same case with @alexander, my LG LS50 can't detect the TI CardBus controller, and neither can to modprobe with tifm* and mmc*.
here i attached the dmesg log and lspci -vvnn.
rgds,

mahardhika

Brian Murray (brian-murray) wrote :

This issue is one that should be reproducable with the live environment of the Desktop CD of the development release - Gutsy Gibbon. It would help us greatly if you could test with it so we can work on getting it fixed in the actively developed kernel. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in linux-source-2.6.20:
status: Invalid → Incomplete
Mahardhika (mahardhika) wrote :

hi Brian,
i already tested on ubuntu gutsy, but the hardware still don't detected.
# uname -a
Linux laptopLG 2.6.22-11-generic #1 SMP Fri Sep 7 05:07:05 GMT 2007 i686 GNU/Linux

# lspci | grep Unknown
02:00.0 CardBus bridge: Texas Instruments Unknown device ac49 (rev 01)
02:00.1 CardBus bridge: Texas Instruments Unknown device ac4b (rev 01)

any comments ?

TIA,

Changed in linux-source-2.6.20:
assignee: brian-murray → nobody
importance: Undecided → Medium
status: Incomplete → Won't Fix
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged

hi all,

i have just jested this issue on my lg lm40 laptop with gutsy - the sd card still doesn't work.

$ uname -a
Linux india 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

$ lspci | grep -i unk
02:00.0 CardBus bridge: Texas Instruments Unknown device ac49 (rev 01)
02:00.1 CardBus bridge: Texas Instruments Unknown device ac4b (rev 01)

Mahardhika (mahardhika) wrote :

yes, i am using gutsy as well now, but my LS-50 still does not recognize my cardreader

Hi all!

Does anyone could make something with this issue? Every time I need to boot in MS WinXP to get data from SD card. This is really problem for me and other LG laptop owners :( Let me know if you need more information from me.

Hi, I've made a meta-bug to keep track of all these Texas Card Reader bugs - please help me by using it to close duplicates, and get new bugs to search for duplicates. The meta-bug is Bug #180076

The Hardy Heron Alpha series was recently released. Alpha2 and subsequent releases contain an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . Please note that Alpha3 will be released within the next day or two so you may want to wait. You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ .

Changed in linux:
status: New → Incomplete

I've opened a new task against the actively developed kernel and am closing the task against linux-source-2.6.22. Thanks!

Changed in linux-source-2.6.22:
status: Triaged → Won't Fix

The same situation with latest Hardy Heron - card reader doesn't work.

02:00.0 CardBus bridge: Texas Instruments Unknown device ac49 (rev 01)
02:00.1 CardBus bridge: Texas Instruments Unknown device ac4b (rev 01)

Please find lspci output attached.

Interesting. Can you also attach your dmesg output for the newer kernel? Thanks.

Hi Leann,

Please find dmesg output attached.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Tim Gardner (timg-tpi) wrote :

It looks like the Yenta socket driver is correctly claiming the device. Update to the current kernel (2.6.24-7.12). Please attach /var/log/syslog after inserting the SD media. Also try 'sudo fdisk -l'.

P.S. Don't compress the attachments.

Changed in linux:
assignee: ubuntu-kernel-team → timg-tpi
status: Triaged → In Progress

it seems that hardy still doesn't support TI SD card reader.

uname -a
Linux home-mobile 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686 GNU/Linux

SD card was inserted into notebook, after dmesg and syslog were captured. Please find all details in the attachment.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

shanakadu (shanakadu) wrote :
shanakadu (shanakadu) wrote :

I have LG LM50 laptop. I have recently upgrade to ubuntu 9.04 . And the Texas SD Reader don't work. I attach the output of lspci -xxx. I have using ubuntu from 6.04 , and never the reader has work for ubuntu. I would like to help to resolve this issue. Thanks.

shanakadu (shanakadu) wrote :

i add lspci -vvn command, too

Mahardhika (mahardhika) wrote :

strange, mine can. i am using ubuntu 8.01 and was being detected by kernel the card reader ~

didn't do anything, just install it

Tim Gardner (timg-tpi) on 2009-11-24
Changed in linux (Ubuntu):
assignee: Tim Gardner (timg-tpi) → nobody
importance: Medium → Undecided
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers