ps2 keyboard does not work on VIA chipset mainboard

Bug #117899 reported by asch on 2007-05-31
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Andy Whitcroft
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.20

PS2 Keyboard does not work on VIA chipset machine with this kernel: there is no response to any key.
Keyboard works in grub menu and BIOS settings. Some more PS2 keyboards were tried.

It was working with the kernel of dapper (it failed after upgrade).

The kernel option apci=off quick-fixes this problem, then the keyboard works.

dmesg lspci and uname is attached.

This bug report was redirected from 108382 which turned out to be SiS specific while this bug is told to be VIA specific.

asch (asch) wrote :

I also have this problem with a PS/2 keyboard running on a VIA chipset motherboard.

The keyboard does not work:
* when booting into "Recovery mode" (runlevel 1).

The keyboard does work:
* in the BIOS Setup;
* in GRUB;
* when booting into full graphical mode (runlevel 2);
* after switching from full graphical mode into single user mode (sudo init 1);
* in any mode using Knoppix 5.1.1, openSUSE 10.2, and Fedora 7.

The keyboard previously worked correctly in:
* Ubuntu 6.06;
* Ubuntu 6.10.

The keyboard worked sometimes under previous Ubuntu 7.04 kernel revisions if the Num Lock key was pressed immediately after the boot process switched off the Num Lock light. Changing the Num Lock setting in the BIOS has no effect on the problem.

For reference, my specific keyboard is a Unicomp Customizer (formerly Lexmark, formerly IBM), and can be found at http://www.pckeyboard.com/ .

Other helpful output is attached.

Wiskas (mail-wiskas) wrote :

Goodday,

How do you switch off apci? Because I have the same problem with my ps2 keyboard.... i am not sure what chipset I have....

When you see the grub menu, select your kernel, press e, then you can
edit your kernel's boot options. append acpi=off to the line. That's all.
This line can be written into the /boot/grub/menu.lst file. This file is
auto-regenerated, when your kernel is updated by apt-get upgrade (or
utomatic upgrade). You can add persistent options that are added to the
re-generated kernel options too. See the manual and the self-describing
menu.lst file.
If you don't know your chipset you should see the other PS2/keyboard
related bug reports as well.

Wiskas írta:
> Goodday,
>
> How do you switch off apci? Because I have the same problem with my ps2
> keyboard.... i am not sure what chipset I have....
>
>

Changing the "PnP OS Installed" option from "No" to "Yes" in the BIOS Setup seems to have corrected the problem. All my devices still work correctly (so far), and the keyboard now works in Single User mode.

For the record, PnP OS Installed has been set to No for every Ubuntu version I've installed, with no problems until recently.

wna (me-jansteffan) wrote :

I resolved the problem by adding the following init script:

   #!/bin/sh
   echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind
   echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind

(linking it to /etc/rc2.d/S20rebind-keyboard worked for me.)

Robert Entner (robertentner) wrote :

On a freshly installed Hardy my keyboard works again without any modifications.

Set to "Fix Released", please change back if the bug is only solved on my system.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Bjørn Sandåker (prognatus) wrote :

I got this bug today, when updating to the new kernel 2.6.27-7 in Kubuntu.

My PC has a VIA chipset. It was not a problem before, upto Ubuntu version 7.10, and it worked Ok in the newest Kubuntu 8.10 also at first, but after this morning's updates the keyboard stopped working after login.

What's more, the previous kernel isn't there anymore! Why wasn't it preserved as usual, when the new kernel was installed? So I'm stuck until someone discovers what they did to break this kernel update...

Hi Bjorn,

Is this still an issue for you? If so, would you possibly be able to ssh into the machine and capture dmesg output and attach it to this report? Thanks.

Andy Whitcroft (apw) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Note that as the problem was reported fixed for in Hardy I am closing this Fix Released. Please open a new bug if the issue is still present in Intrepid and later. It is likely a separate issue with the same symptoms. Thanks.

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers