Ubuntu

Regression: Kernel 2.6.20-16 breaks Smart-battery ACPI support

Reported by Alan Briolat on 2007-05-30
80
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Declined for Feisty by Henrik Nilsen Omma
Nominated for Gutsy by ncsaba
linux (Ubuntu)
Undecided
Unassigned
Declined for Feisty by Henrik Nilsen Omma
Nominated for Gutsy by ncsaba
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned
Declined for Feisty by Henrik Nilsen Omma
Nominated for Gutsy by ncsaba
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned
Declined for Feisty by Henrik Nilsen Omma
Nominated for Gutsy by ncsaba

Bug Description

Binary package hint: linux-image-2.6.20-16-386

Using the 2.6.20-16-386 kernel for some reason stops ACPI battery details from turning up in /proc/acpi/battery/ , which in turn removes functionality from things such as gnome-power-manager because no battery information can be determined. Booting on 2.6.20-15-386 kernel does result in this information being available. I'll attach a dmesg for both boots.

Alan Briolat (alan-codescape) wrote :
Alan Briolat (alan-codescape) wrote :
1ted (wouter-blancquaert) wrote :

The same is true for battery in Acer TM4000, which has a "smart battery":

Output of acpi -V:
In 2.6.20-15

Battery 1: charging, 63%, 01:14:00 until charged
Thermal 1: ok, 35.0 degrees C
AC Adapter 1: on-line

In 2.6.20-16:

Thermal 1: ok, 43.0 degrees C

Sitsofe Wheeler (sitsofe) wrote :

Alan:
Can you run
sudo depmod
then reboot and test again?

Alan Briolat (alan-codescape) wrote :

Did that, still no different.

nclm (nclm) on 2007-05-31
Changed in linux-source-2.6.20:
status: Unconfirmed → Confirmed
isazi (isazi) wrote :

Same problem with acer travelmate 2300, i've posted a bug report today (sorry, i've not seen this).

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/117947

eis (launchpad-eiselin) wrote :

I have the same problem with an Acer Aspire 1680. In 2.6.20-15 my battery is detected correctly, but in 2.6.20-16 there is no battery information available. My laptop also has a 'smart battery system'.

eis (launchpad-eiselin) wrote :

This bug also reports this problem:
https://bugs.launchpad.net/ubuntu/+bug/117504

eis (launchpad-eiselin) wrote :

Same problem is discussed here:
http://ubuntuforums.org/showthread.php?p=2769074

and here:
http://ubuntuforums.org/showthread.php?t=457417

I really hope the Ubuntu team will help us with this issue.

Spoilerhead (spoilerhead) wrote :

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/118031
seems to note where the regression could be.
any progress?

Onestone (onestone) wrote :

Confirming, on an Acer TravelMate 4502WLMi

Besides, when I unplug the power line, the laptop loses power immediately (doesn't switch to battery)! When doing the same in Windows, everything is OK.

Output of "sudo acpi -V":

Thermal 1: ok, 54.0 degrees C

(nothing about battery)

Spoilerhead (spoilerhead) wrote :

just noticed the same behavior here :-(
this bug is really annoying and makes mobile operation quite impossible

Jef (jef-v) wrote :

I have the same behavior on my Toshiba Satellite L10.

I posted my "dmesg" and "lspci -vvnn" to this bug report
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/118006

Spoilerhead (spoilerhead) wrote :

spoilerhead@plasmafire:~$ uname -a
Linux plasmafire 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux
spoilerhead@plasmafire:~$ acpi -V
     Battery 1: charged, 97%
     Thermal 1: ok, 52.0 degrees C
  AC Adapter 1: on-line

just testes
i replaced
kernel/drivers/acpi/i2c_ec.ko with the one from the -15 kernel

that FIXES the bug for me!

so https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/118031 is really the source of the problem!

Spoilerhead (spoilerhead) wrote :

could anyone of the kernel maintainers give us a ETA until its fixed in the package?
there are a lot of people out there who have their battery support broken __since 3 weeks__

we know what it is we know how to fix it, we just need to apply this to reverse the patch that broke it.

goto (gotolaunchpad) wrote :

Here the same, since a few weeks ago. Using an Acer Travelmate 4002WLMi.

Is there any way to help in order to have a fixed release soon?

It's really very annoying not being able to know how much battery it's left, until the computer switches off itself.

PD. I think that if Ubuntu wants to be able to be used by normal people it shouldn't have this kinds of problems, or at least, have a fast fix.

David Gift (david-gift) wrote :

As a user I'm not going to recompile my kernel in case I break anything but it is annoying having to use an old version if I want battery support. I'd be very grateful if this could be packaged.

ooops (ooops) wrote :

The fast solution is described at https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/117773/comments/15. Just copy i2c_ec.ko of the .15 kernel-version over the new one. This will also work for future 'security' updates of the kernel as long as the respective ABI is stable, i.e. who knows how long.

The real problem is that the Ubuntu kernel team releases untested non-security patches as part of a security update. That is the work of amateurs (amateur is about the nicest word I can find for it ;-).

Spoilerhead (spoilerhead) wrote :

agreed in all statements.
but you probably forgot:

- doesn't give a single statement to the bug (even as a patch is there).

its now eleven days since we got the patch that fixes the problem, i wonder if it would take so much time to get a response when something on Mr. Shuttleworths notebook breaks...

oudalrich (uhkeller) wrote :

I wonder how Canonical ever wants to make money from Ubuntu if this amateurism continues. I'll start looking for a more reliable distro. User-friendliness is nice, but not having to be afraid that the next update might break my system would be even nicer.

Spoilerhead (spoilerhead) wrote :

could someone confirm if the fix will be included in the next kernel update?

isazi (isazi) wrote :

Another very uncool thing is that to have battery support i've downgraded my kernel to 2.6.20-15... and that kernel has serious problems with cd/dvd burner :(

craffels (craffels) wrote :

Same issue with a Acer4001LMI. Fortunately the patch fixes the problem for me too. Thanks to the user who provided it! I hope such things won't happen in future again, as they are very annoying.

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Confirmed → Triaged
francis75 (francisco-perso) wrote :

I have the same problem. Unfortunately I don't have the .15 kernel version, because I upgraded to feisty one week ago and the patch didn't work for me. The output was :

File to patch: /lib/modules/2.6.20-16-386/kernel/drivers/acpi/i2c_ec.ko
patching file /lib/modules/2.6.20-16-386/kernel/drivers/acpi/i2c_ec.ko
Hunk #1 FAILED at 308.
1 out of 1 hunk FAILED -- saving rejects to file /lib/modules/2.6.20-16-386/kernel/drivers/acpi/i2c_ec.ko.rej

It is really annoying that after three months canonical didn't fix it yet ... can anyone help me?
My computer is an Acer Travelmate 4002WLMI

dmesg gives :

[ 4.404000] Time: acpi_pm clocksource has been installed.
[ 72.792000] ibm_acpi: ec object not found
[ 72.844000] sbs: Unknown symbol acpi_get_ec_hc
[ 72.948000] pcc_acpi: loading...

and acpi -V :
  Thermal 1: ok, 51.0 degrees C

so, there is no ac found...

Gonçalão (gonvelho) wrote :

I have the same problem. It's not the first time this happen. Also with version .13 of kernel I had this problem. It was fixed and we get down again to the same.
The relation of Ubuntu with smart batteries seems to be long from over, and what is worst is the amount of time this is taking to get fixed.
This is not a Medium thing. This is severe and should be fixed.
Shame on Ubuntu.

Baxter Shepperson (baxshep) wrote :

  This is a Severe bug and needs to be addressed ASAP.

isazi (isazi) wrote :

I think it's too late now, in less than two months we'll get a new version, so, has anyone tried if with gutsy we still have that problem with smart batteries ?

The same problem on my BenQ S53 with new kernel version.

Corhere (corhere) wrote :

Yesterday I updated the kernel to 2.6.20-16.31 from 2.6.20-16.29 and the battery is still not detected in my Acer Travelmate 4002WLMi.

Walter Wunsch (wwunsch) wrote :

the same on my acer extensa 3000!
i copied the old ko and it is o.k.
so nobody of the ubuntu team will fix the bug!
i think its because the problem is not a generell prob!
on my hp nc6400 everything is o.k.!

now my questions: will this be fixed in gutsy?
if not, will the ko-fix work in gutsy?

if not, i will look around for an other distribution.....

ooops (ooops) wrote :

I tested it a few days ago with tribe-5 or 4 and it worked. However,
given the record of this bug and the absence of any real statements of
the kernel-team I would not assume that you can trust on that in the
future. They triaged the bug as medium which is in the best case a we
are sorry. Apparently, stable release and regression is still an
unfamiliar word to the kernel-team of Ubuntu.

Regards, Peter

Walter Wunsch wrote:
> the same on my acer extensa 3000!
> i copied the old ko and it is o.k.
> so nobody of the ubuntu team will fix the bug!
> i think its because the problem is not a generell prob!
> on my hp nc6400 everything is o.k.!
>
> now my questions: will this be fixed in gutsy?
> if not, will the ko-fix work in gutsy?
>
> if not, i will look around for an other distribution.....
>
>

ncsaba (ncsaba) wrote :

OK, so I have the same behavior on an Acer Extensa 3000WLMi_B, i.e. it worked fine after installing from the live CD, and broke after the first security update. The module copy from kernel version 15.x fixed it for me too. Would be nice if the next released kernel version would get it right...

Cheers,
Csaba.

And now the latest update breaks it again.... unbelievable.

Baxter Shepperson (baxshep) wrote :

  This is still present on a fresh Tribe 5 install on an IBM Z60. Showstopper bug for myself and many on the forums, makes the laptop unusable.

uname -r
2.6.22-12-generic

dmesg|grep aml
[ 4.421926] ACPI: Looking for DSDT in initramfs... error, file /DSDT.aml not found.

Henrik Nilsen Omma (henrik) wrote :

Created Gutsy task for this. Could those experiencing this with the 2.6.22 kernel please follow the procedures described here https://wiki.ubuntu.com/KernelTeamBugPolicies and here https://wiki.ubuntu.com/DebuggingACPI and attach the output? Thanks!

Changed in linux-source-2.6.22:
importance: Undecided → Medium
status: New → Incomplete
Henrik Nilsen Omma (henrik) wrote :

Closing 2.6.20 task. We should fix this for Gutsy, but it's too late for Feisty.

Changed in linux-source-2.6.20:
status: Triaged → Won't Fix
Baxter Shepperson (baxshep) wrote :

  Attaching output Henrik requested, thanks for jumping on this, looking forward to getting working laptop soon!

Spoilerhead (spoilerhead) wrote :

probably the fix is the same is i noted 3 months ago in comment #15. could you maybe try that, too?

I found that drivers/acpi/i2c_ec.c no longer exists (in 2.6.22). Does anybody has another idea what to do in Ubuntu Gutsy?

isazi (isazi) wrote :

For what i can see, in gutsy with kernel 2.6.22-14-generic everything is fine and battery works as is.

For me in Gutsy the battery is not detected. I have an Acer Aspire 3050. A "battery absent" message is reported in the kernel log. I run the latest official Gutsy kernel (binary).

Spoilerhead (spoilerhead) wrote :

it works for me in gutsy, too. maybe its a different bug that is affecting you?
if you know how, try a different kernel (vanilla,fedora,gentoo, ...)

Walter Wunsch (wwunsch) wrote :

for it works in gutsy (acer 3000)

ooops (ooops) wrote :

That's okay because it is not a module:

/boot$ grep ACPI_EC config-2.6.22-14-generic
CONFIG_ACPI_EC=y

Here is the dmesg how ec/sbs show up in the new kernel:

[ 8.069115] ACPI: EC: Look up EC in DSDT
[ 8.070816] ACPI: EC: GPE=0x1d, ports=0x66, 0x62
[ 24.832000] ACPI: Smart Battery System [SBS0]: AC Adapter [AC0] (on-line)
[ 25.544000] ACPI: Smart Battery System [SBS0]: Battery Slot [BAT0]
(battery present)

Your problem is definitely a different story than this bug. Create a new
bug-report, attach the respective output and hope someone finds time to
look at it. Alternatively test with the latest vanilla kernel and report
problems directly to the ACPI people.

-Peter

Kovács Zoltán wrote:
> I found that drivers/acpi/i2c_ec.c no longer exists (in 2.6.22). Does
> anybody has another idea what to do in Ubuntu Gutsy?
>
>

OK, thanks. I had other kind of problems with the vanilla kernel. I continued my story on http://bugzilla.kernel.org/show_bug.cgi?id=8953 :-)

Henrik Nilsen Omma (henrik) wrote :

Seems to be working for 3/4 people. Marking Fix Released. If you can still reproduce this problem with the 2.6.24 Hardy kernel (due out in a week or so), please reopen with a 2.6.24 task. Thanks!

Changed in linux-source-2.6.22:
status: Incomplete → Fix Released

bug seems to affect hardy kernel. please confirm

Majorix (axabert) wrote :

Yes, I can confirm that it affects my Hardy.

For those still experiencing this issue with the new Hardy kernel, per the kernel team bug policy please attach the following information. Please be sure to attach each file as a separate attachment.

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks.

Changed in linux:
status: New → Incomplete

requested data attached

Hi NoWhereMan,

After looking at your dmesg output I notice some ACPI errors, and specifically this one seems suspicious:

ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.BAT0._STA] (Node f7c47390), AE_NOT_EXIST

The following upstream bug report: http://bugzilla.kernel.org/show_bug.cgi?id=9730 exhibitted similar errors. The patch which resolved that issue was shipped in upstream's linux-2.6.24-rc7-git5. The Ubuntu kernel then pulled in this patch for the 2.6.24-5.8 Ubuntu kernel release. I see that you are running an older Ubuntu kernel version, 2.6.24-4.7. Care to try running the latest kernel 2.6.24-5.9 which will contain this patch from upstream. Please then verify if this issue still exists. Thanks!

Yes, the package was been updated to -8 and this problem seems to be
gone; however I don't see still any -9 package nor in main nor in
hardy-proposed.

By the way, I'm running hardy kernel under gutsy, that's why sometimes
I might be out of sync, I apologize.

On Jan 30, 2008 12:44 AM, Leann Ogasawara <email address hidden> wrote:
> Hi NoWhereMan,
>
> After looking at your dmesg output I notice some ACPI errors, and
> specifically this one seems suspicious:
>
> ACPI Error (psparse-0537): Method parse/execution failed
> [\_SB_.BAT0._STA] (Node f7c47390), AE_NOT_EXIST
>
> The following upstream bug report:
> http://bugzilla.kernel.org/show_bug.cgi?id=9730 exhibitted similar
> errors. The patch which resolved that issue was shipped in upstream's
> linux-2.6.24-rc7-git5. The Ubuntu kernel then pulled in this patch for
> the 2.6.24-5.8 Ubuntu kernel release. I see that you are running an
> older Ubuntu kernel version, 2.6.24-4.7. Care to try running the latest
> kernel 2.6.24-5.9 which will contain this patch from upstream. Please
> then verify if this issue still exists. Thanks!
>
> --
> Regression: Kernel 2.6.20-16 breaks Smart-battery ACPI support
> https://bugs.launchpad.net/bugs/117773
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Hi NoWhereMan,

Thanks for testing and verifying this is fixed. I'm going to mark this as 'Fix Released' Thanks.

Changed in linux:
status: Incomplete → Fix Released

On Jan 31, 2008 10:07 PM, Leann Ogasawara <email address hidden> wrote:
> Hi NoWhereMan,
>
> Thanks for testing and verifying this is fixed. I'm going to mark this
> as 'Fix Released' Thanks.

Hi Leann, I'm afraid there could be a regression in this new kernel
that causes to the pc to hang with rt61pci, unfortunately I can't seem
to be able find any information on the logs, the only thing I get is a
frozen system and a blinking capslock led

Hi NoWhereMan,

Care to actually open a new bug report regardig this issue. It's helpful to the development teams if bug reports target one specific issue against a specific set of hardware. I recall that there are existing bug reports regarding the rt61pci driver. You might want to browse through them and see if you issue has already been reported. Then maybe just subscribe yourself to the report and add any additional useful information (like the latest version of the kernel you're experiencing this on etc). Thanks!

Changed in linux-source-2.6.24:
status: New → Invalid

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.