long Feisty boot time (boot pauses at scsi_eh_1 and modprobe)

Bug #115915 reported by huffylinux on 2007-05-21
2
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

Howdy. I upgraded to 7.04 (Fiesty Fawn), and boot has about a 30 second delay. I have already tried the irqpoll and network solutions.

I posted my bootchart (2 posts below this one).

I don't know how to correlate the time in bootchart to the time in dmesg. Anyway, the pause usually happens near the ata section, but there are no errors there:

[ 20.554306] input: Logitech USB-PS/2 Optical Mouse as /class/input/input2
[ 20.554445] input: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:1d.1-1
[ 20.554567] usbcore: registered new interface driver usbhid
[ 20.554611] drivers/usb/input/hid-core.c: v2.6:USB HID core driver
[ 50.047951] ata2.00: ATAPI, max UDMA/66
[ 50.047998] ata2.01: ATAPI, max MWDMA2
[ 50.048043] ata2.00: limited to UDMA/33 due to 40-wire cable
[ 50.211722] ata2.00: configured for UDMA/33

Here is a link to a forum thread about this problem if it helps:
http://ubuntuforums.org/showthread.php?p=2689252#poststop

Thanks for any help,
Eric

huffylinux (huffylinux) on 2007-05-21
description: updated
huffylinux (huffylinux) on 2007-05-21
description: updated
huffylinux (huffylinux) wrote :

Here's my bootchart. I finally saw the link to attach.

description: updated
description: updated
huffylinux (huffylinux) wrote :

I noticed that my my old CD writer ( an Iomega ZIp ) wasn't showing up, so I unhooked it and now the boot pause is gone.

scsi_eh_1 must have been waiting unsuccessfully to talk to it?

I was planning on unhooking that thing anyway, so for me this solution is fine.

I'm attaching my new bootchart so people can compare.

Ben Collins (ben-collins) wrote :

Thanks for the report. Probably not much we can do to fix this.

If you still have the hardware, and are willing to retest, please do so with Gutsy Gibbon Tribe-2 or newer. If it still occurs, please add an "Also Affects" for linux-source-2.6.22.

Thanks

Changed in linux-source-2.6.20:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers