feisty kernel 2.6.20 will not boot on Dell Dimension C521 (AMD64) since -12 prerelease

Bug #113567 reported by Gavin McCullagh on 2007-05-09
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

This bug was previously reported within 106063 but seemed to get lost in amongst another bug which was not really a duplicate:

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/106063

I am re-reporting to see if I can draw attention to it.

When running feisty beta (kernel 2.6.20-13-generic) last March all was fine. Then a new kernel image was released (2.6.20-14-generic) and I could no longer boot. At the time, I continued using 2.6.20-13-generic without issues. I tried 2.6.20-15-generic which still didn't and doesn't work.

My hard disk died recently and I couldn't install feisty as the iso images won't boot. I had to install edgy and upgrade but am still using 2.6.17 kernel. My guess is that this machine is fairly widely sold by Dell and it just won't boot Ubuntu Feisty.

dmesg, lspci, boot errors etc are on these comments on the previous bug.

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/106063/comments/19
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/106063/comments/23
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/106063/comments/27
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/106063/comments/94

It might or might not be a coincidence but since reinstall, I've noticed that only one of the two edgy kernels will boot. So, I have linux-image-2.6.17-11-generic and linux-image-2.6.17-10-generic and only the -10-generic is bootable. It's possible I didn't try the -11- in edgy before as I was already using feisty.

Segendorff seems to see this as well

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/106063/comments/98
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/106063/comments/99

If anyone knows of a place I can get a 2.6.20-13-generic kernel image package it would be great as there are some bugs in the 2.6.17 which were fixed by it.

Gavin McCullagh (gmccullagh) wrote :

actually, the title should be

"feisty kernel 2.6.20 will not boot on Dell Dimension C521 (AMD64) since -13 prerelease"

I may have similar problem. I have a Dell Inspiron D600.
I can boot the kernel 2.6.9 but with 2.6.15 the laptop cannot boot.
Simply shows the kubuntu loading screen showing no progress.
If I go to VT1, there are just the very first 2 lines after selecting the kernel in grub, saying the system is starting.
No error messages.

If I try the 2.6.15 in "safe mode" the kernel starts, but when booting hungs it seems when checking some usb HW.

Gavin McCullagh (gmccullagh) wrote :

I'm more than a little embarrassed to say this but, I've just got it to work by adding a single kernel option:

     noapic

I can't believe I didn't try this before, sorry. So, the Dell Dimension C521 needs noapic as a boot option.

=== strange 2.6.17 + feisty SSL issues===

In case a developer is reading this, an interesting side point is that while 2.6.17 was running, firefox had tremendous issues with SSL. This was really strange. So for example, every other launchpad page would fail with "the connection was reset" as the error. A tcpdump showed my own machine sending out tcp resets immediately for most of the connections it started. By contrast, if I tried to download a page directly using the openssl command line, this worked totally reliably, as did w3m. Only firefox had the problem, presumably because firefox has its own SSL implementation. This was only seen with 2.6.17 + feisty and seems to be gone now with 2.6.20.

I also found what was my issue.
I reinstalled the linux-image package for the 2-6-20.15 kernel and now it boots fine.
It seems that in the first installation the kernel vmzlinux boot image was corrupted.

In the Dell D600 laptop model I didn't need to use the "noapic" option when booting the kernel.

It seems that this was not a bug in my case.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Michele Mangili (mangilimic) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers