Ubuntu

strange behavior and system hangs after a few minutes after resume form hibernation on hp compaq nx7400

Reported by lmierzej on 2007-04-27
12
Affects Status Importance Assigned to Milestone
Linux
Expired
Medium
linux (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Swistak
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Swistak

Bug Description

I have HP Compaq nx7400 (Core 2 Duo, Intel GMA 950 graphics card).

After resume from hibernation every thing seems to work just fine,
but after a few moments strange things begun to happen:
-sometimes the system just hangs;
-sometimes only gnome stops responding (I can switch to console or log in by ssh from another machine);
-sometimes gnome doesn't stop responding but gnome applications like terminal or totem doesn't launch anymore
(surprisingly mplayer or eclipse work just fine, only "native" gnome applications are affected);
-once after resume from hibernation I saw a notification which said about HAL problems (I can't recall exact error);
-usually after resume from hibernation when I try to 'sudo /etc/init.d/gdm restart' everything just hangs,
but once when I tried to 'sudo /etc/init.d/gdm restart', just before system hung I saw this: "[869.11600] BUG: soft lockup detected on CPU#0!";
-sometimes only one gnome applications hangs (when it hung I couldn't launch any other gnome application, but once more mplayer and eclipse worked fine),
last time gnome-gnuchess hung and when I tried to 'killall gnome-gnuchess' it didn't kill it and ps output showed gnome-gnuchess as 'defected' process

Please, could someone give me some instructions what can I do to locate real source of the bug?

Johnathon (kirrus) wrote :

Thanks for the report, I'll see if I can help. Firstly, can you check in your /var/crash/ folder for any log files relating to this problem. Also, once its appeared, can you check in the system logs (System > Administration > System Logs) to see if there is anything listed in any of them? If there is, can you attach/upload the log file to this report please?

lmierzej (lmierzej) wrote :

Thank you for your help!

I did a few more hibernation tests. Unfortunately /var/crash/ is always empty,
but once something new appeared in /var/log/messages (attached below,
usually /var/log/messages doesn't show anything strange).

As always, after resume from hibernation for a few moments everything seems fine,
but strange things begun to happen with time (most often gnome just hangs,
keyboard and mouse stop responding, but I can login via ssh from another machine
and then if I try to 'sudo /etc/init.d/gdm restart' everything hangs).

I'm running feisty.

Johnathon (kirrus) wrote :

Brilliant, it's a Kernel problem :)

Right, lets drill down a bit.

Please can you post the following additional information, (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at http://wiki.ubuntu.com/KernelTeamBugPolicies. Thanks in advance!

Johnathon (kirrus) wrote :

If you can, can you run the dmesg command straight after you've resumed, and have started to see the problems?
If gnome crashes, you should be able to get into a terminal by pressing Ctrl - Alt - F1. Gdm is on F7, and there is terminals on F1 - F6.

Thanks!

lmierzej (lmierzej) wrote :

'uname -a' output:
Linux owl 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

lmierzej (lmierzej) wrote :
lmierzej (lmierzej) wrote :
lmierzej (lmierzej) wrote :

I tried to prepare 'dmesg' output just after resume.
After resume I have started a few gnome application and everything started to behave strangely
(gnome hung), then I switched to console and
I've managed to do 'dmesg > dmesg_after_hibernation_when_problems_start'
and checked that file was created. Then I invoked 'killall Xorg' and everything have totally frozen.
After reboot there was no file 'dmesg_after_hibernation_when_problems_start'!!! The file vanished!
It was there I checked, I did 'cat dmesg_after_hibernation_when_problems_start' and saw the output,
but after reboot the file was gone...

Now I will log through ssh from another machine and I will copy the 'dmesg' output just after problems start.

lmierzej (lmierzej) wrote :

After creating 'dmesg_after_hibernation_when_problems_start' and coping it to another machine
via ssh (I'm sure the file will vanish after reboot of source machine), I invoked 'killall Xorg"
and then system totally hung (keyboard stopped responding, can't log in via ssh). A few
seconds after this total freeze I saw on the console this:
'[969.936000] BUG: soft lockup detected on CPU#0!'

Thank you very much for your help!
If there is anything else I could do... I would be glad to do it!

lmierzej (lmierzej) wrote :

I did a few more tests. Every time when gnome hangs and I switch to console
and I try to kill Xorg, just after trying to kill Xorg, system totally hangs
and 'BUG: soft lockup detected on CPU#0!' message appear on console.

I didn't manage to reproduce 'vanishing files' effect. But I could
swear that when after resume from hibernation I created file
with 'dmesg' output for the first time,
after reboot it disappeared...

Johnathon (kirrus) wrote :

Thanks for your report. I'm now moving this to the kernel team and confirming, hope this is the right place.
This is the end of the help I can give you with this bug. I would recommend, that you reboot your computer when this bug appears, with the command "sudo shutdown -r now".
Kind Regards, Johnathon

Johnathon (kirrus) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → nobody
status: Confirmed → Incomplete
Swistak (swistakers) wrote :

I confirm the same behaviour on my HP nx6310. It happens on Ubuntu 7.10 and Kubuntu 8.04 beta.
Where can I find this bug in kernel.org bug tracker?

Swistak (swistakers) on 2008-05-06
Changed in linux-source-2.6.20:
assignee: nobody → canonical-kernel-team
Swistak (swistakers) wrote :

Still present in Ubuntu 8.04 final and easy to reproduce. Can anyone get down to it?

Johnathon (kirrus) wrote :

With another person actively replicating this bug, I'm returning it to Confirmed. Its still a problem :)

Changed in linux-source-2.6.20:
status: Incomplete → Confirmed
Swistak (swistakers) wrote :

I attach some logs. This time system hung just after resume. Previously it gave me ~5 minutes of normal work.
I reported this bug in kernel bug tracker: http://bugzilla.kernel.org/show_bug.cgi?id=10609

Same for me. How can I help?

Swistak (swistakers) wrote :

Well, you can check if 2.6.25 fixes problem for you as it does for me. I can send you a deb package if you don't want to compile by yourself.
What hardware have you got?

I'd like to do it by myself. What steps should I do then?

Swistak (swistakers) wrote :

Basically follow: http://ubuntuforums.org/showthread.php?t=43065
Additionally:
run: sudo make oldconfig before doing make xconfig or make menuconfig (this copies current kernel configuration)
disable "kernel debugging" in "kernel hacking" section (this makes deb package ~18MB instead of 200MB)
use: sudo make-kpkg --initrd --append-to-version=-custom1 kernel_image kernel_headers
to compile the kernel instead of command suggested in the thread I mentioned. This will make the kernel boot properly. Besides kernel-headers package will be made.
Expect sound, wifi etc. to be broken after booting the new kernel. Some modules available in ubuntu kernel are not compiled unless you enable them in configuration.

With vanilla 2.6.25 kernel all resume/suspend problems go away. Tnx for help.

Swistak (swistakers) wrote :

You probably meant "resume/hibernation". Suspend to ram works fine on both kernels.
Is it really 100% trouble free? On my system 2.6.25 vanilla fixed hang ups that happen after resume from hibernation. However there are other problems e.g. the system doesn't shut down (the resumed one).
Did you do some special kernel configuration?

I have no such problem. I used vanilla linux-2.6.25.2.tar.bz2 tarball, copied /boot/config-2.6.24-16-generic to .config, made make oldconfig (just pressed Enter on all the questions), then built it - and here it is!
I think the difference maybe be the result of our different nx7400 configuration. I have a Pentium M version, not Core Duo processor in it.

Changed in linux-source-2.6.20:
assignee: canonical-kernel-team → ubuntu-kernel-team

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

Changed in linux:
status: Unknown → In Progress

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Swistak (swistakers) wrote :

I installed kernel-2.6.27-2 on my Kubuntu 8.04. It doesn't fix the problem at all. Additionally other problems are introduced. The computer doesn't switch off after RAM contents are stored on HD. Instead the fan starts spinning at full speed. After resume the system hangs.

Changed in linux:
status: Incomplete → Confirmed

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Johnathon (kirrus) wrote :

Is this still a problem for you in Intrepid or Jaunty?

Changed in linux:
status: Confirmed → Incomplete
Swistak (swistakers) wrote :

It's still a problem on latest kernels 2.6.29 and 2.6.28. Please refer to http://bugzilla.kernel.org/show_bug.cgi?id=10609

Johnathon (kirrus) wrote :

Argh, sorry, should have checked there. Leaving alone :)

Changed in linux:
status: Incomplete → Confirmed
Changed in linux:
status: In Progress → Invalid
Johnathon (kirrus) wrote :

The bug report was rejected upstream, due to lack of response from the bugs reporter.

Changed in linux:
status: Invalid → Expired
Changed in linux:
importance: Unknown → Medium

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.