Ubuntu

Speakers play even with headphones in on Sony Vaio Intel-HDA

Reported by Hornett83 on 2007-04-26
2
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Medium
Brian Murray

Bug Description

Binary package hint: linux-source-2.6.20

Hello,
I have a Sony Vaio VGN-C1Z/B. It uses the intel-hda module to play sound. Unfortunately when I plug headphones in, sound continues to play from the internal speakers!

I tried manually setting a few ids as per the Ubuntu Wiki page on intel-hda, I also tried the latest version of alsa directly from their site, no change either.

Always this in dmesg:

hda_codec: Unknown model for ALC262, trying auto-probe from BIOS...

In alsamixer, I am able to manually mute just the speakers, but this should happen when headphones are plugged in.
I don't really think there should be two separate controls there anyhow.

Cheers

Hornett83 (hornett83) wrote :
Hornett83 (hornett83) wrote :
Hornett83 (hornett83) wrote :
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please any missing output requested at https://help.ubuntu.com/community/DebuggingSoundProblems ? Thanks in advance.

Changed in linux-source-2.6.20:
assignee: nobody → brian-murray
status: Unconfirmed → Needs Info
Hornett83 (hornett83) wrote :

Yes no problem. :)

Hornett83 (hornett83) wrote :
Hornett83 (hornett83) wrote :
Hornett83 (hornett83) wrote :

Thanks!

Changed in linux-source-2.6.20:
assignee: brian-murray → ubuntu-audio
importance: Undecided → Medium
status: Needs Info → Confirmed
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug does not meet the criteria for a stable release update and is being marked as Won't Fix for this particular version of the kernel. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates .
However, the issue that you reported is one that should be possible to test with the live environment of the Desktop CD of the development release - Gutsy Gibbon. It would help us greatly if you could test with it so we can work on getting it fixed in the actively developed kernel. You can find out more about the development release at http://www.ubuntu.com/testing/ .
If you do decide to test with the development release of Ubuntu please comment on this bug report and include at least the minimal information requested at http://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help.

Changed in linux-source-2.6.20:
assignee: ubuntu-audio → brian-murray
status: Confirmed → Won't Fix
Hornett83 (hornett83) wrote :

Sorry I got tired of this and got it fixed upstream. Thanks anyway.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers