after upgrade to 7.04 wifi usb nic does not associate to AP

Bug #110134 reported by nil_pt on 2007-04-26
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Baltix)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Brian Murray

Bug Description

after upgrade from ubuntu 6.10 to 7.04 or even after clean install from live CD ubuntu 7.04 my wifi usb nic does not associate anymore to the router AP. I think the driver is at76c50x, and nic does not associate using 128bit (40) WEP key to my AccessPoint which have an SSID broadcast disabled.

Wifi Usb nics: Linksys WUSB11 v2.6, and topcom xplorer 3500
Access Point: Linksys BEFW11S4 V2, Firmware Version 1.45.10, Apr 15 2004 WEP key 128 Bits.

The AP does not support WAP but Wifi usb nics works fine with ubuntu 6.06 and 6.10 instalations from downloaded iso live/install CDs (without making updates).

nil_pt (nil-pt) on 2007-04-26
description: updated
nil_pt (nil-pt) on 2007-04-26
description: updated
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

fwheeler_1 (fwheeler-1) wrote :

Hi nil_pt- It looks like your bug report is going forward more quickly than mine (you left a comment a day or two ago). Are you going to be able to send the info asked for by Mr. Murray? Unfortunately, I replaced Feisty with Edgy since the WUSB 11 v. 2.6 work great with it and I need to use the computer on a daily basis. If I hadn't done that, I'd be glad to chip in with the required files. --Fw

nil_pt (nil-pt) wrote :

Hi,
here you have some logs I save today.
I took a look at Brian request, and today I did os updates to ubunto.e.e.6.10 installed yesterday. I was kind of afraid to loose wifi again, but its still there after all updates have finished. Although after all updates have finished a strange behavior to gnome, the top menu shown only the net icon and all other icons and menus have disappeared, also the bottom taskbar did only show waste basked although I had several text-editors open and minimized I could only access them trough alt+tab. I had to go to tty1 to login and be able to shutdown.
Anyway after re-boot uee.6.10 was now showing normal top and bottom gnome ubunto look, and better yet wifi was still working.
Then I run uff.7.04 livecd to collect requested files and surprise, after changed to my ssid and wep key, the usb nic associated to a neighbors AccessPoint apparently it is open.
Then I installed uff.7.04 to an available hd partition (to dev/sda6 (hd0,5)), but no luck in having access to my own AP. Still the neighbor's AP was more appealing to ubuntu, but after new configuration to my own ssid and wep keys, now iwconfig shows correct my ssid but it was not able to associate to it.
By the way, at the last step of install of uff.7.04 I think the install program should had ask me if I wanted to have a new location to grub, but no, grub have been just newly installed to dev/sda6 instead of updating already available grub menu.lst available in uee.6.10 partition in dev/sda5 (hd0,4).

Good luck with attached logs, and thanks in advance.
Best regards, nil_pt

Aaron Lebahn (cplusplus328) wrote :

I already posted in another similar bug, but I want this solved so I am puting info here also.

uname -a:
Linux R2-D2 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

Aaron Lebahn (cplusplus328) wrote :
Brian Murray (brian-murray) wrote :

c_plus_plus it is not clear to me what wireless card you have. If you do not have one that uses the at76 driver please don't comment on this bug. Thanks.

Changed in linux-source-2.6.20:
assignee: brian-murray → ubuntu-kernel-team
importance: Undecided → Medium
status: Needs Info → Confirmed

I also have a Linksys WUSB11 v2.8 using the atmel boards and using the at76c503a drivers, and connecting with 64bit Hex WEP codes. I have the same issues of using the card extensively (connecting to a lot of connections in a short period of time) or downloading a lot of stuff i get kernel panic

drink (martin-espinoza) wrote :

I have linksys wusb11 2.6 (at76 driver) and it is also not working. errors follow

[ 5083.260000] usb 1-1: new full speed USB device using uhci_hcd and address 9
[ 5083.412000] usb 1-1: configuration #1 chosen from 1 choice
[ 5083.540000] ubuntu/wireless/at76/at76c503.c: firmware version 1.101.2 #84 (fcs_len 4)
[ 5083.540000] ubuntu/wireless/at76/at76c503.c: device's MAC 00:06:25:08:05:bc, regulatory domain FCC (U.S) (id 16)
[ 5083.540000] ubuntu/wireless/at76/at76c503.c: registered wlan0
[ 5086.112000] ubuntu/wireless/at76/at76c503.c: 2522: assertion dev->istate == INIT failed
[ 5086.840000] ubuntu/wireless/at76/at76c503.c: unexpected dev->scan_runs 4
[ 5087.584000] ubuntu/wireless/at76/at76c503.c: 1784: assertion dev->curr_bss == NULL failed
[ 5092.984000] ubuntu/wireless/at76/at76c503.c: 1784: assertion dev->curr_bss == NULL failed
[ 5097.984000] ubuntu/wireless/at76/at76c503.c: 1784: assertion dev->curr_bss == NULL failed
[ 5102.988000] ubuntu/wireless/at76/at76c503.c: 1784: assertion dev->curr_bss == NULL failed

ad infinitum

drink@horizon:~$ lsusb
Bus 001 Device 009: ID 077b:2219 Linksys WUSB11 V2.6 802.11b Adapter
drink@horizon:~$ uname -a
Linux horizon 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

Just for the record, eh?

Used to work on edgy. Card was good last time I used it. Couldn't get it to work with ndiswrapper either, so here I am looking for (And finding) bug reports. I used it on my iOpener once, too.

goman (shoreflight) wrote :

Brian,
Hoping to help, and not hinder, I am attaching lspci-vvnn.log with respect to a Netcomm Wireless USB (NP7042) which also uses at76c503a and works fine in 6.06 but not in 7.04. (Also, the adapter seems to be fairly well recognised in the device manager in 6.06 but not in 7.04).
To give you a bit of an idea of my environment I have two HDD's in caddies that I swap in and out of the same PC. The adapter works in 6.06 but not in 7.04
(I have created the lspci, dmsg, version and uname logs for both versions on the same machine if you want them)

Cheers

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug does not meet the criteria for a stable release update and is being marked as Won't Fix for this particular version of the kernel. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates .
However, the issue that you reported is one that should be possible to test with the live environment of the Desktop CD of the development release - Gutsy Gibbon. It would help us greatly if you could test with it so we can work on getting it fixed in the actively developed kernel. You can find out more about the development release at http://www.ubuntu.com/testing/ .
If you do decide to test with the development release of Ubuntu please comment on this bug report and include at least the minimal information requested at http://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → brian-murray
status: Confirmed → Won't Fix

This problem makes me very sad, because it affects both my PCMCIA NIC and my
USB NICs - but I MUST get the USB version going or buy more hardware in
order to share my [pathetic] network connection at home. I'm on a very poor
modem connection (~26.4k and very unreliable) and I'm generally not even
doing updates. If someone mailed me a CD I'd be willing to test it, I guess
- so long as I could do it from the LiveCD. If anyone is interested in
sending me a recent image, drop me a line at my posted address. Thanks.

Przemek K. (azrael) on 2009-11-20
Changed in linux-source-2.6.20 (Baltix):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints