After hibernate there is total loss of sound

Bug #109978 reported by Cornel Cofaru on 2007-04-25
14
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

Version information:
  Kubuntu 7.04 final
`Hardware information:
  TOSHIBA L20-102 Laptop
  Intel 915gm chipset
  snd_intel_8x0 kernel module used for sound.

After resuming from hibernate there is no sound but apparently nothing is wrong (no errors reported, modules all loaded, media players are unaware of any problem).

Michael Broadbent (mikebro) wrote :

Thank you for taking the time to report this bug to help make Ubuntu better.

Could you please include the information requested from https://help.ubuntu.com/community/DebuggingSoundProblems after you hibernate as separate attachments. Thanks.

Cornel Cofaru (zgornel) wrote :

Here are the files that describe the hardware/software context of the problem. I hope this helps and the problem gets solved pretty soon, it's kind of important, especially because a lot of people use hibernation.

isn't this a dupe of 25896 ?

Cornel Cofaru (zgornel) wrote :

It is not a duplicate of 25896 because of different kernel versions. The behaviour is however similar. The problem was SOLVED using 'uswsusp' for the hibernation. More info here (I followed only for the hibernate part): http://blog.paulbetts.org/index.php/2007/02/11/fixing-software-suspend-hibernate-with-uswsusp-in-ubuntu-feisty-and-edgy/

Tormod Volden (tormodvolden) wrote :

Would the sound come back after a sleep (suspend to RAM)?

Cornel Cofaru (zgornel) wrote :

Yes, suspend to RAM behaviour is normal. I am using now 'uswsusp' (User space software suspend) and everything works normally.

Tormod Volden (tormodvolden) wrote :

I really meant to ask if suspend-to-RAM brought back the sound after a suspend-to-disk took it away (using the normal, standard software suspend).

Cornel Cofaru (zgornel) wrote :

If I remeber well, it did not.

Nitinn (nacky-4-u) wrote :

Solution found friendss

double click on sound manager at panel
and
1. check device slected is alsamixer
2. CHeck all lines like MASTER,LINE IN ,HEADPHONES ,PCM are unmute .
   if dey are mute turn them to unmute
   mute = (X) cross sign below it
   unmute= no (X) sign will b dere
3. Your sound will b working perfectly fine

Tried on ACER TRAVELMATE 4603

any further solution contact me on <email address hidden>

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Michele Mangili (mangilimic) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers