IDE cdrom not recognized after upgrade from Ubuntu 6.10 to 7.04

Bug #109706 reported by Geerlof on 2007-04-24
10
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

When I disable the secondary IDE port in the mainboard BIOS system boots normal,

When not switched off it take about 5 minutes to boot the system.
CDROM is not recognized

Ubuntu device Database submission ID is: 7d2a344f993d43791db752cdb96fb9e9

Chris Burgan (cburgan) wrote :

Thanks for your bug report and helping to make Ubuntu better.

This bug was filed without a package. Moving it to linux-source-2.6.20

Olivier (olivier-lacroix) wrote :

you should boot in verbose mode to know what is going wrong.

to do so, hit the "e" key to edit the grub line and remove the words "quiet" and "splash" from the line where they both appear.

this modification will affect your boot only once.

you should be able to get more info on what delays the boot.

Geerlof (geerlof) wrote :
Download full text (6.3 KiB)

I enabled secondary IDE port again and found the system waiting for response of the secondary IDE port. Trying to reset it again and again and finally boots but does not recognize the CDROM drive.

System log attached below

Apr 26 17:14:06 geerlof-desktop kernel: [ 40.622841] intel8x0_measure_ac97_clock: measured 54807 usecs
Apr 26 17:14:06 geerlof-desktop kernel: [ 40.622850] intel8x0: clocking to 48000
Apr 26 17:14:06 geerlof-desktop kernel: [ 54.099780] ata2.00: qc timeout (cmd 0xa0)
Apr 26 17:14:06 geerlof-desktop kernel: [ 54.099808] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
Apr 26 17:14:06 geerlof-desktop kernel: [ 54.099815] ata2.00: (BMDMA stat 0x25)
Apr 26 17:14:06 geerlof-desktop kernel: [ 54.099829] ata2.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x12 data 254 in
Apr 26 17:14:06 geerlof-desktop kernel: [ 54.099833] res 51/51:03:00:12:00/00:00:00:00:00/a0 Emask 0x5 (timeout)
Apr 26 17:14:06 geerlof-desktop kernel: [ 61.100124] ata2: port is slow to respond, please be patient (Status 0xd8)
Apr 26 17:14:06 geerlof-desktop kernel: [ 84.104044] ata2: port failed to respond (30 secs, Status 0xd8)
Apr 26 17:14:06 geerlof-desktop kernel: [ 84.104058] ata2: soft resetting port
Apr 26 17:14:06 geerlof-desktop kernel: [ 84.271092] ATA: abnormal status 0x7F on port 0x00010177
Apr 26 17:14:06 geerlof-desktop kernel: [ 84.435912] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x1)
Apr 26 17:14:06 geerlof-desktop kernel: [ 84.435923] ata2.00: revalidation failed (errno=-5)
Apr 26 17:14:06 geerlof-desktop kernel: [ 84.435932] ata2: failed to recover some devices, retrying in 5 secs
Apr 26 17:14:06 geerlof-desktop kernel: [ 89.437285] ata2: soft resetting port
Apr 26 17:14:06 geerlof-desktop kernel: [ 89.604308] ATA: abnormal status 0x7F on port 0x00010177
Apr 26 17:14:06 geerlof-desktop kernel: [ 89.933183] ata2.00: configured for UDMA/33
Apr 26 17:14:06 geerlof-desktop kernel: [ 89.933229] ata2: EH complete
Apr 26 17:14:06 geerlof-desktop kernel: [ 119.941299] ata2.00: qc timeout (cmd 0xa0)
Apr 26 17:14:06 geerlof-desktop kernel: [ 119.941326] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
Apr 26 17:14:06 geerlof-desktop kernel: [ 119.941334] ata2.00: (BMDMA stat 0x25)
Apr 26 17:14:06 geerlof-desktop kernel: [ 119.941347] ata2.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x12 data 254 in
Apr 26 17:14:06 geerlof-desktop kernel: [ 119.941351] res 51/51:03:00:12:00/00:00:00:00:00/a0 Emask 0x5 (timeout)
Apr 26 17:14:06 geerlof-desktop kernel: [ 126.941643] ata2: port is slow to respond, please be patient (Status 0xd8)
Apr 26 17:14:06 geerlof-desktop kernel: [ 149.945562] ata2: port failed to respond (30 secs, Status 0xd8)
Apr 26 17:14:06 geerlof-desktop kernel: [ 149.945577] ata2: soft resetting port
Apr 26 17:14:06 geerlof-desktop kernel: [ 150.112607] ATA: abnormal status 0x7F on port 0x00010177
Apr 26 17:14:06 geerlof-desktop kernel: [ 150.277429] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x1)
Apr 26 17:14:06 geerlof-desktop kernel: [ 150.277441] ata2.00: revalidation failed (errno=-5)
Apr 26 17:14:06 geerlof-de...

Read more...

templer666 (robert-wloch) wrote :

yeay,
finally i feel I'm at the right place with the troubles I encountered.
I posted already in great detail here:
http://ubuntuforums.org/showthread.php?p=2706945#post2706945

to sum it up:
on my notebook the dvd drive on the second channel disappears after the installation of kubuntu 7.07.
it's there when i boot the live system. funny thing is: the same applies for windows vista on the same machine.
i hope the stole code from open source, not the other way around.

to the post above I added a reply with to more mailing list entries I found. both of them point to a linux kernel problem on the module
ata_piix. previous versions of (k)ubuntu used the module piix.

I guess there is no fix for this yet, as I added this post about a month later than the previous one. however, this should get top priority as i does make the OS unusable.

regards,
robert wloch

Geerlof (geerlof) wrote :

Robert,

Problem also occurs when I boot the OS from CD. I changed my AOpen CD-ROM drive to a LiteOn CD-Writer that solved the problem for me, because my machine is a desktop. Original CD-ROM drive runs fine under Windows XP, I did not try Vista.
But I agree with you, that when you have to change hardware every update the OS is actually unusable. When you have a notebook you are really out of luck!
I think you are right the ata_piix module causes the problem, however there is no soft fix available right now. A hard fix is to change hardware as metioned above. For your situation a really HARD fix!

Regards,

Geerlof Rademaker

Geerlof (geerlof) wrote :

Today I installed the latest kernel patch Update Manager automatically brought to me.

I had to reboot and......

WOW my cd-rom drive was working!!!

Changed in linux-source-2.6.20:
importance: Undecided → Medium
status: Unconfirmed → Confirmed

The use of libata for PATA drives has been reverted in the latest kernel (2.6.20-16.28), due to this most people should find the piix driver is now used rather than the ata_piix driver.

Changed in linux-source-2.6.20:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers