Ubuntu

[Feisty] Kernel crashes in ext3 dx_probe - namei.c

Reported by nitrogen on 2007-04-23
34
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
High
Unassigned

Bug Description

Kernel crashes in ext3 dx_probe. "BUG at fs/ext3/namei.c:384! "

This bug has been reported with linux-image-2.6.20-15-generic (this bug #109177 and bug #122116) and with linux-image-2.6.20-16-generic (bug #120179). Bug #106830 misinterpreted this as a bug in "pan" -- but it is actually a kernel bug in handling a corrupt ext3 fs.

Reading a corrupt filesystem might trigger this bug (bug #122116). Could this be somehow related to ext3 filesystem corruption, bug #65815 Ext3 corruption on a drive), bug #53102 ext3 partitions are getting corrupt more often than they should, bug #66032 fsck.ext3: Unable to resolve, bug #118256 ext3 data corruption with kernel 2.6.20-16-generic?

nitrogen (i-am-nitrogen) wrote :
Download full text (3.3 KiB)

Report from dmesg:

[ 1169.106545] Assertion failure in dx_probe() at fs/ext3/namei.c:384: "dx_get_limit(entries) == dx_root_limit(dir, root->info.info_length)"
[ 1169.106578] ------------[ cut here ]------------
[ 1169.106580] kernel BUG at fs/ext3/namei.c:384!
[ 1169.106582] invalid opcode: 0000 [1] SMP
[ 1169.106585] CPU 0
[ 1169.106587] Modules linked in: binfmt_misc rfcomm l2cap bluetooth ppdev powernow_k8 cpufreq_powersave cpufreq_stats cpufreq_userspace cpufreq_ondemand cpufreq_conservative freq_table tc1100_wmi pcc_acpi sony_acpi dev_acpi video battery container sbs button i2c_ec dock ac asus_acpi backlight xfs nls_utf8 ntfs ext3 jbd mbcache ipv6 sbp2 lp fuse snd_intel8x0 snd_ac97_codec ac97_bus snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device nvidia(P) snd soundcore af_packet snd_page_alloc psmouse serio_raw parport_pc parport k8temp pcspkr shpchp pci_hotplug i2c_nforce2 i2c_core tsdev evdev reiserfs ide_cd cdrom ide_disk sg sd_mod amd74xx generic ata_generic usbhid hid ohci1394 ieee1394 floppy sata_nv ehci_hcd forcedeth libata scsi_mod ohci_hcd usbcore thermal processor fan fbcon tileblit font bitblit softcursor vesafb cfbcopyarea cfbimgblt cfbfillrect capability commoncap
[ 1169.106657] Pid: 7706, comm: find Tainted: P 2.6.20-15-generic #2
[ 1169.106660] RIP: 0010:[<ffffffff888dcf9e>] [<ffffffff888dcf9e>] :ext3:dx_probe+0x15e/0x2c0
[ 1169.106674] RSP: 0018:ffff81004c25fd38 EFLAGS: 00010296
[ 1169.106678] RAX: 0000000000000090 RBX: ffff810047287000 RCX: ffffffff8051bfc8
[ 1169.106681] RDX: ffffffff8051bfc8 RSI: 0000000000000082 RDI: ffffffff8051bfc0
[ 1169.106683] RBP: 0000000000000000 R08: 0000000000000000 R09: 0000000000000000
[ 1169.106687] R10: ffffffff805b7960 R11: ffffffff8027d6c0 R12: ffff81004822d338
[ 1169.106691] R13: ffff810047286d30 R14: 0000000000000000 R15: ffff81004c25fd88
[ 1169.106695] FS: 00002ac3eca086f0(0000) GS:ffffffff8054e000(0000) knlGS:00000000f7521b10
[ 1169.106698] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
[ 1169.106701] CR2: 00000000034c8330 CR3: 00000000599ec000 CR4: 00000000000006e0
[ 1169.106704] Process find (pid: 7706, threadinfo ffff81004c25e000, task ffff810049b57100)
[ 1169.106707] Stack: ffff81004c25fdd4 ffff810050e6f580 0000000000000000 ffff810047286d30
[ 1169.106715] ffff810047286d30 0000000000000000 ffff81004daa79c0 ffffffff888de37b
[ 1169.106721] ffff810050e6f5a8 000000007cdc7180 0000000000000000 00000000ffffffe9
[ 1169.106726] Call Trace:
[ 1169.106740] [<ffffffff888de37b>] :ext3:ext3_htree_fill_tree+0xab/0x1d0
[ 1169.106749] [<ffffffff8020c770>] do_path_lookup+0x1b0/0x1e0
[ 1169.106762] [<ffffffff888d6174>] :ext3:ext3_readdir+0x1a4/0x530
[ 1169.106768] [<ffffffff8023cac0>] filldir64+0x0/0xf0
[ 1169.106773] [<ffffffff8021b237>] cp_new_stat+0xe7/0x100
[ 1169.106787] [<ffffffff8023cac0>] filldir64+0x0/0xf0
[ 1169.106793] [<ffffffff8023680b>] vfs_readdir+0x8b/0xe0
[ 1169.106801] [<ffffffff802dce6f>] sys_getdents64+0x7f/0xe0
[ 1169.106810] [<ffffffff8026111e>] system_call+0x7e/0x83
[ 1169.106820]
[ 1169.106822]
[ 1169.106822] Code: 0f 0b eb fe...

Read more...

Changed in linux-source-2.6.20:
status: Unconfirmed → Confirmed
nitrogen (i-am-nitrogen) wrote :

Marked as confirmed because of the similar bug entry mentioned in the first comment. If this is not in accordance with Ubuntu bug tracking policy, I apologize.

The problem is likely to be related to the use of an ext2 filesystem driver in Windows with an ext3 filesystem using the dir_index option. The ext2 filesystem drivers available for Windows seem to corrupt the directory indices when -O dir_index is enabled (which is a bug in those drivers). However, the ext3 driver in the kernel should detect the corruption and rebuild the directory index (which is the bug being reported here). This is just a hypothesis, but is supported by evidence from past usage with past kernels on other systems, and the disappearance of problems when -O dir_index was disabled using tune2fs.

nitrogen (i-am-nitrogen) wrote :

System information:

AMD Athlon 64 x2 CPU, nForce4-based motherboard. 64-bit version of Ubuntu Feisty, installed from beta, updated to latest available packages.

Andreas Simon (andreas-w-simon) wrote :

I have exactly the same issue on a dual-boot system where I also use the Ext2IFS 1.10c drivers under Windows.
BTW, the same issue happens with Knoppix 5.1.1.

I have the same problem, Machine boots up but nautilus won't start... I also use the Ext2IFS drivers in windows.
any way to fix the problem?

description: updated
description: updated
simon04 (simon-legner) wrote :

I got the same problem using Ubuntu 7.04, Ext2IFS of Win XP.

(temporary) fixed it doing the following steps:
* tune2fs -O ^dir_index (see above, man descripton: dir_index: "Use hashed b-trees to speed up lookups in large directories.")
* sudo touch /forcefsck (force fsck on next boot removing htable references)

Maybe Ext2IFS got a problem with these trees ...

Best regard, simon04

Scott (shatheruk) wrote :

Exact same error coming from the kernel.
and yes, I do have what is supposed to be a "ext2/3" file system mounter for my XP partition.

sandeen (sandeen) wrote :

I've fixed this, so that the kernel is more robust in the case of corruption caused by the windows driver.

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=3d82abae9523c33d4a16fdfdfd2bdde316d7b56a

-Eric

I'm marking this as tiraged as a patch is available.

Changed in linux-source-2.6.20:
status: Confirmed → Triaged
importance: Undecided → High
Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team

Hi All,

The patch in comment: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/109177/comments/8 is available in the Hardy Alpha kernel which is currently under development. It would be helpful if you could test the latest Hardy Alpha release: http://www.ubuntu.com/testing . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. We'll keep this report open against the actively developed kernel bug against 2.6.20 this will be closed. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.20:
status: Triaged → Won't Fix
Changed in linux:
status: New → Invalid

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Brad Figg (brad-figg) wrote :

This bug report is being closed because Feisty is no longer supported.

Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04. To reopen the bug, click on the current status, under the Status column, and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments