No Driver for Attansic Fast Ethernet L2

Bug #108298 reported by Jacopo Salvestrini on 2007-04-20
2
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
Nominated for Feisty by Jacopo Salvestrini
Nominated for Gutsy by Alessandro Gervaso
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
Nominated for Feisty by Jacopo Salvestrini
Nominated for Gutsy by Alessandro Gervaso

Bug Description

Binary package hint: linux-source-2.6.20

in Feisty and previous versions there is no driver for Attansic Fast Ethernet L2.
in bug #77725 i found a link to this driver.
i hope it will be supported in future kernel updates.
bye

Jacopo Salvestrini (jsidew) wrote :

please, can anyone more expert than me take a look on this bug report?

i have found i way to avoid the driver lack.
i have a laptop ASUS F5R with Ubuntu 7.04 and i've installed the windows xp drivers of the wired card via ndiswrapper.
in this way the system can recognize the wired card and finally access to the Internet.
curiously the system recognizes the network cards as follow:

--------
$ifconfig
lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:620 (620.0 b) TX bytes:620 (620.0 b)

wlan0 Link encap:Ethernet HWaddr 00:1A:92:69:31:5E
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
          Interrupt:18 Memory:feac0000-feb00000
$iwconfig
lo no wireless extensions.

eth0 IEEE 802.11b/g ESSID:"" Nickname:"Broadcom 4311"
          Mode:Managed Access Point: Invalid
          RTS thr:off Fragment thr:off
          Link Quality=0/100 Signal level=-256 dBm Noise level=-256 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

wlan0 no wireless extensions.
--------

thanks.

ciao

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers