Ubuntu

PC does not power down after shutdown or hibernate

Reported by zsquareplusc on 2007-04-09
46
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.20-14-generic

The PC does not shut off and i have to push and hold the power button for >4 seconds.
For hibernate (that basically works) it displays the message to power down in text mode. For normal shutdowns, it displays the ubuntu logo and progress bar.

I have installed the AMD64 version of Feisty on a Intel Core 2 Duo system. uname -a:
Linux XXX 2.6.20-14-generic #2 SMP Mon Apr 2 16:32:46 UTC 2007 x86_64 GNU/Linux

Asus P5B-E Mainboard (http://www.asus.com/products.aspx?l1=3&l2=11&l3=307&model=1347&modelmenu=1)
- Intel® P965 chipsethange

Neil Durant (neildurant) wrote :

I'm seeing exactly the same problem, on Feisty with the 2.6.20-15-generic kernel (running SMP), on a Dell Precision 620 (dual Pentium III). After a fresh Feisty install it seemed to shutdown/reboot fine about 4-5 times, but now it's freezing at the "sending all processes the KILL signal" point. I've left it in this state for hours, and it gets no further, and I eventually have to reboot or do a hard shutdown (and upon reboot my ReiserFS partitions need their journals replaying).

Prior to re-installing Feisty, my machine got progressively less reliable with these hard power-downs, to the point where I couldn't boot up without having to run fsck manually from the super user mode.

I'd be very keen to see this fixed, or at least discover a suitable workaround in the meantime. I hate having to hard power-down every time I use the machine.

tallowwood (enmore) wrote :

Similar shutdown problem with fresh Feisty k install with the 2.6.20-15-generic kernel (and now -16) on Intel C2 6600 @ 2.40GHz ASUS P5B-E NVIDIA GeForce 8600 GTS.

dominik (dominik-holler) wrote :

 My Thinkpad T41 does not power off after shut down sometimes , und a PC (MSI K8T Neo2-f v2.0 + MSI GF 5200 FX nvidia driver, SATA HDD) sometimes, too. The strange thing is, that on PC most times Power off works, und on Thinkpad half and half.

plee (plee82) wrote :

Same here, Lastest release Feisty does not power down after shutoff. The only components that are power down are my mouse and keyboard.

dominik (dominik-holler) wrote :

last weeks shutdown works on my thinkpad und pc again,
posting this as a bug was helping ;-)

Manuel (msquarci) wrote :

Same problem here.
The PC does not shut off: it displays the Ubuntu logo and progess bar, then the keyboard and mouse are power down, but the PC remains on.
I can only push and hold the power button for 4 secs to shut off the PC.

I have no problem to restart the machine, only the shut off process doesn't work.

I'm running Feisty 7.04 on Intel Pentium IV 3,0GHz HT:
Asus P5GD1 PRO (http://www.asus.com/products.aspx?l1=3&l2=11&l3=24&l4=0&model=632&modelmenu=1) with the SpeedStep technology enabled.
nVidia Quadro FX 540

uname -a:
Linux XXX 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

dmitriyr333 (dmitriyr333) wrote :

I had this problem for approximately 3 months!!!
Its getting really annoying.
any solution would be greatly appreciated.

-Dmitriy

kmano8 (karl-shouler) wrote :

Also have this problem. New Feisty install as of last night... shut down worked 3 or 4 times maybe. After this, when I shut down it get through the splash screen with the progress bar, and hangs at the screen with the progress bar completely black (where I assume it's supposed to move to the next phase of the shut down).

I'm running Feisty 7.04 on Intel Pentium IV 3.0GHz HT and a nVidia 7600gt

-Karl

razor1394 (razor1394) wrote :

I'm also having this problem but Magic SYSRQ has been a real saver. It lets me reboot and then I'm able to power down during bios initiation. I have this problem on 2 machines. I think that either nvidia-drivers or Automatix is the cause. Both have nVidia cards with the nVidia driver. The cards are 6200TC 256MB and 6150. From what I've gathered adding these options to the bootline may help:

acpi=force vga=normal

I have not tried these however but will soon. If you don't know what Magic SYSRQ you really need to look it up on Wikipedia.

My machine (Compaq Presario), mentioned earlier in a duplicate bug, has
never been "blessed" with Automatix's presence and does not use NVidia
drivers. (Video is integrated Intel i810, processor is a Celeron...)

On 7/25/07, razor1394 <email address hidden> wrote:
>
> I'm also having this problem but Magic SYSRQ has been a real saver. It
> lets me reboot and then I'm able to power down during bios initiation. I
> have this problem on 2 machines. I think that either nvidia-drivers or
> Automatix is the cause. Both have nVidia cards with the nVidia driver.
> The cards are 6200TC 256MB and 6150. From what I've gathered adding
> these options to the bootline may help:
>
> acpi=force vga=normal
>
> I have not tried these however but will soon. If you don't know what
> Magic SYSRQ you really need to look it up on Wikipedia.
>
> --
> PC does not power down after shutdown or hibernate
> https://bugs.launchpad.net/bugs/104868
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Jim Sapp (jimslinux) wrote :

I had this problem on a old thinkpad using Mepis 6.5 and solved in KDE Control panel, login manager, then shutdown tab. then change /sbin/halt to /sbin/poweroff hope this works for some of you.

Olivier Berger (oberger) wrote :

I've had the same problem on my ASUS P4B mainboard computer.

It seems that acpi=ht is forced because this mainboard is present. This leads to acpi only be enabled until hyper-threading would be activated.

As my proc won't support hyperthreading, this is not usefull.

I found that only acpi=force would supercede this acpi=ht mode set by the kernel.

So far, adding acpi=force to grub's kernel command-line seems to solve this issue. I hope there won't be any side effects.

Hope this helps.

dominik (dominik-holler) wrote :

I suspect a Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 04) on my thinkpad t41, because the laptop dooes not power of after the use of wlan via /etc/network/interfaces

Sander de Leeuw (s-deleeuw) wrote :

I've had this problem for a long time, since Hoary I think, but I found a workaround recently. In my case, a kernel-module causes my 'Asus P5GDC Deluxe' not to power off. I don't know which one, though. Tried to blacklist all modules one by one, but gave up after booting over 10 times. Then I wrote a small script that just unloads all modules just before powering off.

Install:
sudo cp -v /path/to/rmmod-all /etc/init.d/
cd /etc/rc0.d
sudo ln -s ../init.d/rmmod-all S89rmmod-all

Remove:
sudo rm /etc/init.d/rmmod-all /etc/rc0.d/S89rmmod-all

ljrossi (ljrossi) wrote :

I try this S89rmmod-all but still the PC doesnt go off ( powers off ). I do have also P5GDC deluxe.

Could you describe your Bios settings (or version) and if you have any changes on the GRUB or wich is your grub settings.
Maybe I mees up something after 4 monthes trying to solve this issue.

What it supossed that this scripts does ? How can I know that it is really runing

Thanks

Julian

ljrossi (ljrossi) on 2008-04-29
Changed in linux-source-2.6.20:
status: New → Confirmed
freddy (freddy-zhagui) on 2008-07-27
description: updated
Alexander Rødseth (alexanro) wrote :

Resetting the BIOS to factory settings resolved this issue for me on one computer.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

copycat (info-pcxpert) wrote :

same here on a p5gdc deluxe.

The problem was already on dapper...I hoped the hardy 8.04.1 would solve it...but the issue stays.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Sander de Leeuw (s-deleeuw) wrote :

I installed the Intrepid Ibex yesterday. For me the new kernel version solved the issue!

Based on sole response from Sander de Leeuw that this was resolved for Intrepid, I'm marking this Fix Released. Thanks.

Changed in linux:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers