Ubuntu

Sound does not work for ATI SB450 HDA

Reported by tonetheman on 2007-04-05
16
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Low
Daniel T Chen

Bug Description

Sound does not work for toshiba satellite a135-s2276 in feisty
the sound does not work in feisty beta. i can boot the live cd for 6.10 and the sound works.

here is the lspci -nnv

00:14.2 Audio device [0403]: ATI Technologies Inc SB450 HDA Audio [1002:437b] (rev 01)
        Subsystem: Toshiba America Info Systems Unknown device [1179:ff00]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64, Cache Line Size: 32 bytes
        Interrupt: pin ? routed to IRQ 17
        Region 0: Memory at d0500000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000 Data: 0000

agcc@agcc-laptop:~$ sudo tail -2 /proc/asound/oss/sndstat
Mixers:
0: Generic 11c1 Si3054
agcc@agcc-laptop:~$ sudo amixer
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 224 [88%] [-6.20dB]
  Front Right: Playback 224 [88%] [-6.20dB]
Simple mixer control 'Caller ID',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Off-hook',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
agcc@agcc-laptop:~$

Daniel T Chen (crimsun) wrote :

Please attach /proc/asound/card0/codec*

tonetheman (tonetheman) wrote :

Here is some more info from proc asound

agcc@agcc-laptop:/proc/asound/card0$ cat codec#0
Codec: Generic 11c1 Si3054
Address: 0
Vendor Id: 0x11c11040
Subsystem Id: 0x11790001
Revision Id: 0x100200

agcc@agcc-laptop:/proc/asound/card0$ cat id
SB

agcc@agcc-laptop:/proc/asound$ cat modules
 0 snd_hda_intel

agcc@agcc-laptop:/proc/asound$ cat version
Advanced Linux Sound Architecture Driver Version 1.0.14rc1 (Tue Jan 09 09:56:17 2007 UTC).
agcc@agcc-laptop:/proc/asound$ cat cards
 0 [SB ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xd0500000 irq 19

Daniel T Chen (crimsun) wrote :

Please dist-upgrade to current Feisty.

Changed in linux-source-2.6.20:
importance: Medium → Low
tonetheman (tonetheman) wrote :

i usually take whatever the upgrade gui reports so this is what i just tried

agcc@agcc-laptop:~$ sudo apt-get dist-upgrade
Password:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

agcc@agcc-laptop:~$
agcc@agcc-laptop:~$ uname -a
Linux agcc-laptop 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

I can reinstall 7.04 beta on this laptop and do that also if you want to see if that helps. Or I could wipe it clean and reinstall 6.10 and
get some of the same info that we have already done

With the kernel 2.6.20-12 the sound works on this laptop (with an ATI SB450 card), but on newer revisions of the kernel, the sound doesn't work.

lspci -nnv:
00:14.2 Audio device [0403]: ATI Technologies Inc SB450 HDA Audio [1002:437b] (rev 01)
 · Subsystem: Samsung Electronics Co Ltd Unknown device [144d:c02b]
 · Flags: bus master, slow devsel, latency 64, IRQ 17
 · Memory at c0400000 (64-bit, non-prefetchable) [size=16K]
 · Capabilities: [50] Power Management version 2
 · Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-

acoster@acoster-laptop:~$ cat /proc/asound/card0/codec#1
Codec: Generic 11c1 Si3054
Address: 1
Vendor Id: 0x11c13026
Subsystem Id: 0x2117144d
Revision Id: 0x100700

cat on codec#3 is attached as it is too long.

I also have a satellite a135-s2276 and got the sound to work by following these directions
http://knowledge76.com/index.php/ALSA_1.0.10_Setup_on_Ubuntu_Breezy
for alsa-driver-1.0.14rc2 and alsa-lib-1.0.14rc2. Note I did not update any other software mentioned on that page just the driver and lib.

~$ tail -2 /proc/asound/oss/sndstat
Mixers:
0: Realtek ALC861-VD

description: updated

$ cat /etc/asound.conf ~/.asoundrc*
cat: /etc/asound.conf: No existe el fichero ó directorio
cat: /home/paula/.asoundrc*: No existe el fichero ó directorio

Attach files -> https://help.ubuntu.com/community/DebuggingSoundProblems
And change status of Need info to Confirmed

Changed in linux-source-2.6.20:
status: Needs Info → Confirmed
thiagomz (thiagomz) wrote :

I have the same erro on Satellite A105-S2051

thiagomz (thiagomz) wrote :
thiagomz (thiagomz) wrote :
thiagomz (thiagomz) wrote :

In my case, 6.10 live also works fine while 7.04 fails. I have realized lspci reports a different device:

Booting from a 6.10 CD, lspci reports:
00:14.2 Audio device: ATI Technologies Inc Unknown device 437b (rev 01)

While 7.04 reports:
00:14.2 Audio device: ATI Technologies Inc SB450 HDA Audio (rev 01)

There is also a relevant thread in the forum: http://ubuntuforums.org/showthread.php?t=415821

Regards,
Julian

TimMadden (timmadden) wrote :

I have this problem too. Originally, the volume indicator showed that there weren't any volume controls. If I went into the alsamixer, it only showed controls for the modem, offhook and callerid. I tried a work around for the forums involving sudo rmmod snd-hda-intel and then sudo modprobe snd-hda-intel probe_mask=8 model=3stack which gave me volume controls in the panel and alsamixer, but no sound from the speakers.

I will post output from "DebuggingSound...". And will patiently, quietly, wait for this bug to be squashed. :)

here are the first couple:

tim@tim-laptop:~$ tail -2 /proc/asound/oss/sndstat
Mixers:
0: Realtek ALC861-VD

tim@tim-laptop:~$ asoundconf list
Names of available sound cards:
SB

tim@tim-laptop:~$ cat /etc/asound.conf ~/.asoundrc*
cat: /etc/asound.conf: No such file or directory
cat: /home/tim/.asoundrc*: No such file or directory

TimMadden (timmadden) wrote :
TimMadden (timmadden) wrote :
TimMadden (timmadden) wrote :
TimMadden (timmadden) wrote :

OK, I have sound now based on a workaround in the forums. Here is what I did based on suggestion here:
http://ubuntuforums.org/showthread.php?t=415821&page=4

sudo modprobe snd-hda-intel probe_mask=8 model=3stack

instead of

sudo modprobe snd-hda-intel probe_mask=8 model=auto

I also did it in recovery mode straight off the grub menu as root instead of as my normal user.

I am not sure which did it the change to 3stack or the recovery mode... Not going to mess with it now that it is working!

TimMadden (timmadden) wrote :

Although, I should note, this only fixed the sound out, not the mic. Nothing there...

Steve Karg (steve-karg) wrote :

Adding the following line at the end of the /etc/modprobe.d/alsa-base file allows this workaround to be permanent.

options snd-hda-intel probe_mask=8 model=3stack

That worked for me to get sound working on a Toshiba A135-S2266 with Kubuntu 7.04 Feisty. I did not have to download and compile the newer ALSA drivers.

See also:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/88570

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers