acerhk module - add support for Amilo A1650g keyboard

Bug #84159 reported by damagedspline on 2007-02-09
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Colin Ian King
linux-source-2.6.17 (Ubuntu)
Undecided
Chuck Short

Bug Description

Binary package hint: linux-source-2.6.17

The keyboard on my laptop had a few buttons that were unrecognized.

I added functionality to the keys by adding some code to the acerhk module (now architectural changes - I only introduced a new model).

My laptop is a Fujitsu-Siemens (FSC) Amilo A1650g and using Ubuntu Edgy.

Now the display, wireless & cool-n'-quiet (fancy fan) buttons are properly recognized, but I haven't written the scripts that wrap the buttons yet.

In order not to compile the entire kernel I downloaded the latest code for acerhk (0.5.34) and modded it. The version of acerhk in the kernel is 0.5.31, should I still post the patch here?

Thanks for taking the time to report this bug. Unfortunately we can't fix it, because your description didn't include enough information.

Please include the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available here: <http://wiki.ubuntu.com/DebuggingKernelProblems> Thanks!

damagedspline (icpazi) wrote :

uname -a:
Linux asaf-laptop 2.6.17-11-generic #2 SMP Thu Feb 1 19:52:28 UTC 2007 i686 GNU/Linux

damagedspline (icpazi) wrote :

Sorry, about the split in messages...

damagedspline (icpazi) wrote :

this patch will 'retrieve' 3 missing buttons - display, fancy fan, and wireless - functionality for the button was added by scripts

Chuck Short (zulcss) on 2007-08-23
Changed in linux-source-2.6.17:
assignee: nobody → zulcss
John Tait (johntait1-waitrose) wrote :

The patch written by damagedspline also works for the Fujitsu Seimens Amilo Li 1718 which is a very popular model on sale at Tesco
and is crucial for less experienced users as it enables the wireless key on the laptop
Without this patch many users will be unable to use their laptop wirelessly with Ubuntu
I hope it can be included somehow in the hardware recognition during installation

It seems this patch is still not included in the current Hardy kernel which is actively being developed. If you can, please confirm this issue still exists in the Hardy Alpha release: http://www.ubuntu.com/testing and that the patch fixes this issue. We'll keep this open against the actively developed kernel but against 2.6.17 this will be closed as it does not qualify for a stable release update. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.17:
status: New → Won't Fix

This bug report is being closed because we received no response to the last inquiry for information. Please reopen it if this is still an issue in the current Ubuntu release. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks.

Changed in linux:
status: Incomplete → Invalid
damagedspline (icpazi) wrote :

I have just installed the final Hardy and the acerhk km version is still 0.5.34...
I opened this issue last year and still no progress.

Please refer me to instructions on how to commit fixes to the mainline Ubuntu's Intrepid Ibex kernel modules - I'll make it done.

Reopening and assigning to the kernel team to consider merging. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Invalid → Triaged
Changed in linux-ubuntu-modules-2.6.24:
assignee: ubuntu-kernel-team → colin-king
status: Triaged → In Progress
Colin Ian King (colin-king) wrote :

Patch now included in Intrepid

Changed in linux-ubuntu-modules-2.6.24:
status: In Progress → Fix Committed

Beginning with the Intrepid development cycle, the linux-ubuntu-modules package has been migrated into the linux kernel source package. I'm just moving this bug to the linux package. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.26-5.14

---------------
linux (2.6.26-5.14) intrepid; urgency=low

  [ Ben Collins ]

  * SAUCE: applesmc: Add MacBookAir
  * build: Do not build ddeb unless we are on the buildd
  * build: control: Consistency in arch fields.
  * SAUCE: Update toshiba_acpi.c to version 0.19a
    - LP: #77026
  * build: Added perm blacklist support and per-module support to abi-check
    - Blacklist p80211 module from abi checks
  * ubuntu/lirc: Get rid of drivers symlink and use real include stuff

  [ Colin Ian King ]

  * SAUCE: acerhk module - add support for Amilo A1650g keyboard
    - LP: #84159
  * SAUCE: rt2x00: Fix OOPS on failed creation of rt2x00lib workqueue
    - LP: #249242

  [ Mario Limonciello ]

  * Add LIRC back in

  [ Tim Gardner ]

  * Makefile race condition can lead to ndiswrapper build failure
    - LP: #241547
  * update linux-wlan-ng (prism2_usb) to upstream version 1861
    - LP: #245026

  [ Upstream Kernel Changes ]

  * Fix typos from signal_32/64.h merge

 -- Ben Collins <email address hidden> Fri, 01 Aug 2008 00:05:01 -0400

Changed in linux:
status: Fix Committed → Fix Released
damagedspline (icpazi) wrote :

Thanks!!! Verified to be solved.

Now one more thing to be fixed:
 /etc/modprobe.d/options << "option acerhk autowlan=1"

Which Package owns this file?

$ cat /var/lib/acpi-support/*-*
R01-A1I
FUJITSU SIEMENS
AMILO A1650G
-1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers