Can't copy VCD ".dat" files from CD to Hard Drive

Bug #82307 reported by Andrew Fenn on 2007-01-30
26
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
acpi
Invalid
Undecided
Unassigned
linux (Ubuntu)
Low
Unassigned
linux-source-2.6.17 (Debian)
Invalid
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Low
Unassigned
linux-source-2.6.22 (Ubuntu)
Low
Unassigned

Bug Description

I can't copy VCD ".dat" files (which seem to be avi files) off the VCD and on to my hard drive. I can copy them on to my windows partition (using windows) and then copy them from that to my Ubuntu partition though.

The problem seems to be getting them off the VCD in the first place.

The error i'm recieving is:

Error "I/O error" while copying "path/path/thevcdfile.dat"

This happens with every VCD I rent (around 12 disks now). Ubuntu should at least attempt to copy what is there.

Andrew Fenn (andrewfenn) wrote :

Here is a screenshot. Also can't copy using command line.

Brian Murray (brian-murray) wrote :

Thanks for your bug report. Could you include the output of dmesg when you are trying to copy the .dat file?

Andrew Fenn (andrewfenn) wrote :

Hi,

Could you give me more clear instructions on how to do that?

Thanks.

Brian Murray (brian-murray) wrote :

To get the output of dmesg you could do the following:

1) In a terminal type 'dmesg -c'. This will display kernel messages and clear the buffer.
2) Try to copy the .dat file from the VCD to wherever you want.
3) In a terminal type 'dmesg' to display the kernel messages. This will only show stuff relevant to when you were copying the .dat file.
4) Copy and paste that output into a comment on this bug

Thanks in advance.

Andrew Fenn (andrewfenn) wrote :

Included a file with my dmesg output

Brian Murray (brian-murray) wrote :

Thanks for you bug report however from the kernel error log (dmesg) it seems that this is most likely a hardware issue. Given the repetitive nature of the sector errors it may be with that media. Do you have the same issue with other VCDs? Additionally, which version of Ubuntu are you running?

Andrew Fenn (andrewfenn) wrote :

I'm using Ubuntu Edgy 6.10. My other laptops specs are here:

https://wiki.ubuntu.com/LaptopTestingTeam/SamsungR55

This happens with all VCDs (I have tried about 15 now) on Ubuntu. Like I said before I have to copy them in windows and then copy them to my Ubuntu partition.

Once they are copied to the hard drive I can copy them around fine. I just can't copy them off the CD in Ubuntu.

I have been able to copy every single one to the hard drive with windows xp and watch them in Ubuntu with this method.

Andrew Fenn (andrewfenn) wrote :

Updated the issue with my comments. Like I said I can copy them using windows xp. Once they are on my hard drive it isn't a problem. I don't think there is a problem with either the media or the hardware. Possibly a mis configured?

Rajeev Nair (rajeev) wrote :

same here

Andrew Fenn (andrewfenn) on 2007-04-17
description: updated
Rajeev Nair (rajeev) wrote :

Iam on feisty beta .

Also cant mount vcd properly .

Gnome -vfs not initialised error in gxine

Andrew Fenn (andrewfenn) wrote :

I believe that mounting the VCD is a different bug altogether compared to this bug.

I can see the VCD fine when I pop it in and can browse the directories fine but can not copy the media to my hard drive because of these IO errors. As I have said before windows XP can copy these discs without error.

Ali Sattari (corelist) wrote :

I have Exactly same problem on kernel 2.6.20-13.

Mine started happening on Feisty (Kubuntu and Xubuntu on 2 different partitions). Edgy and Dapper doesn't have any problems copying .dat files but Fiesty does. This issue is related to Bug #43589

Andrew Fenn (andrewfenn) wrote :

I disagree that it is related to bug #43589. Once the VCD is on my hard drive they play fine in all players.

My problem is specifically that I can not copy them from the CD. I have yet to test this in feisty so I will have to get back to you on if this problem still exists in the latest version.

Ben Collins (ben-collins) wrote :

That's because the files you see when you mount a VCD are not really the files that the players play. They read data from the CD in a raw format.

You have to use a tool to extract the mpg's from a VCD image. This is not a lacking of feature in the kernel, it's a detail of the VCD format.

Changed in linux-source-2.6.17:
status: Confirmed → Rejected
Ali Sattari (corelist) wrote :

Ben Collins,
This is a kernel issue, and confirmed as a bug in some other distros too (gentoo and suse tested and have the same problem).
I don't care if the files are video mpeg files or whatever else, when i mount CD i can't copy files or dump disk (using dd) as iso or any other operations, i can just see the file names via 'ls' command.

This is not related to vcd player issues.

Aha! now that's the confirmation I've been waiting for. I retract my previous comment then. But the thing is, I can copy any files from any CDs... except files from a Video CD. And this started happening in Feisty.

Andrew Fenn (andrewfenn) wrote :

If they are not really files then why:

- are they shown as files in both windows and Ubuntu?
- I can copy those files in Microsoft Windows to my hard drive?
- I can play those files in Ubuntu after I have copied them?

Andrew Fenn (andrewfenn) wrote :

Could you elaborate by answering the questions below as to why this isn't a bug or missing feature?

Changed in linux-source-2.6.17:
status: Rejected → Needs Info
assignee: nobody → ben-collins
Simos Xenitellis  (simosx) wrote :

I went by the LKML (linux-kernel mailing list) on this issue and I believe the answer for this precise issue (the issue of not being able to copy the DAT files, NOT the issue of playback of VCDs with gstreamer), is greatly summarised at

http://uwsg.iu.edu/hypermail/linux/kernel/0612.1/1351.html

Could someone (with a VCD disk and is affected) try out and report back?

Simos Xenitellis  (simosx) wrote :

Gstreamer comes with a plugin, cdxaparse, that parses a .dat file from (S)VCD into raw MPEG-1.

Reference: http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gst-plugins-bad-plugins/html/gst-plugins-bad-plugins-plugin-cdxaparse.html

Do gst-inspect-0.10 | grep -i vcd
to check if you have the plugin.

Andrew Fenn (andrewfenn) wrote :

I just tried a VCD on Fiesty.

I can't even see the VCD now. Its vanished.

Simos Xenitellis  (simosx) wrote :

Andrew: What changes did you do? On which comment do you refer to?

Andrew Fenn (andrewfenn) wrote :

I upgraded to feisty and put the CD into the tray.

Ali Sattari (corelist) wrote :

as a quick and dirty solution, try to install 'cdfs' module and mount vcd disks like this:

mount -t cdfs -o ro /dev/hdc /media/cdrom1/

then you can copy vcd tracks as .mpeg files easily.

Bogdan Butnaru (bogdanb) wrote :

I have a similar issue on Gutsy, but the errors are a bit different (see below). The disc plays with no glitches in a hardware player, but the .dat files can't be copied.

I can't find a cdfs package, only a cdfs-src but that doesn't build (under Gutsy, at least), I think it's made for a different kernel.

$ sudo dmesg
[68555.788000] end_request: I/O error, dev sr0, sector 5040
[68555.788000] printk: 22 messages suppressed.
[68555.788000] Buffer I/O error on device sr0, logical block 1260
[68555.788000] Buffer I/O error on device sr0, logical block 1261
[68555.788000] Buffer I/O error on device sr0, logical block 1262
[68555.788000] Buffer I/O error on device sr0, logical block 1263
[68555.788000] Buffer I/O error on device sr0, logical block 1264
[68555.788000] Buffer I/O error on device sr0, logical block 1265
[68555.788000] Buffer I/O error on device sr0, logical block 1266
[68555.788000] Buffer I/O error on device sr0, logical block 1267
[68556.704000] end_request: I/O error, dev sr0, sector 5040
[68556.704000] Buffer I/O error on device sr0, logical block 1260
[68556.704000] Buffer I/O error on device sr0, logical block 1261

If this error occurs near the end of the MPEG stream, then the MPEG stream would have played fine up to that point, and would not cause a problem with watching the film, however the actual file if copied will try every byte, and will fail on those at the end. This means that a disk manufacturer could deliberately specify such a file table as a trivial system to prevent people copying the file so easily. An MPEG stream ripper should still be able to get the data, but a straight file copy will fail.

Somewhat more insidious would be to insert bad blocks into parts of the file which playback of the mpeg will cause to be skipped - like a section of the header holds the offset for the first frame, or a frame for the next frame. Again - a stream ripper should also get around this.

One way to try to prove this might be to attempt, without copying, to load the files into a media player:
mplayer /media/cdrom/mpegav/avseq01.dat

If the errors are still there then it is something else.
I tried this on a VCD on my machine, and immediately when trying to copy a file the same error was shown - which suggests it is not the end of the file. I then tried to play the .dat file in mplayer, which also failed with "Seek Failed". So it must be something else.

Just to clear any idea that it might be specific hardware (which I doubt), it might be worth putting which drive hardware is being used. I am using an External USB2 LG DVD+-/RW Model 8SA-2164D.

If I try to make an image of the CD with dd:
dd if=/dev/scd0 of=/tmp/vcd.iso
dd: reading `/dev/scd0': Input/output error
0+0 records in
0+0 records out
0 bytes (0 B) copied, 2.4244 seconds, 0.0 kB/s

This response is nearly immediate.

Even with these results, It is possible that something is deliberately done to the VCD's file system to cause such errors to occur. However, the alternative proposed by Simos Xenitellis is now sounding more likely. Is there someone here willing to give that a go?

Changed in linux-source-2.6.22:
status: Unconfirmed → Confirmed
Brian Murray (brian-murray) wrote :

Bug 7460 at bugzilla.kernel.org seems similar to this.

I did a bit of testing with 2.6.22 on Gutsy with multiple VCDs and was never able to copy the .dat file off. My tests with multiple VCDs included:

1) In a desktop session after stopping hald-addon-storage
2) Booting into single user mode

Changed in linux-source-2.6.22:
importance: Undecided → Low
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
Changed in acpi:
status: Unknown → Confirmed
Andrew Fenn (andrewfenn) on 2007-06-20
Changed in linux-source-2.6.17:
assignee: ben-collins → nobody
status: Needs Info → Confirmed
VINU (vinaychandrac) wrote :

 I Cant copy some movie to my pc, if i copy the dat file and paste it to my drive, it will show that 20 minutes remaining, it will run for sometime and the time it was showing will start increasing to 30, 40, 120 like that, i think at some part of the film some scene will struck for 10 seconds, and again it will run properly, i dont want the scene that will got stuck, can i copy other scenes from the movie which is perfect.

please suggest me something, i am facing this problem daily.

Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.17:
assignee: nobody → ubuntu-kernel-team
Changed in linux-source-2.6.17:
status: New → Confirmed
jpv2 (jpv2) wrote :

It looks like elkanguro found method how to play VCD's (even if they can't be copied to disk) on Ubuntu. Just use SMPlayer to play VCD's. Works for me (on Ubuntu 7.10)

Original post can be found here (in Polish)
http://forum.ubuntu.pl/showpost.php?p=393101&postcount=7

Ntweat (hinduja-saurabh) wrote :

I am using Gusty and facing the same problem....

Kaffine can play the video perfectly... but cannot copy the cd...

i even tried making an image but K3B said cannot copy multiple track cd...

Then to test this i made a VCD with windows and tried copying that it did even K3B made the image...

According to me there is some problem in readying multiple track cds in linux

naufal (musp-student) wrote :

hello,
after a few work,now I can copy a .dat movie file. with these step:
1:Install the 'vcdimager' from synaptic
2:type in terminal:
vcdxrip and computer will copying the .dat file automatically to /home/user directory...

naufal (musp-student) wrote :

.dat file will be copied in .mpg format

Changed in acpi:
status: New → Invalid
Changed in linux:
status: Unknown → Confirmed
Brian Murray (brian-murray) wrote :

I've recreated this using kernel version Ubuntu 2.6.24-7.12-generic on Hardy Heron. The extract from '/var/log/messages' follows:

Feb 13 19:25:16 wonderwoman kernel: [ 772.058857] hda: command error: status=0x51 { DriveReady SeekComplete Error }
Feb 13 19:25:16 wonderwoman kernel: [ 772.058876] hda: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
Feb 13 19:25:16 wonderwoman kernel: [ 772.058883] ide: failed opcode was: unknown
Feb 13 19:25:16 wonderwoman kernel: [ 772.059323] end_request: I/O error, dev hda, sector 5028

This bug isn't worthy of a Stable Release update for kernels 2.6.22 or 2.6.17 so I am marking those as won't fix. It really would be quite helpful if someone were to work with upstream on this bug report if it is important to them.

Changed in linux-source-2.6.17:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Changed in linux:
importance: Undecided → Low

This most likely won't get resolved prior to the Hardy release. However we'll milestone this for a future release. As Brian mentioned, it would be great if any concerned parties would work with upstream to resolve this. Thanks.

Changed in linux:
milestone: none → later
status: New → Won't Fix

After speaking with the Ubuntu kernel team this report will be closed. As naufal pointed out, please use an application such as vcdxrip which is able to understand the file format. Thanks.

Changed in linux:
milestone: later → none
Andrew Fenn (andrewfenn) wrote :

Or perhaps you could just make it work when I copy files directly from the CD as the title of the bug report suggests?

Ben Collins (ben-collins) wrote :

Maybe you could look into the VCD image format and realize that it is not a filesystem in the sense you are thinking of. The "files" you see are merely references to actual data on the CD, and not meant to be copied around like mpg files. Otherwise there wouldn't be a need for vcd image tools (like vcdxrip and vcdimage).

As I believe I have said in previous comments on this very same bug report. If you can play the VCD, and use vcdxrip (or similar tools), then the kernel is reading the disk just fine. It does not, however, have support for VCD formats (which is different than ISO-9660).

So your request requires a new feature, not a "fix". This "feature" will not be implemented in Ubuntu at any point in time, unless some one goes out implements it and submits it to the upstream kernel.

Andrew Fenn (andrewfenn) wrote :

Ok, so there is a work-a-round which is having to use another program to rip the VCDs but since the original bug report is about copying them directly from the disk I feel this isn't fixed at all from a usability point of view and from the fact that it doesn't deal with my original problem.

If you view it as a missing feature then mark it as such, I would like it to be fixed though so others and I will not have problems copying their VCDs out of the box. If it requires leaving it marked as such in launchpad then fine, that's what a bug tracker is for.

In short, there is no need to close valid bugs. You might not see it as a bug, a user trying to copy his VCDs like they do in Windows XP will and won't be looking for a program. : )

Ben Collins (ben-collins) wrote :

I didn't close it as a non-bug, I closed it as Wont-Fix, which means I acknowledge that it is a missing feature, but that we wont put in the large effort needed to implement it. Copying MPG's from a VCD isn't a very common operation. Most people either play the VCD image directly from the hard drive or directly from the CD. Those are the common use cases and those use cases work.

IMO, a feature like this would be better implemented in the desktop, e.g. in nautilus. It does similar things for tar/zip/iso's. So even if I think it should be implemented, it's not going to happen in the kernel.

Changed in linux-source-2.6.17:
status: Confirmed → Invalid
Changed in linux:
status: Confirmed → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Niyas 628 (niyanar) wrote :

I'm not able to play any vcd on my drive. I think it is due to difficulty in reading the vcd format.
When I copied the file in to HD using windows it plays in ubuntu using vlc player.
But I can not do the same with in ubuntu..
What is the problem?
How can I fix it permenently and easily???

Changed in linux-source-2.6.17 (Ubuntu):
assignee: nobody → Niyas 628 (niyanar)
status: Won't Fix → Incomplete
Przemek K. (azrael) wrote :

Please don't reopen this task because it concerns Linux 2.6.17 which was the kernel in Ubuntu 6.10, which is unsupported (EOL) now.
Your problem is a separate issue and should be treated within a separate bug report.
Please consult the following page to report a new bug in a proper manner.
https://help.ubuntu.com/community/ReportingBugs

Changed in linux-source-2.6.17 (Ubuntu):
assignee: Niyas 628 (niyanar) → nobody
status: Incomplete → Invalid
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.