Ubuntu

HP NetServer LP1000R NetRaid (megaraid) panics

Reported by Данило Шеган on 2007-01-29
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
discover-data (Debian)
Fix Released
Unknown
linux (Ubuntu)
Medium
Unassigned
Declined for Jaunty by Andy Whitcroft
Declined for Karmic by Andy Whitcroft
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by Andy Whitcroft
Declined for Karmic by Andy Whitcroft

Bug Description

Binary package hint: linux-source

When using any of the install CDs (ubuntu-server 6.10, ubuntu-desktop 6.10) on HP NetServer LP 1000r, megaraid_mbox/megaraid_mm drivers crash at random point during installation (sometimes right at 'disk detection', sometimes in the middle of mke2fs step for partititons).

The solution seems to be to use megaraid.ko ("legacy megaraid" driver), but the problem is that it doesn't recognize the controllers as supported.

So, I used the patch from

  http://www.suseblog.com/?p=156

against 2.6.17-10-generic megaraid.c and megaraid.h, which allowed me to boot, partition, format and install Ubuntu on the system.

I'll attach a patch here for reference.

# ctwm
tag 44563 + upstream
# discover-data
retitle 109763 discover: no way to use one module name for kernel 2.2 and another for kernel 2.4
reassign 109763 discover
tag 109763 + upstream
tag 119372 + upstream
tag 119449 + upstream
tag 121496 + upstream
# read-edid
tag 102233 + upstream
# vtwm
retitle 57067 vtwm: during f.movescreen, virtual desktop gets messed up
retitle 112525 vtwm: TitlePadding does not work properly
retitle 113327 vtwm: focus does not reliably follow mouse pointer under X 4.1.0
retitle 120259 vtwm: Keystrokes vanish with Mozilla, some KDE apps
tag 57067 + upstream
tag 112525 + upstream
tag 113327 + upstream
tag 120259 + upstream
thanks

--
G. Branden Robinson | I had thought very carefully about
Debian GNU/Linux | comitting hara-kiri over this, but
<email address hidden> | I overslept this morning.
http://people.debian.org/~branden/ | -- Toshio Yamaguchi

We believe that the bug you reported is fixed in the latest version of
discover-data, which has been installed in the Debian FTP archive:

discover-data_1.2002.01.28-1.diff.gz
  to pool/main/d/discover-data/discover-data_1.2002.01.28-1.diff.gz
discover-data_1.2002.01.28-1.dsc
  to pool/main/d/discover-data/discover-data_1.2002.01.28-1.dsc
discover-data_1.2002.01.28-1_all.deb
  to pool/main/d/discover-data/discover-data_1.2002.01.28-1_all.deb
discover-data_1.2002.01.28.orig.tar.gz
  to pool/main/d/discover-data/discover-data_1.2002.01.28.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Branden Robinson <email address hidden> (supplier of updated discover-data package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Mon, 28 Jan 2002 02:11:58 -0500
Source: discover-data
Binary: discover-data
Architecture: source all
Version: 1.2002.01.28-1
Distribution: unstable
Urgency: low
Maintainer: Branden Robinson <email address hidden>
Changed-By: Branden Robinson <email address hidden>
Description:
 discover-data - hardware lists for libdiscover1
Closes: 119372 121496 130702 130799
Changes:
 discover-data (1.2002.01.28-1) unstable; urgency=low
 .
   * new upstream version
   * pci.lst:
     - added several new S3 graphics chipsets, including the "Twister K"
       (thanks, Chris Lawrence) (Closes: #119372,#130799)
     - added PCI ID for Hewlett-Packard NetRAID 2M card, which uses the AMI
       MegaRAID chips (thanks, Dann Frazier) (Closes: #121496)
     - added X server/driver information for i815 video chips (Closes: #130702)
     - change SiS 630 chipsets from XF86_SVGA server to XFree86(sis)
Files:
 c7a59aedc66feb15baf46f0a562eefb3 664 libs optional discover-data_1.2002.01.28-1.dsc
 714c371545dce6d6999d7cfc23e7a1d8 55265 libs optional discover-data_1.2002.01.28.orig.tar.gz
 4b57ae3f771f8656a6ff8c18f1d8626f 2566 libs optional discover-data_1.2002.01.28-1.diff.gz
 e3f4ed2481e6e300fe5a04b9d448c714 58238 libs optional discover-data_1.2002.01.28-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iEYEARECAAYFAjxU+uUACgkQ6kxmHytGonwyrQCfYu/ljIHG7hCR3K97gMMW1/XJ
9ewAn3FeWi3ZisU86OLbujf6Y9OBQsgw
=p4rs
-----END PGP SIGNATURE-----

Binary package hint: linux-source

When using any of the install CDs (ubuntu-server 6.10, ubuntu-desktop 6.10) on HP NetServer LP 1000r, megaraid_mbox/megaraid_mm drivers crash at random point during installation (sometimes right at 'disk detection', sometimes in the middle of mke2fs step for partititons).

The solution seems to be to use megaraid.ko ("legacy megaraid" driver), but the problem is that it doesn't recognize the controllers as supported.

So, I used the patch from

  http://www.suseblog.com/?p=156

against 2.6.17-10-generic megaraid.c and megaraid.h, which allowed me to boot, partition, format and install Ubuntu on the system.

I'll attach a patch here for reference.

(the patch is against 2.6.11, but this part of code hasn't changed, and it works with 2.6.17 as well)

Hi,

This bug was reported a while ago and there hasn't been any recent activity. Just curious if this is still an issue in the Hardy Heron 8.04 Alpha release - http://www.ubuntu.com/testing ? The Hardy Heron Alpha series is currently under development and contains an updated version of the kernel. You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. We'll keep this report open against the actively developed kernel bug against 2.6.17 this will be closed. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.17:
status: New → Won't Fix
Ralf Mörler (mobang) wrote :

Today I tried to install 8.04 but there was only a black screen after I hit the Enter key for Installation :-(

This isn't fixed in 8.04 and I don't think that it will ever be fixed here because it seems that no one needs this fix really. I fixed the issue by using an other SCSI Adapter ;-)

Bye Ralf

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

*This is an automated response*

This bug report is being closed because we received no response to the previous request for information. Please reopen this if it is still an issue in the actively developed pre-release of Jaunty Jackalope 9.04 - http://cdimage.ubuntu.com/releases/jaunty . To reopen the bug report simply change the Status of the "linux" task back to "New".

Changed in linux:
status: Incomplete → Won't Fix
Raúl Pedroche (pedroche) wrote :

The reported problem still affects Intrepid and Jaunty. The source of the problem is upstream, in vanilla kernel itself.
H/W products affected seem to be the whole HP Netserver LT, LP and LC ranges.
From my own tests: install in HP LP6000r works, as install CD (Intrepid) sees the virtual disk as a real SCSI disk. Unfortunately, installed system will not boot, as buffer inquiries (that make sense with a "real" disk, but not with the virtual volume) time out _after_ kernel looks for and does not find root filesystem.
Fix is really easy and can be performed by the end users, but having to download kernel sources, patch, compile and install after each new kernel package release can become excessively cumbersome.

Changed in linux (Ubuntu):
status: Won't Fix → New
Changed in discover-data (Debian):
status: Unknown → Fix Released
Raúl Pedroche (pedroche) wrote :

Confirmed: it also affects Karmic.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was flagged as having a patch attached. The Ubuntu Kernel Team's preferred policy is for all patches to be submitted and accepted into the upstream kernel before agreeing to merge them into the Ubuntu kernel. The goal for the Ubuntu kernel is to have little to no divergence from the upstream linux kernel source.

https://wiki.ubuntu.com/KernelTeam/KernelPatches has been written to document the suggested policy and procedures for helping get a patch merged upstream and subsequently into the Ubuntu kernel. Please take the time to review that wiki if this patch should be considered for inclusion into the upstream and Ubuntu kernel. Let us know if you have any questions or need any help via the Ubuntu Kernel Team mailing list. Thanks in advance.

tags: added: kj-comment
removed: cft-2.6.27
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Andy Whitcroft (apw) wrote :

The megaraid driver seems to have some support for megaraid3 devices now, could those affected please test the latest a maverick or natty kernel and confirm whether there is still an issue. Please report back here. Thanks!

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Closing due to lack of response to the previous inquiry for information. Feel free to reopen if you are able to respond to comment #13.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.