Ubuntu

I/O errors with USB to IDE converter

Reported by grahams1 on 2007-01-23
8
Affects Status Importance Assigned to Milestone
linux-source-2.6.17 (Ubuntu)
Medium
Brian Murray

Bug Description

I/O errors when trying to access IDE disk via an USB to IDE converter (sold as R-Driver II).

Scanning with lsusb and lsscsi my system detects the device and a /dev/sda is created. However the disk partitions aren't seen and I can't mount it. A simple od </dev/sda fails with I/O errors, usually immediately but sometimes after reading a few disk blocks.
I also tried booting from a live ubuntu 6.06 cd and slax (2.6.16 kernel) and I see the same errors.

I've successfully accessed the same IDE disk via the converter on the same machine via windows XP and from DSL 3.2 (2.4.31 kernel) without issue.

From the website at http://www.usbgeek.com/prod_detail.php?prod_id=0190 the chipset is a MYSON CENTURY, CS88186

The lsusb -vv output is

Bus 002 Device 004: ID 14cd:6600
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 64
  idVendor 0x14cd
  idProduct 0x6600
  bcdDevice 2.01
  iManufacturer 1 Super Top
  iProduct 3 USB 2.0 IDE DEVICE
  iSerial 2 ???????3
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 32
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xc0
      Self Powered
    MaxPower 0mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 2
      bInterfaceClass 8 Mass Storage
      bInterfaceSubClass 6 SCSI
      bInterfaceProtocol 80 Bulk (Zip)
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0200 1x 512 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x02 EP 2 OUT
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0200 1x 512 bytes
        bInterval 0
Device Qualifier (for other device speed):
  bLength 10
  bDescriptorType 6
  bcdUSB 2.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 64
  bNumConfigurations 1
Device Status: 0x0001
  Self Powered

grahams1 (gps1539) on 2007-01-23
description: updated
Brian Murray (brian-murray) wrote :

Thanks for your bug report. To better help us troubleshoot the issue could add the output of 'fdisk -l /dev/sda' and 'dmesg' showing the I/O errors? Thanks in advance.

Thanks for looking into this. I will try to connect the device and get the fdisk and dmesg output in the next few days.

Graham

Brian Murray <email address hidden> wrote: Thanks for your bug report. To better help us troubleshoot the issue
could add the output of 'fdisk -l /dev/sda' and 'dmesg' showing the I/O
errors? Thanks in advance.

** Changed in: Ubuntu
     Assignee: (unassigned) => Brian Murray
       Status: Unconfirmed => Needs Info

--
I/O errors with USB to IDE converter
https://launchpad.net/bugs/81059

grahams1 (gps1539) wrote :

No output from fdisk -l /dev/sda

#fdisk -l /dev/sda

# fdisk /dev/sda

Unable to read /dev/sda

lsscsi shows the disk is connected

# lsscsi
[7:0:0:0] cd/dvd _NEC DVD+RW ND-2100AD 1.28 /dev/scd0
[8:0:0:0] disk ST380020 A /dev/sda

This is the dmesg from running fdisk -l /dev/sda
# dmesg
[17312846.148000] sd 8:0:0:0: SCSI error: return code = 0x10070000
[17312846.148000] end_request: I/O error, dev sda, sector 0
[17312846.148000] Buffer I/O error on device sda, logical block 0
[17312846.172000] sd 8:0:0:0: SCSI error: return code = 0x10070000
[17312846.172000] end_request: I/O error, dev sda, sector 8
[17312846.172000] Buffer I/O error on device sda, logical block 1
[17312846.192000] sd 8:0:0:0: SCSI error: return code = 0x10070000
[17312846.192000] end_request: I/O error, dev sda, sector 16
[17312846.192000] Buffer I/O error on device sda, logical block 2
[17312846.212000] sd 8:0:0:0: SCSI error: return code = 0x10070000
[17312846.212000] end_request: I/O error, dev sda, sector 24
[17312846.212000] Buffer I/O error on device sda, logical block 3
[17312846.232000] sd 8:0:0:0: SCSI error: return code = 0x10070000
[17312846.232000] end_request: I/O error, dev sda, sector 0
[17312846.232000] Buffer I/O error on device sda, logical block 0

grahams1 (gps1539) wrote :

After a quick google search, it looks similar to this bug http://bugme.osdl.org/show_bug.cgi?id=3223

Brian Murray (brian-murray) wrote :

You mention using 6.06 and it not working, but I realized we don't what version of Ubuntu you are currently using. Once I have that information I can properly classify the bug. Also do you recall what specific kernel version was on the Knoppix CD that worked?

grahams1 (gps1539) wrote :

Hi

I'm currently on 6.10, but I get the same failure after booting a 6.06 live cd and I recently tried booting from a Feisty CD (downloaded ~ 1/26) and the issue is still there.

Sorry I had an error in my original post, I found DSL 3.2 (kernel 2.4.31), not Knoppix worked fine with this converter, as did Windoz XP.

description: updated
grahams1 (gps1539) wrote :

Hi Brian

Any progress on this one?

It looks like an old bug reported and fixed? back in 04. http://bugme.osdl.org/show_bug.cgi?id=3223
That report talks about the patch being planned for submittal to 2.6.10. I'm wondering if that didn't happen.

I'd be happy to try the patch, but I'm not sure how to patch a Linux kernel. Are there any good howtos?

Graham

Brian Murray <email address hidden> wrote: You mention using 6.06 and it not working, but I realized we don't what
version of Ubuntu you are currently using. Once I have that information
I can properly classify the bug. Also do you recall what specific
kernel version was on the Knoppix CD that worked?

--
I/O errors with USB to IDE converter
https://launchpad.net/bugs/81059

grahams1 (gps1539) wrote :

I can confirm that this bug is fixed in the 2.6.20-15 kernel

Brian Murray (brian-murray) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. Thanks again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in linux-source-2.6.17:
assignee: nobody → brian-murray
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers