System freeze up during edgy installation

Bug #68867 reported by Mikkel Kamstrup Erlandsen on 2006-10-28
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned

Bug Description

First; output og "lspci -vv":
http://librarian.launchpad.net/4937942/lspci.log

Second: Sorry I really don't know where to file this bug, and it contains several issues, but I guess that they are somehow related. I also commented on bug 62986, but I figure that they are unrelated after all.

I have been completely unable to install Edgy on my AMD64 box. I have tried three different CD images (with checkedmd5-sums on the isos), amd64-desktop, amd64-alternate, and i386-desktop. All hung completely at some point during the installation (hard reset required).

amd64-desktop: At install screen keyboard didn't work, there was no counter counting down from . Retry boot a few times and it suddenly worked. When it finally booted usplash was black/white (that is a known bug), but when it was about to switch to X it just froze hard on a black screen. CDrom drive stopped spinning. I waited ~5min and did a hard reboot.

amd64-alternate: Keyboard problems at install screen. When I got past those after a few retries, everything appeared to work. When it got to package installation it stalled for several minutes and then complained something about being unable to download libgcrypt. A retried a few times and sometimes the install procedure just froze before I even got to install packages.

i386-desktop: Seemed to work fine booting all the way into the desktop. At some point during the installation X just froze hard. I could move the mouse but everything else was unresponsive. Had to hard reboot. I tried this 3 times using the vesa driver for X in the last run. Always froze during installation.

My office mate could reproduce the exact same bug on his machine. Edgy installer (desktop cd) just hang at ~50%. Everything was just dead. He also had to hard reset the machine.

Attaching "lspci -vv" from his machine...

I installed Dapper from the 64bit-amd desktop cd without problems. First thing there after I upgraded to Edgy with the update tool in the update-manager, and everything works.

This is definitely a bug somewhere in the installer.

I'm suffering from exactly the same problem, tried AMD64 and i386 desktop, and also tried 6.06 AMD64 desktop, none will boot up.

Using: Amd 3400+ b4 bit processor, 2 gig Ram, 200 Gig Sata Hardrive

Any help would be appreciated

Colin Watson (cjwatson) wrote :

None of this really sounds like an installer bug as such. It sounds like the kernel's having trouble.

Colin: But Edgy runs perfectly once it is installed (ie. upgraded from Dapper)... So are you sure about the kernel thing?

justletmein: I really don't think you can do much. Install Dapper and do a dist-upgrade.

Matthew Woerly (nattgew) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you with the latest version of Ubuntu? Thanks in advance.

Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Edgy Eft 6.10 has reached it's end of life. As a result, we are closing the linux-source-2.6.17 Edgy Eft kernel task.

Changed in linux-source-2.6.17:
status: New → Invalid
Changed in linux:
status: New → Incomplete

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Ralph Janke (txwikinger) wrote :

Unfortunately this bug report is being closed because we received no response to the last inquiry for information. However, the Intrepid Ibex 8.10 Beta release was most recently announced - http://www.ubuntu.com/testing/intrepid/beta . If you are able to confirm this is still an issue with this most recent release please feel free to reopen this report. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks.

Changed in linux:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers