Ubuntu

bcm43xx in edgy doesn't connect to AP, locks down system

Reported by fuoco on 2006-10-27
This bug report is a duplicate of:  Bug #61388: random freeze (probably bcm43xx). Edit Remove
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned

Bug Description

I had the driver working fine (not great, but usable) on dapper. I used NetworkManager to connect to my unencrypted AP. Today I upgraded to edgy and it stopped working. I choose my AP from NetworkManager and it tries to connect for about a minute, and then stops without getting connected. I expected the driver's situation to improve with the newer kernel, but it seems like this is a regression.

Peter Liedler (peter-liedler) wrote :

Thank you for your bug report.

Could you please check if the package linux-restricted-modules is installed?

Did you try to connect the network via console? If so, please attatch the console output.

Thanks Peter

I have these packages installed:
linux-restricted-modules-2.6.17-10-powerpc
linux-restricted-modules-common
linux-restricted-modules-powerpc

I have not tried to connect the network via console, I don't really know how to. If you can point me to instructions I will try that.
Also I suspected bcm43xx module to cause some kernel panics/hangs that I experienced, so I unloaded it and now the system is OK.
I understand there are patches in the bcm43xx mailing list that improve the driver quite a bit.

Peter Liedler (peter-liedler) wrote :

Please try this:

sudo ifconfig wlan0 up

where wlan0 is your wireless card.

Xou can display your wireless settings, if already configured with

sudo iwconfig

I tried that command but nothing happens. It doesn't fail or something, but pinging the router or any other address fails:
$ ping 192.168.1.1
connect: Network is unreachable
$ ping yahoo.com
ping: unknown host yahoo.com

Jesper Krogh (jesper) wrote :

I have the same behaviour on a fresh Edgy installation on an Dell Inspiron 6400 (sometimes I get a lockup) but mostly I can only view the accesspoints, but not assosiate with them.

The firmware has been installed using "bcm43xx-fwcutter" and the script coming in that package.

Peter Liedler (peter-liedler) wrote :

Hello again, lets try next step:

is the module properly loaded? You can check this with the command:

sudo lsmod | grep bcm

Please post the output.

If not, you could add the module to /etc/modules - which could solve the problem temporarily.

Jesper Krogh (jesper) wrote :

The module loads automatically:

$ lsmod | grep bcm
bcm43xx 124436 0
ieee80211softmac 30720 1 bcm43xx
ieee80211 33608 2 bcm43xx,ieee80211softmac

From dmesg:
[17179589.724000] ieee80211_crypt: registered algorithm 'NULL'
[17179589.756000] ieee80211: 802.11 data/management/control stack, git-1.1.13
[17179589.756000] ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno
@linux.intel.com>
[17179589.848000] bcm43xx driver

$ iwconfig
eth1 IEEE 802.11b/g ESSID:off/any Nickname:"Broadcom 4311"
          Mode:Managed Frequency=2.484 GHz Access Point: Invalid
          Bit Rate=1 Mb/s Tx-Power=18 dBm
          RTS thr:off Fragment thr:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

But:
$ sudo iwlist eth1 scanning
eth1 No scan results

(even tried iwconfig eth1 rate 11M as suggested on the wiki)

Indeed the module is correctly autoloaded. There is no problem of scanning for me. I do get results with 'iwlist scan' and also NetworkManager shows some APs. When I choose mine, however, it tries to connect but doesn't succeed.

Peter Liedler (peter-liedler) wrote :

@fuoco:

can you try these steps to install the firmware (or did you do it already?):
sudo apt-get install bcm43xx-fwcutter
sudo /usr/share/bcm43xx-fwcutter/install_bcm43xx_firmware.sh

Took this from the forum: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Dapper

Please read the chapter 1.3.3. Setting up the Wireless Card
carefully. I think it describes the associating problem. Nevertehless, the bug should be solved.

Changed in linux-source-2.6.17:
status: Unconfirmed → Confirmed

Something made it work somehow now. It's not the instructions from that page coz I haven't done any changes to /etc/network/interfaces - NetworkManager just succeeded in connecting this time. I will have to try some more to see what exactly is going on. I'll report back...

Well, maybe not related to the original problem, but so far what I found out is when I come back from sleep I eventually find (after trying to connect for a few minutes) the following in dmesg:
[81518.921534] bcm43xx: IRQ_READY timeout

So I unloaded and reloaded the module which then worked.
Also the range of the wireless connectivity is very short - which seems to be taken care of by the patches I mentioned from the mailing list.

I cannot establish anything solid about that. The behavior is extremely unpredictable.
It could work sometimes right away, sometimes I have to try to reconnect several times, sometimes I unload/reload the driver. At sometimes I tried the command
'sudo iwconfig eth0 ap any' which seemed to help, but again not 100% sure...
The thing is that while it could work right away, it could also waste me over one hour of trying to connect, through which many times the system locks up and I have to hard shutdown.
With the suspend it is the same: it could work right away, it could require reloading the module, and it could easily lock up the machine too...
I have no real idea about what to do to fix this, but to maybe see what upstream has done to improve this and sync the driver with theirs.

Okay, so from my use of edgy since the last post it seems 'sudo iwconfig eth0 ap any' almost always makes it work - but then again why should it be run manually?
But the major problem is that very often the machine crashes and I must hard shut down it. This happens once a day or two, and I'm afraid it might harm the machine...

Michael R. Head (burner) wrote :

Is this now a dupe of bug #61388 (bcm driver causes system lockups)

Chris Wagner (chris-wagner) wrote :

I don't believe this is a duplicate of #61388, as I am seeing similar problems on my laptop that has a BCM4318 chip, but I am not having lock-up problems... so far. I am running Feisty on it.

fuoco, are you still seeing these problems on Feisty?

The 18 month support period for Edgy Eft 6.10 has reached its end of life. As a result, we are closing the linux-source-2.6.17 Edgy Eft kernel task. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers