reiserfs / only readonly

Bug #66301 reported by Arnd
2
Affects Status Importance Assigned to Milestone
linux-source-2.6.17 (Ubuntu)
Invalid
Undecided
Brian Murray

Bug Description

Binary package hint: linux-image-2.6.17-10-generic

After upgrading to edgy with linux-image-2.6.17-10 the root reiserfs partition / is not writable. However no corruptions are found.
It works perfectly if I boot with a 2.6.15 kernel (dapper). More details below...

arnd@zzplural9:~$ uname -a
Linux zzplural9 2.6.17-10-generic #2 SMP Fri Oct 13 18:45:35 UTC 2006 i686 GNU/Linux

arnd@zzplural9:~$ touch test
touch: cannot touch 'test': Read-only file system

arnd@zzplural9:~$ mount
/dev/hda3 on / type reiserfs (rw,noatime,notail)

arnd@zzplural9:~$ dmesg | grep ReiserFS
ReiserFS: hda3: found reiserfs format "3.6" with standard journal
ReiserFS: hda3: using ordered data mode
ReiserFS: hda3: journal params: device hda3, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda3: checking transaction log (hda3)
ReiserFS: hda3: Using r5 hash to sort names

arnd@zzplural9:~$ sudo fsck.reiserfs /dev/hda3
[...]
Filesystem seems mounted read-only. Skipping journal replay.
Checking internal tree..finished
Comparing bitmaps..finished
Checking Semantic tree:
finished
No corruptions found
There are on the filesystem:
        Leaves 12713
        Internal nodes 93
        Directories 19616
        Other files 259578
        Data block pointers 1523053 (345 of them are zero)
        Safe links 0
[...]

Revision history for this message
Ben Collins (ben-collins) wrote :

Try "sudo mount -o remount,rw /" after boot.

If this works, then it's a bug somewhere else.

Changed in linux-source-2.6.17:
status: Unconfirmed → Needs Info
Revision history for this message
Arnd (arnd-arndnet) wrote :

That works. But obviously only until next boot.
Any idea for "somewhere else"?

Revision history for this message
Arnd (arnd-arndnet) wrote :

You can close this bug if you want. I reinstalled edgy from scratch and now it works, however this time I used ext3.

Revision history for this message
Brian Murray (brian-murray) wrote :

This bug report is being closed due to your last comment regarding this being worked around. Thanks again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in linux-source-2.6.17:
assignee: nobody → brian-murray
status: Needs Info → Rejected
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers