Panic during suspend/hibernate on ThinkPad T42 (e1000/ipw2200)

Bug #64430 reported by Matt Zimmerman on 2006-10-06
2
Affects Status Importance Assigned to Milestone
linux-source-2.6.17 (Ubuntu)
High
Ben Collins
linux-source-2.6.19 (Ubuntu)
Medium
Unassigned

Bug Description

My ThinkPad T42 now reproducibly panics while preparing to suspend or hibernate. amixer is the process which is running, and the call trace is:

run_time_softirq
do_softirq
common_interrupt

This doesn't happen in single-user mode, perhaps because amixer doesn't run there. The audio device is:

00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
        Subsystem: IBM Unknown device 0537
        Flags: bus master, medium devsel, latency 0, IRQ 5
        I/O ports at 1c00 [size=256]
        I/O ports at 18c0 [size=64]
        Memory at c0000c00 (32-bit, non-prefetchable) [size=512]
        Memory at c0000800 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>

(snd_intel8x0)

Matt Zimmerman (mdz) wrote :
Matt Zimmerman (mdz) wrote :

I tried unloading snd_intel8x0 and friends, but I still got a panic (this time the swapper process was blamed, similar stack trace)

Matt Zimmerman (mdz) wrote :

As noted on IRC, this doesn't seem to be reproducible in recovery/single-user mode.

Therefore, I am attaching a diff showing which modules are loaded in each case.

Changed in linux-source-2.6.17:
assignee: nobody → ben-collins
importance: Undecided → High
status: Unconfirmed → Confirmed
Matt Zimmerman (mdz) wrote :

<mdz> BenC: if I disable the unloading of e1000 and ipw2200, it doesn't seem to panic
[...]
<mdz> BenC: I've whitelisted e1000 (so only ipw2200 gets unloaded) and it isn't crashing on me
 imlpying that it's e1000
<mdz> swapped them, and boom
 so it's e1000

I confirmed that leaving e1000 loaded across a suspend both avoids this problem and works, so the problem is somehow related to that driver unloading.

Ben Collins (ben-collins) wrote :

Thanks to an extensive two day debug session with Matt, we've reduced this to a single commit, and actually to a single portion of that commit.

Patch is in, and hopefully this will make it into edgy release.

Changed in linux-source-2.6.17:
status: Confirmed → Fix Committed
Matt Zimmerman (mdz) wrote :

Fix confirmed in 2.6.17-10.33-generic

Changed in linux-source-2.6.17:
status: Fix Committed → Fix Released
Ben Collins (ben-collins) wrote :

We want to confirm that this didn't regress in 2.6.19.

Changed in linux-source-2.6.19:
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Ben Collins (ben-collins) wrote :

Confirmed fixed still in 2.6.19 by Matt Zimmerman (Thanks Matt).

Changed in linux-source-2.6.19:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers