Ubuntu

ICH8 doesn't work

Reported by Ante Karamatić on 2006-10-02
42
Affects Status Importance Assigned to Milestone
linux-source-2.6.17 (Ubuntu)
High
Ben Collins

Bug Description

ICH8 doesn't work in edgy's kernel. This is a regression from Dapper.

godot (godotcg-launchpad) wrote :

I confirm this. SATA devices are not recognized with ICH8 in Edgy. It works in Dapper.
I can install Dapper, everything works fine. And then I upgrade to Edgy, but Edgy won't finish booting with 2.6.17-10 kernels. It stops to "booting: Waiting for root filesystem", and then after approx. 4 minutes it says it doesn't find my partition (with UUID or by directly supplying /dev/sdaX). And indeed if I type `ls /dev/sd*` under BusyBox, there's nothing. But with the kernel Dapper I still have, it boots fine (with UUID or with root=/dev/sdaX)

Core 2 duo, MSI Neo-F (HDD drive connected to the ICH8 SATA ports, not Jmicron one)

Daniel Torres (lolikapuxa) wrote :

same hardware here. MSI NEO, conected to the 3rd SATA port, not the jmicron one.
 But it gives me a diferent error. It crashes when doing something about dual function at boot.

gok (gok) wrote :

Same for me

Asus P5B Deluxe

Dapper => ich8r ok / Jmicron nok
Edgy => ich8r nok / Jmicron ok

It's a joke ? :p

Good luck :-)

flojlg (flojlg) wrote :

not a joke unfortunatly
same issue here with p5b

bug filled here:
https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/62963
but it was mentionned as a duplicate of this one:
https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/57502

since xxx15 kernel recognise the sata but not the last one xxx19

so now still waiting.

zoolonly (zoolonly) wrote :

I confirm the bug !
ICH8 works with ubuntu 6.06 and does not with the beta of the edgy
MB : P5B

The kernel freezes for edgy release tommorrow (the 5. of october). Is
there any chance that this bug will be fixed before that ?

Andreas

godot (godotcg-launchpad) wrote :

I really hope this will be fixed. This a regression from Dapper, and it will concern more people in near future since ICH8 will continue to gain in adoption. Personaly i'm ok with using Dapper's kernel in Edgy, but doing this my Jmicron doesn't work, and I must install manually Nvidia's drivers since my card wasn't supported in 1.0.8762.
So I vote for the resolution of this bug too ;-)

Changed in linux-source-2.6.17:
assignee: nobody → ben-collins
importance: Undecided → High
status: Unconfirmed → Confirmed
banxian (azsd) wrote :

lucky I have my main IDE HDD connect though a Promise tx2plus,
so I have successed boot into system after an dist-upgrade from Dapper to daily Oct-04.

In Edgy my extra HDDs (SATA@ICH8) disappeared, and my recorders (IDE@JMicron) recognized by kernel.
in Dapper the HDDs working fine but recorders was not working.

I think workaroud was switch SATA Disks from ICH8 to addonial Jmicron SATA node.

I will try newly daily cds to see if it been fixed later.

Clopy (clopy) wrote :

I also think it would be nice to be fixed for edgy. I'm in a corporate environment and not allowed to open the pc case :(. So now I'm stuck with Windows.

If its not solved in edgy, I'll have to open the case. Ubuntu worths the risk ;)

Ben Collins (ben-collins) wrote :

On Thu, 2006-10-05 at 08:45 +0000, banxian wrote:
> lucky I have my main IDE HDD connect though a Promise tx2plus,
> so I have successed boot into system after an dist-upgrade from Dapper to daily Oct-04.
>
> In Edgy my extra HDDs (SATA@ICH8) disappeared, and my recorders (IDE@JMicron) recognized by kernel.
> in Dapper the HDDs working fine but recorders was not working.
>
> I think workaroud was switch SATA Disks from ICH8 to addonial Jmicron
> SATA node.
>
> I will try newly daily cds to see if it been fixed later.

I'd like to get this bug fixed ASAP, but right now I don't have access
to the type of ich8 controller that is causing the problem.

Will anyone volunteer to give me access to a machine running latest edgy
that has this problem?

Criteria:

* ssh access (my ssh key is in my launchpad user account)
* sudo (root) access
* ability to build kernel drivers on it.
* boot device on the jmicron controller (so the ich8 isn't being used)
* Disk on ich8 so I can see if it is getting detected during my testing.

Any help would be appreciated.

firefoxtester (gregpinero) wrote :

Hi Ben,

I believe I have the target system, but I may not be sophisticated enough to get Edgy installed on it. I also won't be home until tommorow night. If no better candidates come forward perhaps you could talk me through getting Edgy installed? I don't know how to set up SSH for you either :-(

...but I make my system available to you as a last resort.

gok (gok) wrote :

hi ben,

P5B deluxe (jmicron + ich8r)

send me an email with your ip , i reply with host/login/password

<email address hidden>

see u

gok (gok) wrote :

Ben,

my config :

pci ide controller silicon image : cdrom + ubuntu hdd (boot)
jmicron : no devices
ich8r : 2 hdd sata with mdadm raid 1

gok (gok) wrote :

ben,

to login : ssh -p666 -l root tout.nu

i add your ssh-dss keys ;-)

let me know if you have problem

Joel Ebel (jbebel) wrote :

Ben,

I sent you an email to your preferred address regarding access to a machine for testing. Please respond to that email if you will be making use of it.

Thanks,
Joel Ebel

Ben Collins (ben-collins) wrote :

gok, Joel, thanks for the offers of machine usage.

Gok, I used your system (sure you saw all the reboots). It now has working ich8.

Fix is commited, and is being uploaded now.

Changed in linux-source-2.6.17:
status: Confirmed → Fix Committed
gok (gok) wrote :

good job ben !

i see my sata hdd... so gooooood !!!

if i burn daily live cd tomorrow.. fix is included ?

thank u

zoolonly (zoolonly) wrote :

Good job !
Thanks for all !!

zoolonly (zoolonly) wrote :

[EDIT] : ICH8 doesnt work yet ! but i beileve it will ... soon , so i just wanted to thanks ben for the work he did !
Sorry for the ones that thought i was able to make it work (Marc , Thomas Hotz) ...

Ludmil (ludmil-vd) wrote :

 I have the same problems with ds3 and sata hdd. I tried the 10-07 daily image (kubuntu 64) and there is the same problem. Two days passed and I still dont know if the fix is included in any daily release. My question is how can I understand what bugs are fixed in a daily?

SFAOK (gary-breavington) wrote :

My understanding is that the fix has been uploaded but has not been released yet. Once it's released it should make it into the next days daily build. I'm not sure what happens between the fix being comitted and being released - I'm guessing there's some sort of code review that takes place before it is released. I'm hoping it'll get released today and be in tomorrow's build and I can finally get Ubuntu installed on my new computer :)

Ludmil (ludmil-vd) wrote :

As I can see we have a new kernel 2.6.17-10.29 published today at 14:03:20 so its highly possible in tomorrows builds to have a working ich8.

SFAOK (gary-breavington) wrote :

Yep, the changelog references this bug so fingers crossed for tomorrow's build :)

Ante Karamatić (ivoks) wrote :

Na Pon, 2006-10-09 u 20:48 +0000, SFAOK je napisao:

> Yep, the changelog references this bug so fingers crossed for tomorrow's
> build :)

When new kernel is released, it's released as a source. That source
needs to build on all Ubuntu's buildd machines (every arch has couple of
machines; source needs to be build on one of every arch). In case of
simple sources it takes couple of hours (due the queue). In case of
kernel it can take even a day or more (due the queue, size of source and
number of binaries).

When kernel finally gets into distribution, it still doesn't get
included on daily-cd. Daily-cd is build from (installer) source in which
it still says "build with kernel x.y.z". Only when this source is
changed, daily-cd gets newer kernel.

--
Ante Karamatić <email address hidden>
PGP: 0xD3BDA225

gok (gok) wrote :

hey hey hey !!!

this morning, after update & dist-upgrade => new kernel released

and ICH8 working now ;-)

Have a nice day

Andcor (corneliussen) wrote :

Just curios. I get 4 of this errors:

Cannot allocate resource region {1} of device 0000:03:00.0
Cannot allocate resource region {2} of device 0000:03:00.0
Cannot allocate resource region {3} of device 0000:03:00.0
Cannot allocate resource region {4} of device 0000:03:00.0

(also described in bug #57592)

Is this in any way related to this bug, so that I can expect my computer to work with the new kernel from today?

Ludmil (ludmil-vd) wrote :

I dont know how much it takes a kernel to become available in a daily but there is the new kernel 2.6.17-10.29 in todays releases so it should work now.

Matt Zimmerman (mdz) wrote :

This fix is now released, no?

Sleeperknight (patman888) wrote :

tryed it with the 10/10 daily build, 2.6.17-10.29, couldn't get it working, would not recognize the sata hard drive hooked up to the ICH8 controller, tryed it in both IDE and AHCI. I'm also getting the grub error 21 when i try to use the Jmicron controller. but i can get it installed with it hooked up to the Jmicron, but just booting up won't work.

Sleeperknight (patman888) wrote :

2.6.17-10.30 has been released, wonder if it will work?

SFAOK (gary-breavington) wrote :

I've tried the daily alternate CD for today (11th October) and my drive attached to the ICH8 wasn't recognised. I'm guessing the fix hasn't made it into the installer's kernel. I would try the live CD (I usually have better luck with it (touch wood ;) as I think it has more up to date packages) but the last build was 09/10, that's before the fix was added to the kernel :(

Alf (hubbuntu) wrote :

Since apt-get upgrading from an older version of Edgy a couple of days ago, my SATA/JMicron, SATA/ICH8 and PATA/IDE drives are now all recognised. This is a Gigabyte GA_965P_DS3 motherboard.

SFAOK (gary-breavington) wrote :

The live desktop daily for the 11th came out a little later than usual - but works for me on my P5B. At last I have Edgy installed! :) Thanks to all!

Changed in linux-source-2.6.17:
status: Fix Committed → Fix Released
Mathias Kende (mathias-kende) wrote :

I've just tried the daily build (AMD64 alternate CD) with the same motherboard and for me it's still not working : neither are the network interface nor the SATA HDDs recognised.

so I'm still stick with windows on this machine.

Does the alternate CD take a little longer to be up-to-date ?

Henri Cook (ph8) wrote :

Is anyone able to confirm whether this worked with today's daily? I'm hoping to get a command line install on my P5B with software RAID somehow - presumably i can install desktop and strip out all the rubbish if I have to (if the alternate cd is not working yet)

Cheers,

ph8

Giblet5 (pw-byteshuffler) wrote :

I just tried the 2006-10-12 daily alternate CD image.

Asus P5B Deluxe WiFi-AP w/addons:
Promise PATA PCI
Sil SATA PCIE4x
Hard Drives at ICH8-SATA1, ICH8-SATA4, Sil-SATA1 and Sil-SATA2
DVD-Rs at Promise-Primary, Master and Slave

No joy. The JMicron is recognized, the ICH8 is not.

Since I have purchased a Promise PATA controller to work around the JMicron thing, and still have CDROM access from Dapper, it sure would be swell if the driver could enable the JMicron controller AND the ICH8 controller. I see in the 2.6.18 source where the JMicron is enabled (only works if AHCI mode is set in BIOS). It shouldn't be too hard to fix this.

The Edgy Daily alternate sees no hard drives but the first Sil SATA (? Where's the second one ?).

I abandoned the JMicron controller because it SUCKS. You can't set the access mode, so you get Error 21 out of grub (LBA default bios access mode and no way to turn it off in the bios settings).

I'd be happy with the 'broken' Dapper driver at this point. I have the JMicron controller turned off in BIOS but Edgy still sees it somehow.

GabrielGrant (gabrielgrant) wrote :

Do we have a conclusive answer as to whether this is fixed or not? The status is marked as Fix Released, but both of the last two comments shed some doubt on this. Confirmations either way anyone?

Stefan Steinheimer (nosefish) wrote :

The Edgy Live-CD works very well for me. JMicron, ICH8, and the network chip are recognized and work fine (Asus P5B, IDE-mode, haven't tried AHCI). I don't know about the alternate CD. If it doesn't work, the installer is probably still using an old kernel build.

Andcor (corneliussen) wrote :

For me to, just had to set the controllers to raid in bios

2006/10/25, Stefan Steinheimer <email address hidden>:
>
> The Edgy Live-CD works very well for me. JMicron, ICH8, and the network
> chip are recognized and work fine (Asus P5B, IDE-mode, haven't tried
> AHCI). I don't know about the alternate CD. If it doesn't work, the
> installer is probably still using an old kernel build.
>
> --
> ICH8 doesn't work
> https://launchpad.net/bugs/63516
>

erani (jundoe) wrote :

Hmm...

I changed the I/O settings at BIOS from IDE to RAID. The problem with various "Cannot allocate resource region {1} of device " solved, but Edgy still crashes at startup, and on the screen it says: "PCI: JMB36x: Enabling dual function on 0000:02:00.0" and then nothing.

I waited for about 5 minutes, and nothing still happened.

So, results. Tests have been done with Edgy Eft which was released on 26th of Oct.

Desktop CD: Working, detects HD's, finds network drives, and installation works. Booting up the Ubuntu fails.

Alternate: Works, but doesn't detect HD's, doesn't find network drivers and installation doesn't work either.

I've also tried Dapper Drake, but even alternate or desktop installer won't even boot up from the cd itself...!

Would it be possible, as I read from other thread, that GRUB doesn't detect hard drive when attempting to boot up Ubuntu...?

Andcor (corneliussen) wrote :

There are, as far as I know some bugs in grub concerning jmicron, but I
havent had any errors of that kind so far
2006/10/27, erani <email address hidden>:
>
> Hmm...
>
> I changed the I/O settings at BIOS from IDE to RAID. The problem with
> various "Cannot allocate resource region {1} of device " solved, but
> Edgy still crashes at startup, and on the screen it says: "PCI: JMB36x:
> Enabling dual function on 0000:02:00.0" and then nothing.
>
> I waited for about 5 minutes, and nothing still happened.
>
> So, results. Tests have been done with Edgy Eft which was released on
> 26th of Oct.
> Desktop CD: Working, detects HD's, finds network drives, and
> installation works. Booting up the Ubuntu fails.
>
> Alternate: Works, but doesn't detect HD's, doesn't find network drivers
> and installation doesn't work either.
>
> I've also tried Dapper Drake, but even alternate or desktop installer
> won't even boot up from the cd itself...!
>
> Would it be possible, as I read from other thread, that GRUB doesn't
> detect hard drive when attempting to boot up Ubuntu...?
>
> --
> ICH8 doesn't work
> https://launchpad.net/bugs/63516
>

xtknight (xt-knight) wrote :

I don't know if anyone's listening, but my Edgy still detects none of my SATA drives hooked up to the ICH8 controller. It is the ICH8, not ICH8R.

Specs:
Gigabyte GA-965P-DS3 rev 2.0 BIOS F7 (Intel P965 Express, ICH8)
Intel Core 2 Duo E6300 (1.86 GHz)

00:1f.2 IDE interface: Intel Corporation SATA Controller 1 IDE (rev 02) (prog-if 8f [Master SecP SecO PriP PriO])

00:1f.5 IDE interface: Intel Corporation SATA Controller 2 IDE (rev 02)

03:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Con
troller (rev 02) (prog-if 01 [AHCI 1.0])

03:00.1 IDE interface: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02) (prog-if 85 [Master SecO PriO])

Compiling a custom kernel (2.6.19.1) and enabling some SATA features solved the issue. Dapper detects my ICH8 controller and its drives just fine. (Sort of off topic, but neither distro will detect my JMicron PATA. I had to go through lots to get Edgy on this machine.)

The pata_jmicron module works for my JMicron PATA drives. I have libata, ata_piix, and ahci loaded and I'm not sure which my ICH8 is utilizing at the moment.

My current drive arrangement looks like this:

SATA hard drive 1->Intel ICH8 (I believe both ide and ahci work but I can test that)
SATA hard drive 2->Intel ICH8 (I believe both ide and ahci work but I can test that)

PATA DVD burner 1->JMicron PATA [ide mode]
PATA DVD burner 2->JMicron PATA [ide mode]

(attached `sudo lspci -vv`, `sudo lsmod`, `sudo lshw`)

Douma Motors (agreatwhitebird) wrote :

I trouble with a fresh Gutsy install on my Toshiba a200 (with intel's IHC8 family soundcard).

my speakers worked but my headphone jack wasn't being detected or showing up in the alsa mixer, nor was it working. Speakers didn't mute when I plugged my phones in.

But this fixes a lot of problems with these sound cards, because it ends up hooking you up with the latest alsa drivers, which i found hard to install elsewhere...

THE LINK THAT FIXED MY SOUND:
http://linuxtechie.wordpress.com/2007/10/19/getting-intel-ich8-family-rev-3-sound-card-to-work-in-gutsy/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers