Support for Intel 965 (GMA X3000) doesn't work

Bug #62135 reported by Sebastian Heinlein on 2006-09-24
34
Affects Status Importance Assigned to Milestone
X.Org X server
Invalid
Medium
linux-source-2.6.17 (Ubuntu)
Medium
Ben Collins
mesa (Ubuntu)
High
Rodrigo Novo
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

I run an Intel DG965WH mainboard with a Dual 2 Core processor and an Intel onboard graphics GMA X3000. The xserver complains about too less videoram and segfaults.

Setting the VideoRam to 13072 doesn't help.

Sebastian Heinlein (glatzor) wrote :

I run an Intel DG965WH mainboard with a Dual 2 Core processor and an Intel onboard graphics GMA X3000. The xserver complains about too less videoram and segfaults.

Setting the VideoRam to 13072 doesn't help.

Sebastian Heinlein (glatzor) wrote :

The log file of x

please post your Xorg logfile and let us know the kernel versions you are using.

Ben Collins (ben-collins) wrote :

Make sure you have the -9.23 kernel. The DRM/AGP bits were merged then.

Changed in linux-source-2.6.17:
status: Unconfirmed → Needs Info
Sebastian Heinlein (glatzor) wrote :

sebi@sebi-pc:~$ apt-cache policy linux-image-2.6.17-9-generic
linux-image-2.6.17-9-generic:
  Installiert:2.6.17-9.23
  Mögliche Pakete:2.6.17-9.23
  Versions-Tabelle:
 *** 2.6.17-9.23 0
        500 http://server.daheim edgy/main Packages
        500 http://archive.ubuntu.com edgy/main Packages
        100 /var/lib/dpkg/status

sebi@sebi-pc:~$ uname -a
Linux sebi-pc 2.6.17-9-generic #2 SMP Thu Sep 21 22:33:03 UTC 2006 x86_64 GNU/Linux

Loading the agpgart or intel-agp module manually doesn't have any effect.

Sebastian Heinlein (glatzor) wrote :

Using the new 2.6.17-10-generic doesn't solve the issue either. Would a local ssh access help you in investigating the root of the problem?

Sebastian Heinlein (glatzor) wrote :
Sebastian Heinlein (glatzor) wrote :

The GMA X3000 works using a stock 2.6.18git10 kernel.

Alex Willmer (alex-moreati) wrote :

I have the same behaviour with an Asus P5B-VM and linux-image-2.6.17-10.24.

Manually creating /dev/agpgart and loading agpgart/intel_agp has not made a difference.

If VideoRam is not specified in xorg.conf Device section, then X is able to start, but without DRI/GLX etc.

Created an attachment (id=7233)
Xorg.0.log

Xorg.0.log

The bug went away when I recompiled (with the intent of adding debug code to)
i965_dri.so from mesa. Note I didn't change anything yet - just a plain
recompile.

This is mesa from fedora rawhide: mesa-libGL-6.5.1-3.fc6

I'm now using kernel-PAE-2.6.18-1.2708.fc6

O.k. if it's working now, closing this.

Joel Ebel (jbebel) wrote :

Another vote for this. I get the same error using 2.6.17.10-24 using an Asus p5b-vm. It seems to work if I drop the resolution to 1024x768, but I'm trying to use this to display 1920x1080 on my TV. It looks like intel has made open source drivers available. It would be great to get these integrated to take full advantage of the intel graphics:

http://intellinuxgraphics.org

Ben Collins (ben-collins) wrote :

I know that the kernel side of the drivers are present. I'm getting someone with Canonical support to test a machine there and get me some information.

Ben Collins (ben-collins) wrote :

Looks like my backport missed some parts. Got things in there now.

Changed in linux-source-2.6.17:
assignee: nobody → ben-collins
importance: Undecided → Medium
status: Needs Info → Fix Committed
Ben Collins (ben-collins) wrote :

Kernel side is commited and tested. However, xorg shows this message on startup:

(EE) AIGLX error: dlopen of /usr/lib/dri/i965_dri.so failed (/usr/lib/dri/i965_dri.so: cannot open shared object file: No such file or directory)

I thought the mesa+xorg bits were there, but it seems not. We need this dri module in order to support accelerated graphics on this chipset.

At the very least, graphics is working now, but not accelerated.

Changed in mesa:
importance: Undecided → High
status: Unconfirmed → Confirmed
Ben Collins (ben-collins) wrote :

I tested with i965_dri.so built from our source, and the i965_dri.so built from mesa git.

However, both show the same problem on the test machine. DRI shows it is "working" (as reported in Xorg.0.log, and glxinfo). GL programs cause an error from the i915 drm module about a bad command.

The error is caused by a failure on validate_cmd() for a userspace passed command. This leads me to believe that the userspace is either broken, or the kernel side hasn't been updated to expect the command it is being sent. Either way, not even drivers from intellinuxgraphics.org works.

Joel Ebel (jbebel) wrote :

Are you able to get higher resolutions than 1280x1024? I was able to get the agpgart working, but still can only display a limited number of resolutions. I'm guessing that getting to these higher resolutions requires the modesetting branch of the intel x.org driver. That may be too experimental to get into edgy though. At this point, it doesn't even compile for me, though others seem to have reported success. I just wish I could get this to display at my LCD's native resolution and aspect ratio. I realise that this has nothing to do with either the kernel or mesa, so perhaps the xserver-xorg-driver-i810 package should also be included on this bug.

Joel Ebel (jbebel) wrote :

Ben, How did you specifically manifest the error from the i915 drm module? In an attempt to get higher resolutions out of my GMA X3000, I rebuilt drm from git, and mesa from the officially released 6.5.1, and I rebuilt my i810 module from git as well. I'm not getting any i915 module errors, and I successfully ran tuxracer and some other things with what certainly felt to be acceleration. I'm not sure which of these is responsible, but it seems to be working from the latest sources of drm, mesa, and the xorg i810 driver.

Unfortunately I'm still failing to get the resolution I want. I managed to get the modesetting branch of the i810 xorg driver to compile by adding some #defines to it, but now I get no video output at all, despite everything else thinking X is running. I can even log in. I just can't see it.

Changed in linux-source-2.6.17:
status: Fix Committed → Fix Released
Rodrigo Novo (rodarvus) wrote :

Assigning bug to myself. I'll upload a version of mesa in a few minutes adding back support to compile i965.

Now, if the driver is stable enough - or not - thats another business, and I believe it should be filled as another bug in this case.

(but I'll leave this bug open for now, just for reference :) )

Changed in mesa:
assignee: nobody → rodarvus
Rodrigo Novo (rodarvus) wrote :

Package uploaded:

 mesa (6.5.1~20060817-0ubuntu3) edgy; urgency=low
 .
   * Added back i965 dri driver to configs/debian-dri (fixes lp#62135)

Matt Zimmerman (mdz) wrote :

      mesa | 6.5.1~20060817-0ubuntu3 | edgy | source

Changed in mesa:
status: Confirmed → Fix Released
Ben Collins (ben-collins) wrote :

There's still a bug in i965_dri.so. Basically it needs to be compiled with an older gcc to avoid miscompilation.

I read this off some mailing lists for people seeing "i915_dispatch_cmdbuffer failed" in the kernel logs.

Changed in mesa:
status: Fix Released → Confirmed
Paul Sladen (sladen) wrote :

BenC: can you attach the patch in case somebody else applies the gcc-3.4 change.

Paul Sladen (sladen) wrote :

<BenC > tfheen: It's a one line change to a Makefile to set CC=gcc-3.4 for i965_dri.so only, and build-dep on gcc-3.4 for i386 and amd64

Oliver Brakmann (obrakmann) wrote :

I just read on LKML that recompiling i965_dri.so with -fno-strict-aliasing should fix it as well. JFYI.

http://lkml.org/lkml/2006/10/24/109

Paul Sladen (sladen) wrote :

Oliver: can you test/confirm this?

Oliver Brakmann (obrakmann) wrote :

Well, sort of. I rebuilt the package after adding "CFLAGS += -fno-strict-aliasing" to the Makefile in $(srcdir)/src/mesa/drivers/dri/i965, installed and restarted X. Afterwards, those "i915_dispatch_cmdbuffer failed" messages are gone, and both glxgears and GL screensavers finally run.

However, it doesn't seem terribly hardware accelerated. CPU utilization is up to ca. 15% just running glxgears, and there are still those "libGL warning: 3D driver claims to not support visual 0x5a" messages. glxinfo says "direct rendering: yes", though.

Oliver Brakmann (obrakmann) wrote :

Alright, it kept bugging me, so I installed Quake3 and tested. The result is that either the Core 2 Duos can play Q3 in software at 90 FPS, or hardware acceleration works :-)

Changed in xorg-server:
status: Unknown → Rejected

*** Bug 9007 has been marked as a duplicate of this bug. ***

Bojovic Dragan (drabo) wrote :

beryl does not work.

i compiled mesa and reinstall the package libgl1-mesa-dri

http://www.minimix.ch/ubuntu_packages/libgl1-mesa-dri_6.5.1~20060817-0ubuntu3_i386.deb

glxgears works now but if i start beryl-manager i can only see grey outlines of the windows and effects.

can someone help me, please !

Oliver Brakmann (obrakmann) wrote :

I'm not using Beryl, but the compositor of the xfce4 window manager, so I cannot help you there. I've uploaded the package that I've been using successfully since Oct 24, though. You might try that and see if it helps. If not, I suppose there's something wrong with Beryl.
<http://home.teleos-web.de/obrackmann/libgl1-mesa-dri_6.5.1~20060817-0ubuntu3+local1_i386.deb>

Bojovic Dragan (drabo) wrote :

hi,

your lib does not solve the problem but thanks anyway, i think ist a beryl bug too. will try to install 0.1.2

thanks again

PRDR (d2-ymail) wrote :

No luck.

Using http://home.teleos-web.de/obrackmann/libgl1-mesa-dri_6.5.1~20060817-0ubuntu3+local1_i386.deb
Beryl 0.1.2 and 0.1.3 start, but windows are completely blank.

¿Beryl bug?

Albert Vilella (avilella) wrote :

Is this beryl bug supposed to be fixed with the new mesa 6.5.2 or newer beryls?

Peter Cordes (peter-cordes) wrote :

I can confirm that -fno-strict-aliasing fixes the DRI on AMD64 Edgy. Intel DG965WH mobo, Core 2 Duo CPU.

apt-get source libgl1-mesa-dri
apply the simple patch to the build rules from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=394311

fakeroot apt-get source -b libgl1-mesa-dri
sudo dpkg -i libgl1-mesa-dri*.deb

PRDR (d2-ymail) wrote :

Yes, the "-fno-strict-aliasing" patch fixes DRI and it is possible to run things like glxgears... but I have had no luck whatsoever with beryl... still just blank windows...

helpdeskdan (helpdeskdan) wrote :

Thank you for posting packages for us newbie's. Question: How do you keep update manager from continually wanting to upgrade the replacement package?

Oliver Brakmann (obrakmann) wrote :

Hi! Sorry, I had to remove my package due to space constraints. It's back now: http://home.teleos-web.de/obrackmann/libgl1-mesa-dri_6.5.1~20060817-0ubuntu3+local1_i386.deb
I changed the name of this package so it won't be updated unless a newer version is released by the ubuntu folks.

helpdeskdan (helpdeskdan) wrote :

Yikes! That's even worse!! It wants to uninstall everything! Not to sound ungrateful, but I had to downgrade to the original file. Thanks very much for your work on this annoying bug!!

Oliver Brakmann (obrakmann) wrote :

Whoops, that is rather unexpected, as it doesn't do this on my system. Can't imagine why it would do that, except that maybe you're not on Edgy anymore but on Feisty already? Anyway, I'll better remove the package if it's causing trouble for people. Sorry for the inconvenience.

helpdeskdan (helpdeskdan) wrote :

No, it's Edgy. I tried it again to be sure; not as weird this time - must have hit the wrong button last time in aptitude. Anyway, the problem is libgl-mesa-dev which depends on the exact version6.5.1~20060817 . It wants me to remove libmesa-dev or downgrade. Last time I might have hit remove which I imagine would have caused it to suggest removing many more packages. (of course the solution was just to re-install the older package that I previously downloaded here)

Why aptitude says it can upgrade libgl-mesa-dri from 20060817-0ubuntu3 to 20060817-0ubuntu3 is beyond me.

Thanks for your help! Hopefully someday this will be included so everybody can benefit from the fix!

When will Mesa be upgraded to 6.5.2 version ?
I'm looking forward to playing with a composited desktop.

Toaste (cascraven-hotmail) wrote :

The deb package seems to be 404. I can temporarily host it if need be if somebody can send me the file.

Oliver Brakmann (obrakmann) wrote :

OK, I put it back up now. Before installing it, please make sure that libgl-mesa-dev isn't installed, as it seems to cause problems (see above). If it's then still causing problems, I'll remove it again.

Florian Boucault (fboucault) wrote :

Is it possible to have this patch into feisty ?

Thanks for the good work!

helpdeskdan (helpdeskdan) wrote :

beryl would be nice - is anybody working from that project working to fix this bug so it will work?

Anyone tried compiz?

Florian Boucault (fboucault) wrote :

I tried beryl but all the textures were wrong and filled with plain colours.

I think this bug needs Xorg 7.2 which has been release recently.

xorg 7.2 changes:
http://xorg.freedesktop.org/wiki/ChangesForX11R72?highlight=%2872%29

There's an effort to get 7.2 in feisty, see this bug:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/84731

I don't know if this will get in...

FYI I've tried compiz with no luck. X crashes and I'm back to gdm when launching compiz --replace

Alex Willmer (alex-moreati) wrote :

Since Feisty updated to X.Org 7.2, & mesa 6.5.2 my 965g has worked for X, GL, Compiz & Beryl. It appears that the people commenting on and following this bug are using Feisty.

Is anyone still having problems, or is this bug OK to close?

Jim Morris (jim-morris-world) wrote :

I want to ask that this NOT be closed, as I have the issue in Ubuntu 6.10. I have the affected Intel 965 chipset on a brand new Dell system. With the latest Mesa-DRI from Ubuntu 6.10 3D simply does not work - black screen. Rebuilding Mesa myself using the compiler flag suggesed above allows 3D to work. Unfortunately I have had several instances where updating the system with apt-get or with synaptic broke 3D until I reloaded my locally build DRI package...

Doesn't work here correctly.
Can someone post it's xorg.conf? I've upgraded to 7.2 and compiz starts but doesn't work correctly

What do you mean by "it doesn't work properly" ?
Here is my xorg.conf.

fixed with new xorg upload, it seems composition wasn't enabled. :) feel free to close this bug if no one else has problems

Timo Aaltonen (tjaalton) wrote :

This is fixed in feisty, works just fine on a Lenovo ThinkCentre M55 with i965 chip and current feisty.

this will not be backported to 6.10 since it is too invasive a change.

Changed in xserver-xorg-driver-i810:
status: Unconfirmed → Fix Released
Changed in mesa:
status: Confirmed → Fix Released
helpdeskdan (helpdeskdan) wrote :

Too invasive? Bojovic Dragan posted a file that fixed my problem:

http://www.minimix.ch/ubuntu_packages/libgl1-mesa-dri_6.5.1~20060817-0ubuntu3_i386.deb

Without it, no GL. Oliver Brakmann also produced a working file, but it broke apt. Also, I haven't tried beryl.

I'm not ready for feisty yet - couldn't we get that file uploaded?

Oliver Brakmann (obrakmann) wrote :

Hi Dan, everyone,

FWIW, my .deb only breaks apt if you try to install the -dev package as well. To make that work, you need a -dev package with the same adjusted version string the other package has (plus a corrected Depends: line). Since I needed exactly that a few days ago (I "needed" ;-) to compile prboom+), I created that package: http://home.teleos-web.de/obrackmann/libgl1-mesa-dev_6.5.1~20060817-0ubuntu3+local1_i386.deb

I successfully compiled prboom with it, and apt doesn't complain. It's the very same binary as before, I just unpacked the package and fixed the version strings, no recompilation or anything. Have fun :-)

helpdeskdan (helpdeskdan) wrote :

Excellent, thanks! I hope everybody can benefit from it.

Timo Aaltonen (tjaalton) wrote :

You can request a backport, it might be done or rejected :)

helpdeskdan (helpdeskdan) wrote :

How do I request that? The packages are created, they just need to be uploaded.

Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.