Headphone jack not working (mcp51)

Bug #61610 reported by drunken-wallaby on 2006-09-21
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned

Bug Description

the hp pavilion dv9043ea has a nvidia high definition audio-chip.

lspci ->
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

uname -r -> 2.6.17-8-generic

the problem is, that the headphone jack is not working (both on edgy, as well as on dapper). someone (http://ubuntuforums.org/showthread.php?p=1517455) solved this, by compiling alsa from source and additionally patching it.

i hope, this info is enough, if you need more, feel free to ask...

Bernhard

drunken-wallaby (berndl81) wrote :

Hi Daniel.

As this problem isn't yet resolved in an up-to-date edgy, I wanted to ask, if it is possible to include this patch by myself? Is there a wiki-page somewhere on adding a patch to an official ubuntu-kernel?

Thx in advance,
Bernhard

Manuel Vazquez Acosta (mva-led) wrote :

It seems that this bug isn't been worked on.

I have the exact same problem. My laptop is also an HP: pavilion dv2025nr. The same lspci gives the same result.

Regards,
Manuel.

The Hardy Heron Alpha series was recently released which contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ . Thanks

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.17:
status: Fix Committed → Won't Fix
wolfger (wolfger) wrote :

Over 3 months with no response. We are closing this bug report because it is unverified on the current kernel, as described in the previous comments. Please reopen it if you can verify the bug exists on the current kernel, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
Ludovic Claude (ludovicc) wrote :

The Headphone jack is still not working with Ubuntu 8.04 and the latest updates from the repository. My computer is an AMD 64, with the on-board MCP51 nVidia audio. I can see the code from the patch mentioned above in the latest alsa-source, so it looks like this patch was applied but does not fix this issue...

Changed in linux:
status: Invalid → New

Hi Ludovic,

Care to confirm this is still an issue with the latest Alpha for the upcoming Intrepid Ibex 8.10 ? You should be able to test via a LiveCD - http://www.ubuntu.com/testing. Please let us know your results. Thanks.

Changed in linux:
status: New → Incomplete

Hi all,

This was solved long ago, at least for me.

Best regards,
Manuel.

Leann Ogasawara wrote:
> Hi Ludovic,
>
> Care to confirm this is still an issue with the latest Alpha for the
> upcoming Intrepid Ibex 8.10 ? You should be able to test via a LiveCD -
> http://www.ubuntu.com/testing. Please let us know your results.
> Thanks.
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>

Andreas Moog (ampelbein) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers