tifm driver (out of tree) needed for TI SD reader

Bug #59035 reported by Stefano Rivera on 2006-09-05
2
Affects Status Importance Assigned to Milestone
linux-source-2.6.17 (Ubuntu)
Undecided
Ben Collins

Bug Description

0000:06:09.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller

The tifm driver (http://tifmxx.berlios.de/) is needed to properly support this device.

Gentooers managed to do it with sdhci, but it's *really* messy: http://gentoo-wiki.com/HARDWARE_Gentoo_Acer_Ferrari_4005WLMi_Manual#SDHCI

On dapper, the best I could get was this:
[ 115.354295] ieee1394: Node removed: ID:BUS[0-00:1023] GUID[00c09f000064844b]
[ 115.406679] fakephp: Fake PCI Hot Plug Controller Driver
[ 115.434137] fakephp: Can't remove PCI devices with other PCI devices behind it yet.
[ 115.559063] ieee1394: Initialized config rom entry `ip1394'
[ 115.566362] sdhci: Secure Digital Host Controller Interface driver, 0.10
[ 115.566559] sdhci: Copyright(c) Pierre Ossman
[ 115.566716] PCI: Device 0000:06:09.4 not available because of resource collisions
[ 115.566947] sdhci: probe of 0000:06:09.4 failed with error -22
[ 115.573815] ohci1394: $Rev: 1313 $ Ben Collins <email address hidden>
[ 115.574019] ACPI: PCI Interrupt 0000:06:09.2[C] -> GSI 21 (level, low) -> IRQ 177
[ 115.597452] ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[177] MMIO=[c0317000-c03177ff] Max Packet=[2048]
[ 116.105948] ieee1394: Host added: ID:BUS[0-00:1023] GUID[00c09f000064844b]

As you can see, it won't work :-)

See https://wiki.ubuntu.com/HardwareSupportMachinesLaptopsAcer.

Changed in linux-source-2.6.17:
assignee: nobody → ben-collins
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers