Does not boot on HP dc7600 USDT (regression from dapper)

Bug #58489 reported by Ondřej Surý on 2006-09-01
38
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Kernel freezes after:
HP Compaq aptop series board detected. Selecting BIOS-method for reboots
NET: Registered protocol family 16
EISA bus registered
ACPI: bus type pci registered
PCI: BIOS Bg: MCFG area is not E820-reserved
PCI: Not using MMCONFIG
PCI: PCI BIOS revision 2.20 entry at 0xebfd6, last bus=63
Setting up standard PCI resources
ACPI: Subsystem revision 20060127
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
ACPI: Assume root bridge [\_SB_.PCI0] bus is 0

Disabling IOAPIC and LAPIC (noioapic nolapic) on boot time doesn't help.

Chuck Short (zulcss) wrote :

Try booting with nommconf.

Thanks
chuck

Changed in linux-source-2.6.17:
importance: Untriaged → Medium
status: Unconfirmed → Needs Info
Ondřej Surý (ondrej) wrote :

Freezes at exactly same place, no message changed (MMCONFIG wasn't used before or now).

ssmerche (ssmerche) wrote :

Similar behavior on a Toshiba Satellite U205-S5022

Augestflex (augestflex) wrote :

The following bug reports seem to be related in the fact that they are all receiving the same bios message either when choosing to start or install. The message is:

PCI: BIOS Bug: MCFG area is not E820-reserved.
PCI: Not using MMCONFIG

The other apparantly related bug reports are:
https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/58489
https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/56727
https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/59756
https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/61077
https://launchpad.net/distros/ubuntu/+bug/61215

Ondřej Surý (ondrej) wrote :

nommconf doesn't help

Changed in linux-source-2.6.17:
status: Needs Info → Confirmed

The same on a Toshiba Tecra A8. "nommconf" doesn't work..

I get the same BIOS Bug error message when trying to install Edgy. Dapper booted and installed fine though. My motherboard is an Asus P5B, with the Intel P965 chipset.

Augestflex (augestflex) wrote :

Trying to start Kubuntu Edgy Edge Knot 3 or Beta after I choose to start Kubuntu the first thing that comes up after "Loading Kernel" is:
PCI: BIOS Bug: MCFG area is not E820-reserved.
PCI: Not using MMCONFIG
The computer then hangs and fails to boot. I have tried the default option and the Graphics Safe Option. My hardware is as follows:

Motherboard: ASUS A8N32-SLI Delux, BIOS ver 1303
Chipset: nforce4
Processor: AMD 64 X2 4200
Memory: 2x1024 Corsair XMS 3500 LL Pro
Video Card: 1x EVGA Nvidia 7800 GT
HDD0: Maxtor 5T060H6 - 60GB
HDD1: WDC WD2000JB-00DUA1 - 200GB
CD/DVD Burner: HP DVD Writer 740b
Sound: Onboard RealTex AC '97 850
NIC: Onboard: 2xMarvell Yukon 88E8053 PCI-E Gigabit Ethernet Controller
Monitor: ViewSonic P95f+

Also note the following:
1. I have confirmed this to also happen in 6.10 Beta (in addition to Knot 3).
2. This occurs with the 6.10 Beta x386 version
3. This occurs with the 6.10 Beta 64-bit version

I tried installing the latest daily build of Edgy (Oct 8) from the desktop cd. Still does not work. Here are the error messages I receive:

PCI: BIOS Bug: MCFG area at e0000000 is not E820-reserved
PCI: Not using MMCONFIG

cp: unable to open `root/var/log´: No such file or directory
mount: Mounting /root/dev on /dev/.static/dev failed: No such file or directory
mount: Mounting /sys on /root/sys failed: No such file or directory
mount: Mounting /proc on /root proc failed: No such file or directory

Target filesystem doesn't have /sbin/init

Here are my hardware specs:
Motherboard: ASUS P5B (P965 chipset)
CPU: Intel Core 2 Duo E6600
Memory: Corsair XMS2 6400 DDR2 (2x1024 MB)
HDD: Samsung SpinPoint T133S 400GB SATA2
GFX: Asus Extreme GeForce 7600GS
DVD drive: Samsung SH-W163A SATA

I've attached the output of "lspci -vv" and "lspci -vvn", as requested by sfllaw.

It's working great now. The problem was that my SATA controller (ICH8) didn't work. That bug (#63516) has been fixed in the most recent daily builds.

Ante Karamatić (ivoks) wrote :

I can confirm this. I managed to get a workaround by disabling VT (virtual technology) in BIOS. Message still exsist, so I don't think 'not booting' is releated to that message.

This happens to me only with Xen kernel.

Some upstream toughts:

http://lkml.org/lkml/2006/10/1/260

Josh Meyer (pickture) wrote :

The final Edgy still does not boot on my desktop, though there is no longer an error message.

Alienware ALX
CPU: AMD Athlon 64 FX-60
Motherboard: ASUSTeK A8N32-SLI-Deluxe
Graphics: NVIDIA GeForce 7900 GT (x2)
HDD: NVIDIA 300GB RAID

Bug in Gutsy

[ 49.400470] PCI: BIOS Bug: MCFG area at e0000000 is not E820-reserved
[ 49.400515] PCI: Not using MMCONFIG.

$ uname -a
Linux ubuntu 2.6.22-6-generic #1 SMP Fri Jun 1 19:24:12 GMT 2007 i686 GNU/Linux

Start Ubuntu, similar bug -> https://launchpad.net/ubuntu/+bug/61215

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
status: Unconfirmed → Confirmed
Ben Collins (ben-collins) wrote :

Lst comment related to gutsy is not related to this bug report. Rejecting.

Changed in linux-source-2.6.22:
status: Confirmed → Rejected
Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.17:
assignee: nobody → ubuntu-kernel-team
Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Edgy Eft 6.10 has reached it's end of life. As a result, we are closing the linux-source-2.6.17 Edgy Eft kernel task.

Hardy Heron 8.04 was recently released. It would be helpful if you could test the new release and verify if this is still an issue - http://www.ubuntu.com/getubuntu/download . You should be able to test your bug using the LiveCD. Please let us know your results. Thanks.

Changed in linux-source-2.6.17:
status: Confirmed → Invalid
Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.17:
status: Invalid → Won't Fix

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Unfortunately this bug report is being closed because we received no response to the last inquiry for information. However, the Intrepid Ibex 8.10 Beta release was most recently announced - http://www.ubuntu.com/testing/intrepid/beta . If you are able to confirm this is still an issue with this most recent release please feel free to reopen this report. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Thanks,

Changed in linux:
status: Incomplete → Invalid

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers