JMicron PATA/SATA Controller does not work

Bug #57502 reported by andrewpmk on 2006-08-23
122
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Ben Collins
linux-source-2.6.17 (Ubuntu)
High
Ben Collins
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kernel-image-2.6.17-6-386-di

On all 2.6.17 and below kernels, the JMicron JMB363 controller, found on the ASUS P5B motherboard, does not work. As a result, the Ubuntu Live CD will not boot (unable to mount root partition on the CD) and the Ubuntu Install CD cannot mount itself. More information is available here: <http://www.ubuntuforums.org/showthread.php?t=234706&highlight=jmicron>.

The 2.6.18 kernel (which is still in beta as of August 23, 2006) incorporates a fix for this problem. To fix this problem on 2.6.17 a patch could be used.

Victor Petrov (victor-petrov) wrote :

I would like to confirm the bug. I am the starter of the above mentioned thread at ubuntuforums.org.
Currently, I am running kernel 2.6.17.9, and still, no progress on the Jmicron detection. I was unsuccessful at installing the 2.6.18 -mm patch, or the 2.6.18-rc4 patch.
Several people mention that giving the parameter "all-generic-ide" to the kernel (at boot) works for Fedora Core, however, it did not work with the Ubuntu 6.06.1 desktop cd.

OnkelJens (jensschreiber) wrote :

I can also confirm it.

Using 6.06 no PATA devices are found. So
installing ubuntu is not possible if you have only a PATA hard drive.
My SATA dvd drive is detected fine.

Chuck Short (zulcss) wrote :

Will backport the patches tonight.

Changed in linux-source-2.6.17:
assignee: nobody → zulcss
firefoxtester (gregpinero) wrote :

Sorry a couple noob questions;

1. When you say backport, does that mean this fix will make it into Dapper?

2. If so should I just download a new install CD and it will work?

3. How will I know when the CD ISO downloads have been updated to include this fix?

Thanks (perhaps these would be good FAQ questions for somewhere or other).

Greg

firefoxtester (gregpinero) wrote :

BTW I'm confirming this too. (see my bug: https://launchpad.net/bugs/58358 for details)

I also think this should be changed to critical. Everyone buying a P965 motherboard is hitting this issue. Doing a search on the forum for "P965" bring up more issues each day.

firefoxtester (gregpinero) wrote :

I made a wiki page to put all of the information about this issue in one place:
https://wiki.ubuntu.com/Core_2_Duo_Support

As you can see it's a pretty major issue. There are already 3 bugs and at least 9 forum threads regarding this. Hopefully we can get this fixed for Edgy.

Robert Rak (cynicist) wrote :

Decided to confirm this as well since the status has not changed. I agree with firefoxtester, this is very critical because of how many boards it affects. Virtually everyone who has a Core 2 Duo processor is using this chipset. The amount of complaints is rising on various linux forums as people begin buying this newer tech and I very much miss using my favorite open source operating system :(

Daniel Torres (lolikapuxa) wrote :

I confirm this. This bug should be considered Critical.

Same problem here.

Changed in linux-source-2.6.17:
status: Unconfirmed → Confirmed
Justin Clark (ihcnet) wrote :

I confirm it as well. I own a Asus P5B Deluxe motherboard, and it also fails to identify the IDE optical drive.

Ray Trautman (raytraut) wrote :

Same problem here.

Hoeflerb (hoeflerb) wrote :

I've found that if you take the latest edgy kernel (2.6.17.11) and compile in the ide-generic module, the all-generic-ide kernel boot parameter can be used and JMB363 PATA devices are detected. I played with a number of kernels and kernel configs before I figured this out. I'm not sure what is going on here, but it seems like ide-generic can't pick up the PATA drives unless it is initialized before the other disk controller modules. There is a comment about similar behavior in the 2.6.18 <a href="http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=15e0c694367332d7e7114c7c73044bc5fed9ee48">changelog</a>, but I think this is a different problem because vanilla 2.6.18-rc6 with ide-generic compiled as a module doesn't work for me.

Marcus Fischer (elyps) wrote :

I confirm it as well. I own a Asus P5B Deluxe motherboard, and it also fails to identify the IDE optical drive.

Joao Muniz (jrcmuniz) wrote :

Ok, unfortunately, same problem here...

Mobo ASUS P5B i965, Core 2 Duo E6400.

:(

Mariusz (mariusz) wrote :

I confirm this problem..
Mobo GIGABYTE GA-965P-DS3 P965, Core 2 Duo E6300 :(

Changed in linux-source-2.6.17:
assignee: zulcss → victor-petrov
description: updated
Chuck Short (zulcss) wrote :

Patch has already been sent.

Changed in linux-source-2.6.17:
status: Confirmed → Fix Committed
Game_Ender (game-ender67) wrote :

Does that mean the fix will be in dapper or edgy? and how can I tell when it is applied?

I also confirm the bug. I can't use linux! I would like to second the previous post.. will the fix be in Edgy and how will we know?

Someone (pc741tw) wrote :

I also confirm this bug.
I want to use Ubuntu.

BuJac (bj-aufderwacht) wrote :

same: P5VD2-MX, CORE 2 DUO, E6400, SB: VIA VT8237A, JMB363
all-generic-ide in grub.conf (kernel-line) works fine with 2.6.18-RC8
no solution for xen-3.0 unstable !?
someone?

Henri Cook (ph8) wrote :

This is NOT fixed in Edgy Knot 3, there also seems to be some sort of halt on the release of daily builds from before when Chuck submitted his fix - what a pain!

I'm hoping daily builds resume soon and I can get a daily install CD which hopefully will have chuck's patch!

Henri Cook (ph8) wrote :

This change hasn't made it into the changelogs yet, there seem to be a *lot* of us waiting for this, I for one am sitting here with a completely useless system as once i've got past the CDROM problem (by booting from USB disk), my SATA 2s aren't then recognised!

Do you know when this package will next be recompiled and hence, added to the daily build?

Changed in linux-source-2.6.17:
assignee: victor-petrov → ben-collins
importance: Untriaged → Medium
status: Fix Committed → In Progress
Changed in linux-source-2.6.15:
assignee: nobody → ben-collins
importance: Untriaged → Medium
status: Unconfirmed → In Progress
Changed in linux-source-2.6.15:
status: In Progress → Fix Committed
Changed in linux-source-2.6.17:
status: In Progress → Fix Committed
Someone (pc741tw) wrote :

I want to know when this package will fix,and added to the daily build!!

Bug confirmed.
MSI P965 NEO-F motherboard.

Really hope the fix gets in Edgy Eft, a lot of people (basically all people with a Core 2 Duo chipset + others) are affected by this problem.

Joao Muniz (jrcmuniz) wrote :

Dear all

I found this link on www.ubuntuforums.org

https://wiki.ubuntu.com/EdgyReleaseSchedule

OMG, it seems that we have to wait until October 19th-26th...

Cheers

Joao.

Game_Ender (game-ender67) wrote :

That is only the next official release, I would hope that there would be a nightly as stated above that includes the fix. Until then I am holding off on building my Core 2 Duo system.

Someone (pc741tw) wrote :

I want daily build include fix.

I need to use Ubuntu.

I bought a SATA DVD Writer to by-pass the problem. Samsung, 'Writemaster' SH-W163A DVD writer, which you can pick up online for GBP 25-30 in the UK. Be sure to buy a SATA cable and a molex to SATA converter so you can use the power. Not an elegant solution but good for the desperate. Except now I can't watch films because hdparm doesn't work with sata.

Ben Collins (ben-collins) wrote :

Fixed kernel is in two places:

1) dapper-proposed
2) edgy main

Choose your desired route. Tomorrow, we should have edgy daily ISO's with this new kernel.

Someone (pc741tw) wrote :

I am glad to hear that.
Thanks.

Joao Muniz (jrcmuniz) wrote :

Bad news... :(

take a look at:
http://www.ubuntuforums.org/showthread.php?t=258010&page=3&highlight=JMicron

last two posts:

doesn't work (gigabyte 965P DQ6 with core 2 duo) by "nuggien"

and

still doesn't work with Asus P5B Deluxe by "amorangi"

Someone (pc741tw) wrote :

I try today daily build.

Still wrong.

Maybe not include fix yet.

Harry up!

Someone (pc741tw) wrote :

Sorry.
I don't see "Tomorrow,we should have edgy daily ISO's with this new kernel."

I will try tomorrow.

Ante Karamatić (ivoks) wrote :

One note: all this boards are shipped with Realtek gigabit ethernet card, which is supported by r1000 module. It would be great if that module would be implemented in installer's /lib/modules/`uname -r`/kernel/drivers/net.

Henri Cook (ph8) wrote :

According to the changelists the fix IS included in the daily build of the 20th.. unfortunately it doesn't appear to work (confirmed with three other people)

If anyone has <any> success with this please post here - otherwise it looks like it's back to the drawing board Chuck! :s

What can I say? I bought machine with Core 2 Duo at monday and until then I have to use windows... because - yes you are right - I can confirm that daily build from 20.09.2006 still doesn't work with Asus p5b deluxe.

Please, fix it. I really want to switch back to linux as quick as possible.

andrewpmk (andrewpmk) wrote :

Too bad, it doesn't work for me either. I just wasted a blank CD :(

josef (ok1dtm) wrote :

GA P965 DS4 confirm also cd with daily build from 20.9 no work with pata devices

Ben Collins (ben-collins) wrote :

Pretty much what this tells me is that the patch that I was provided
just doesn't fix the problem.

For those of you that can, please provide this information (from livecd
boot).

lspci -vv
lspci -vvn
dmesg

I'll work on getting this resolved as quickly as possible. The sooner I
can get this info, the sooner I can come up with a patch, and the sooner
I can create some daily images to test. Probably easiest way for folks
to test the daily kernels is to install on the disk from another
computer, update the kernel, and then boot this disk in the machine with
the JMicron controller.

Thanks

Thunder.m (thunder-m) wrote :
Download full text (75.0 KiB)

Hi I am using debian sid with vanilla kernel 2.6.18, evrything works.

lspci -vv:
00:00.0 Host bridge: Intel Corporation P965/G965 Memory Controller Hub (rev 02)
        Subsystem: Giga-byte Technology Unknown device 5000
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 0
        Capabilities: [e0] Vendor Specific Information

00:01.0 PCI bridge: Intel Corporation P965/G965 PCI Express Root Port (rev 02) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 32 bytes
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: e4000000-e6ffffff
        Prefetchable memory behind bridge: 00000000d0000000-00000000dfffffff
        Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-
        Capabilities: [88] Subsystem: Giga-byte Technology Unknown device 5000
        Capabilities: [80] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
                Address: 00000000 Data: 0000
        Capabilities: [a0] Express Root Port (Slot+) IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
                Device: Latency L0s <64ns, L1 <1us
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed 2.5Gb/s, Width x16, ASPM L0s, Port 2
                Link: Latency L0s <256ns, L1 <4us
                Link: ASPM Disabled RCB 64 bytes CommClk+ ExtSynch-
                Link: Speed 2.5Gb/s, Width x16
                Slot: AtnBtn- PwrCtrl- MRL- AtnInd- PwrInd- HotPlug- Surpise-
                Slot: Number 32, PowerLimit 75.000000
                Slot: Enabled AtnBtn- PwrFlt- MRL- PresDet- CmdCplt- HPIrq-
                Slot: AttnInd Off, PwrInd On, Power-
                Root: Correctable- Non-Fatal- Fatal- PME-
        Capabilities: [100] Virtual Channel
        Capabilities: [140] Unknown (5)

00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #4 (rev 02) (prog-if 00 [UHCI])
        Subsystem: Giga-byte Technology Unknown device 5004
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 4: I/O ports at b000 [size=32]

00:1a.1 USB Controller: Intel Cor...

Changed in linux-source-2.6.17:
importance: Medium → High
Changed in linux-source-2.6.17:
status: Fix Committed → Fix Released
Changed in linux-source-2.6.15:
status: Fix Committed → In Progress
167 comments hidden view all 247 comments
Ben Collins (ben-collins) wrote :

The fix is contained, and being reviewed in, the dapper-proposed repository release of the kernel. Please add that to your APT sources and install manually to test this kernel.

Shriramana Sharma (jamadagni) wrote :

At https://launchpad.net/ubuntu/+bug/58358/comments/13 Ben also said that this fix is available for edgy also in the edgy-proposed repo. Just for info.

Changed in linux-source-2.6.15:
status: In Progress → Fix Released
Daniel Hollocher (chogydan) wrote :

I get the below errors also, but then I can boot fine.

PCI: JMB36x: Enabling dual function on 0000:03:00.0
PCI: Cannot allocate resource region 0 of device 0000:03:00.0
PCI: Cannot allocate resource region 1 of device 0000:03:00.0
PCI: Cannot allocate resource region 2 of device 0000:03:00.0
PCI: Cannot allocate resource region 3 of device 0000:03:00.0
PCI: Error while updating region 0000:03:00.0/0 (00009008 != 00000000)
PCI: Error while updating region 0000:03:00.0/2 (00009010 != 00000000)

There is a difference for my errors; the device was 2 instead of 3.
I am running an Asus PB5 motherboard, with the JMicron controller. I have a CD drive, and a harddrive on the one-and-only IDE channel.

I don't know if this relates, but I tried to boot from a 6.06 LTS CD, and that failed. I assume its because the motherboard is new, and that 6.06 kernal is dated. I "installed" ubuntu simply by swapping the harddrive from my old computer, which had a fully updated version of edgy on it, already.

Thomas Hotz (thotz) wrote :

danielhollocher: I also get similiar outputs on Edgy. The fixes are currently not included in the 6.06 LTS CD. Maybe there will be an update of the CD, but I don't know (if and when).

I am currently testing Ubuntu Feisty Fawn and there these messages are gone. I use an Asus P5B Deluxe Wifi-AP motherboard.

Daniel Hollocher (chogydan) wrote :

Thanks Thomas. I just upgrade, and feisty is working. I actually didn't realize that allot of work had happened on this issue. I found this through google, and google linked me to only an individual comment. I thought it was a full report, to which I responded. It wasn't until after I submitted, that I saw the rest of the discussion.

Sorry all!

Thomas Hotz (thotz) on 2007-04-04
Changed in linux-source-2.6.20:
status: Unconfirmed → Fix Released
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
rebird242 (nik242) wrote :

I have an MSI P965 NEO that does not work. Please help!!!

Same problem as above. I noticed the fix was commited where do I get it so I can install it?

Martin Pitt (pitti) wrote :

I consider this for the dapper point release if someone can actually give some feedback about the kernel in dapper-proposed? Thank you!

Martin Pitt (pitti) wrote :

Ben, do you have a pointer for the fix for this? Is it isolated and unintrusive enough for SRU?

confirmed using gutsy, 2.6.22-9 (at 4 august 2007), on intel p965, core2 duo e6600, msi p965 neo board.
without passing irqpoll and disabling splash,hdd install and the live cd fails to load.

danub (admin-dark-tower) wrote :

As of fiesty Fawn, I still am unable to make this work. I have the newest release, just downloaded it today. If I set the boot args to "no apic no lapic" it loads kubuntu, but the grub is screwed up and I cant load to windows. I constantly get a "ata?.01: failed to set xfermode (err_mask=0x40)". I'm really unhappy as i haven't been able to put a linux distro on my new comp since i built it last year. I am using the intel 965 board.

my current setup is 4 hard drives. 2 on the jmicron and 2 aren't. the 2 that aren't show fine. Problem is, one that is is my data drive and holds all my backups/scripts/etc. if you actually have a fix for this... it would be nice to get it into a distribution so i can start using ubuntu/kubuntu again.

Martin Pitt (pitti) wrote :

The dapper-proposed approach with ABI 50 never really took off, readjusting tags and status for standard SRU workflow.

Changed in linux-source-2.6.15:
status: Fix Committed → In Progress
Pii (pasi-parkkinen) wrote :

Hello guys!

I have tried one year to get Linux to my "new" computer, still not succeeded... :(

My hardware is following:
Mobo: Abit B9 Intel 965 LGA775 ATX (Having the JMicron SATA controller)
CPU: Intel Core 2 Duo E6400, 2.13 GHz, Socket 775, FSB 1066, 2MB Cache

And my problem is that HDD is not found.

I just downloaded Kubuntu 7.10beta and tried. Fedora 7 also tried today, also same problem.

I don't know if this helps, but I got following errors during boot:
"usb 3-1 device not accepting addres 2, error -71" and "ata 3.00: failed to set xfermode (err_mask=0x40)."

Something weird with usb there is, because on all graphical installers I've tried (Fedora, Mandriva etc..) with this hardware I have a terrible slow mouse. My mouse is just standard Logitech USB-mouse.

I've a 12 years experience as a standard Linux-user, but never before installation has been that difficult...

Any idea when this will be fixed.

Meanwhile I'm forced to use M$ ... :( (Which indeed didn't have any installation problems)

tqft (ianburrows-au) wrote :

This might not be good if you are on dialup - but try
downloading puppy linux - 83Mb and booting from cd.
It is a live cd. The question this will answer is
whether it is a driver/setup issue with feisty et al
or whether it is a linux problem. Puppy has a small
tool to mount all sorts of partitions - so if it can
see and mount them then we may get some clues to the
problem.

My first guess from current experience with recent
Feisty install is that the installer installed to the
hd but the hd numbering was off with what it wrote to
/boot/grub/menu.lst. I had to change the grub boot
parameters to get it to boot to (hd0,0) rather than
whatever it wrote.

--- Pii <email address hidden> wrote:

> Hello guys!
>
> I have tried one year to get Linux to my "new"
> computer, still not
> succeeded... :(
>
> My hardware is following:
> Mobo: Abit B9 Intel 965 LGA775 ATX (Having the
> JMicron SATA controller)
> CPU: Intel Core 2 Duo E6400, 2.13 GHz, Socket 775,
> FSB 1066, 2MB Cache
>
> And my problem is that HDD is not found.
>
> I just downloaded Kubuntu 7.10beta and tried. Fedora
> 7 also tried today,
> also same problem.
>
> I don't know if this helps, but I got following
> errors during boot:
> "usb 3-1 device not accepting addres 2, error -71"
> and "ata 3.00: failed to set xfermode
> (err_mask=0x40)."
>
> Something weird with usb there is, because on all
> graphical installers
> I've tried (Fedora, Mandriva etc..) with this
> hardware I have a terrible
> slow mouse. My mouse is just standard Logitech
> USB-mouse.
>
> I've a 12 years experience as a standard Linux-user,
> but never before
> installation has been that difficult...
>
> Any idea when this will be fixed.
>
> Meanwhile I'm forced to use M$ ... :( (Which indeed
> didn't have any
> installation problems)
>
> --
> JMicron PATA/SATA Controller does not work
> https://bugs.launchpad.net/bugs/57502
> You received this bug notification because you are a
> direct subscriber
> of the bug.
>

      Sick of deleting your inbox? Yahoo!7 Mail has free unlimited storage.
http://au.docs.yahoo.com/mail/unlimitedstorage.html

Try this:
$ sudo rmmod pata_jmicron
$ sudo modprobe pata_jmicron

As for me it solves the problem an the disks are detected and functional. may it have something to see with the initrd?

Pii (pasi-parkkinen) wrote :

How I exactly do that, I mean the problem occurs already on the installation phase, and I don't have any other disks where I could have working installation. Is there a possibility on (K)ubuntu installation to give those commands during installation? I'm not an expert with these installation / hardware things ..

Using an alternate with alt+F2

I can confirm it works on my box but having installed before the ubuntu version.

Changed in linux-source-2.6.15:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

This pending upload fixes it, it's just not mentioned in the changelog:

 linux-source-2.6.15 (2.6.15-29.61) dapper-proposed; urgency=low
 .
   * Fix for kernel crash on lvremove
     - LP: #103729
   * e1000: Disable MSI by default. Allow it to be enabled with module param.
     Some chip implementations seem to not work well with MSI.
     - LP: #56885
   * tg3: Backport v3.69
     - LP: #72696
   * Add r1000 to nic-modules
     - LP: #81782
   * Add bnx2 to nic-modules
     - LP: #73647
   * usb-serial: Fix oops with pilot-link
     - LP: #39518
   * megaraid: Move AMI/Megaraid3 IDs from megaraid_mbox.ko to megaraid.ko
     - LP: #57233

Pii (pasi-parkkinen) wrote :

Ok, I tried again...

Now I downloaded the final Ubuntu 7.10 x64 version ...

At the second try I was able to start the Live version, there I selected Install and all went well. After some updates I was forced to boot again ... now JMicron was not found ... and Ubuntu boot was stalled.

Then - I must say - I tried many things ;) - also the Live version: No success. Finally I remembered that I had some problems in Windows Vista and JMicron on early days of Vista. There the trick was to power off the computer completely (by removing the AC - outlet) and to leave the CD-ROM open!! (yes really!). I tried that and voilá there I am - using working Ubuntu installation (and these new 3D graphics are so cool! :)).

This weird "boot camp" disappeared some months after Vista release (they obviously published some kind of driver update to the SATA -controller ??), and I haven't had any need for that with Windows. Now this problem is back, but with Linux...

I don't know anything about device driver implementation, but it seems to be something generic because behaviour has been seen on M$ and Linux.

uname -a in my Ubuntu box:
2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux

As of final release of 7.10, the problem persists (I've edited my fstab, removed splash, added irqpoll)

Giblet5 (pw-byteshuffler) wrote :

Just for the record, Feisty and Gutsy both work fine on an Asus P5B
Deluxe WiFi and an Asus P5B Deluxe Twin-View.

On the WiFi edition board, I'm running Feisty (7.04), a DVD-RW is
hanging off the JMicron PATA port (Master). On the Twin-View edition
board, running Gutsy (7.10), there is a 500GB Seagate PATA drive
(Master) and the DVD drive is hanging off of a Promise PCI IDE
controller card.

I can boot from a JMicron DVD, or hard disk drive, no problems.

I suspect mangar is having some other issue... Bad timing off rounded
cables, for instance (do NOT use rounded cables - they can throw IDE
timing all to heck and back). Maybe not, but it works on two of those
controller chips here. Just sayin'...

On Thu, 2007-10-25 at 22:20 +0000, mangar wrote:
> As of final release of 7.10, the problem persists (I've edited my fstab,
> removed splash, added irqpoll)
>

Antonio De Marinis (demarant) wrote :

Hi,
tqft wrote on 2007-10-05:
> My first guess from current experience with recent
> Feisty install is that the installer installed to the
> hd but the hd numbering was off with what it wrote to
> /boot/grub/menu.lst. I had to change the grub boot
> parameters to get it to boot to (hd0,0) rather than
> whatever it wrote.

THANKS this worked for me! I changed the grub parameter from being erroneous set to (hd0,3) to (hd0,0) in the grub boot parameters.

I installed ubuntu gutsy 7.10 on my conputer wich has vista preinstalled. The installation from live cd went fine, but after re boot the boot stalled and pressing ctrl+F1 showed the issue "ata2.00: failed to set xfermode (err_mask=0x40)". So at first I thought the Sata controller being the issue, since I run a JMicron JMB361 controller, and tried different boot tips. What helped was to change the grub root only!

Thanks again

Antonio De Marinis (demarant) wrote :

very strange.
I finally boot it up gutsy by changing the grub root to (hd0,3) to (hd0,0) and the first thing I did was of course to edit the /boot/grub/menu.lst so that the next I time I would boot it would work, so I choose restart and nope ... it said cannot not mount partition ... very strange, then I re-edit the boot root to (hd0,3) and pressed 'b' and booted fine again, but this time with another boot root. anyone has any explanations that could help?

I have the "failed to set xfermode" issue, too. My workaround is to disable the controller in the BIOS. This is a realy bad workaround, because I cannot access my DVD-Drive. Vista has no problems with it so I think we can rule out hardware failours. It's very sad that this bug hasn't been fixed for about 1 1/2 years. Is there any progress Ben?

cheers,
Janosch

danub (admin-dark-tower) wrote :

I gave up on trying to get ubuntu on my box natively. I just ended up installing a VMWare environment and loading Ubuntu to that. Redhat seems to find the controller just fine though....oh well

Ok I fixed this for me following a hint from the last post on http://ubuntuforums.org/showthread.php?t=637721. According to the guy in the forum the SATA Contollers are double booked (whatever that means) which apparently confuses ubuntu. The solution for me was to plug my harddisk in a high numbered sata port, in my case port 6 worked like a charm. Hope this helps.

danub (admin-dark-tower) wrote :

What he means by the double booked is that the sata controllers are also on the jmicron controller (so they are on both controllers making them double booked). And while moving your hard drive to a higher numbered sata port gets it off the jmicron controller, this is only a mediocre workaround. Most people don't have a sata cd/dvd rom yet (still PATA) which automatically puts the drive on the jmicron controller (which in the case of my mobo and others, makes that drive "double booked" again, since it is on the ata controller and the jmicron controller).

What needs to happen is that Ubuntu dev's need to get a fix for it. What happens to the people like me that have 8 drives in their box? I automatically lose the option of using 4 of my drives since 2 would be on the ATA/jmicron controller and my first 2 sata ports are on the SATA/jmicron controller. So instead of having a total of 2.5 TB of storage and 3 dvd/cd burners, I would get 1 dvd/cd burner and 1.5 TB of storage. Kinda makes the money I spent on the other drives pointless....

Martin Pitt (pitti) wrote :

For the record, the kernel in dapper-updates has a patch which should fix this, but nobody tested it so far. The kernel was moved to -updates to fix the other bugs.

Please reopen if you still have problems in Ubuntu 6.06.2 or 8.04.

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
hjoska (hjoska) wrote :

I have an ASUS P5B motherboard with ICH8R SATA and Jmicron-363 SATA/PATA/RAID controller. Two Pata winchester connected to the Jmicron (no RAID), and a SATA CDROM to the ICH8R. Ubuntu 7.10 live cd loads well, but the kernel does not see any HDD. BIOS up to date, contains Jmicron 1.06.59 version.

From the kernel log you can see the kernel recognized the pata drives "ata3: PATA max UDMA/100 cmd 0xac00 ctl 0xa880 bmdma 0xa400 irq 17", it says "ata3: port is slow to respond, please be patient (Status 0x80)", later "ata3: SRST failed (errno=-16)"

I tried Ubuntu 8.04 beta too, the result is the same.

Windows run well, Puppy 3.01 recognizes all drives. I know a lot distributions have the same problem, anyway it is solved in the Linux world too. Puppy 3.01 uses 2.6.21.7 kernel, so it does not need the latest kernel version. For Ubuntu this is a two year old problem and a few people needs solution.

Pascal Schwarz (iso-thinktux) wrote :

I have the same Problem with 8.04 Final (Desktop Livecd) on a MSI P965 Neo-F mainboard.

Pii (pasi-parkkinen) wrote :

Me too have the same problem (still), I mean with 7.10 I could use Ubuntu. approx. 1/7 tries (or something like that) succeeded and Ubuntu was booting up. After 8.04 update I can't reach my Linux anymore. During boot I press ALT+F1 to get the console and this is what I get:

-- a clip from a console (manually written, can contain typos)--
Loading, please wait
[102.256034] ata 7.00 revalidation failed (errno=-5)
[137.378078] ata 7.00 revalidation failed (errno=-5)

Check root=bootarg cat /proc/cmdline or missing modules, devices:
cat /proc/modules ls / dev
-- clip ends

Windows works yes, I'm very disappointed to the Ubuntu. :( In my case the 7.10 boot up functionality was bad now its totally dead!

For the record, my HW is the following:

Mobo: Abit B9 Intel 965 LGA775 ATX (Having the JMicron SATA controller)
CPU: Intel Core 2 Duo E6400, 2.13 GHz, Socket 775, FSB 1066, 2MB Cache

Pascal Schwarz (iso-thinktux) wrote :

7.10 worked perfectly for me, the cd and the installed system...

Pii (pasi-parkkinen) wrote :

I updated the latest BIOS for mobo and Jmicron, Windows boots up now a little bit faster - Ubuntu is still completely dead. Is there any way to get that to work?

Pii (pasi-parkkinen) wrote :

I'm having two different kernels, it seems that with this new one (2.6.24-16) I really can't boot up Ubuntu. With an older one (2.6.22-14) Ubuntu can be started. But even with the older kernel I need to try several times.

Below a clip from my /boot/grub/menu.lst Is there any tricks I could try?

title Ubuntu 8.04, kernel 2.6.24-16-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=5152f10c-4ae1-4b61-b8cd-7d70b925d309 ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic
quiet

title Ubuntu 8.04, kernel 2.6.22-14-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=5152f10c-4ae1-4b61-b8cd-7d70b925d309 ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic
quiet

dalinuxlova (jackdachef) wrote :

try appending "irqpoll" that it looks like the following:

title Ubuntu 8.04, kernel 2.6.24-16-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=5152f10c-4ae1-4b61-b8cd-7d70b925d309 ro "irqpoll" quiet splash
initrd /boot/initrd.img-2.6.24-16-generic
quiet

hopefully that helps ...

Andcor (corneliussen) wrote :

Not like that it wont. I have had luck with irqpoll and all-generic-ide
boot options. But they have to be appended to the kernel line without "".

My bootline looks like this when I'm trying to install (i.e. wants to
get all the information on what goes wrong that I can):
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/sda1 ro irqpoll
all-generic-ide

dalinuxlova wrote:
> try appending "irqpoll" that it looks like the following:
>
> title Ubuntu 8.04, kernel 2.6.24-16-generic
> root (hd0,2)
> kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=5152f10c-4ae1-4b61-b8cd-7d70b925d309 ro "irqpoll" quiet splash
> initrd /boot/initrd.img-2.6.24-16-generic
> quiet
>
>
> hopefully that helps ...
>
>

Pii (pasi-parkkinen) wrote :

Thank you very much guys! I'm now happily running the 8.04 on my box! The irqpoll arqument without "". And now I can run Ubuntu! Boots every time!!! :).

Andcor (corneliussen) wrote :

I should maybe say that the irqpoll did not work for me with the 8.04
live cd. In stead i had to disconnect the hard discs that was connected
to the ICH8 controller and install on the hard disc connected to the
jmicron controller. Then, when the system was installed, I could connect
the other hard discs again and use the irqpoll option. I don't know if
it is the bootloader on the live cd, or if the live cd uses another
kernel than the installed system (it could be that as my dvb tuner did
not show up on the live cd).

Andreas

Pii wrote:
> Thank you very much guys! I'm now happily running the 8.04 on my box!
> The irqpoll arqument without "". And now I can run Ubuntu! Boots every
> time!!! :).
>
>

GripS (evilgrips321) wrote :

Adding the 'irqpoll' argument and nothing else worked for me after I had installed ubuntu by disabling the jmicron controller on my DFI Lanparty LT P35 T2R.

I have 2 sata drives in a non-raid config. Raid is set to ide mode. After setting SATA mode from IDE to raid I was able to install via the live cd. Set back to IDE after the install and disabled the jmicron controller in bios. Added the irqoll argument. Booted into bios and enabled the jmicron controller. Booted into ubuntu just fine and now cd/dvd roms are recognized.

I have the same problem with Ubuntu 8.04 in an Abit Ab9 Pro Motherboard even with irqpoll option.
I've also tried Xubuntu 7.04. With irqpoll option it recognize my HD and installs, but when I try to start Windows through GRUB it doesn't detect my HD... So I had to use the WinXP CD and do a fixmbr to use it again.

euthymos (euthymos) wrote :

Same problem here. No solutions.

Displaying first 40 and last 40 comments. View all 247 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers