prism2 modules won't build on 2.6.17

Bug #53748 reported by Tormod Volden on 2006-07-22
14
Affects Status Importance Assigned to Milestone
linux-source-2.6.17 (Ubuntu)
High
Ben Collins

Bug Description

knot-1: The prism2 modules are no more shipped with the kernel, probably due to this build failure. I installed linux-wlan-ng-source from universe and tried to build it using module-assistant, but it failed with several errors.

Debian unstable has 0.2.4+svn20060710-1 which fixes building on 2.6.17. I hope this one can be put into edgy soon.

Tormod Volden (tormodvolden) wrote :

I downloaded the debian package linux-wlan-ng-source_0.2.4+svn20060710-2_all.deb and tried to build it using module-assistant. This failed also, see attached log.

chansen (cyril-hansen) wrote :

I just tried to update to edgy from Dapper - My MA111 usb key is useless now without any driver.

Tormod Volden (tormodvolden) wrote :

The reason I could not build, is that there are duplicate .h files in the linux-headers tree and in the linux-wlan-ng tree. By removing the "wlan" and "prism2" directories in /usr/src/linux-headers-2.6.17-6/include I was able to compile the modules (using "sudo module-assistant build linux-wlan-ng").

Of course, the linux-wlan-ng-source 0.2.4+svn20060414-5ubuntu1 still fails to build, but the newer 0.2.4+svn20060808-2 builds.

Changed in linux-source-2.6.17:
assignee: nobody → ben-collins
importance: Undecided → High
status: Unconfirmed → Confirmed
Tormod Volden (tormodvolden) wrote :

Just want to add that debian now is at 0.2.5-2 and although it has to be packaged manually, the merge-o-matic output 0.2.5-2ubuntu1 compiles nicely (as long as the wlan and prism2 links in the linux-headers are removed). http://tormod.webhop.org/linux/wlan

andi5 (andi5) wrote :

I would love to see the kernel shipping prism2(_usb) modules again. Do not think nobody cares and everybody wants to compile kernel modules ;-)
Thanks in advance!

Ben Collins (ben-collins) wrote :

Synced our kernel to linux-wlan-ng 0.2.5. Enabled all the prism2 drivers.

Changed in linux-source-2.6.17:
status: Confirmed → Fix Committed
Mark Florian (markrian) wrote :

I believe this change has broken my wireless card (MA311, used to use the orinoco module), which was working perfectly well before. Should I file a new bug?

Tormod Volden (tormodvolden) wrote :

(Mark, I believe your comment was from before the new kernels were even built, so I don't think it's related.)

I have tried the new -generic kernel, and I can't get my prism2 to work with it :(

One difference with my own modules is that the p80211 now is called ieee80211, and there is no /proc/net/p80211 tree.

I get repeated "prism2sta_ev_info: Unknown info type=0x00". I have seen 0x01 as well.

pirast (pirast) on 2006-10-02
Changed in linux-source-2.6.17:
status: Fix Committed → Unconfirmed
Tormod Volden (tormodvolden) wrote :

Sorry, not very correct to say that p80211 was replaced by ieee80211. Now, back in 2.16.17-9-generic, I see that both ieee80211 and p80211 are loaded, the latter built by myself.

It seems rather that p80211 is missing from 2.6.17-10.

Changed in linux-source-2.6.17:
status: Unconfirmed → Fix Committed
Tormod Volden (tormodvolden) wrote :

Same issue with the 2.6.17-10.27. Should I file a new bug? Seems related to how the prism2 sources are synced though, since the manually built modules worked fine.

Ben Collins (ben-collins) wrote :

In latest kernel, p80211 is built into the kernel.

I'm not sure what you mean by "same issue". The modules are there and built, and they can load.

If anything is wrong, it's an upstream bug. They are built now the same way they were in dapper.

Ah, I think I know what the bug is. I'll have it fixed in tomorrow's upload.

Tormod Volden (tormodvolden) wrote :

By "same issue" I meant that I can't get the wifi connection to work, and that I get these Unknown Info messages.

The reason I think it's not an upstream issue, is that the modules I built separately (using module-assistant and the linux-wlan-ng-source package) did work.

> In latest kernel, p80211 is built into the kernel.

There is no /proc/net/p80211 tree though. Looing forward to tomorrow's upload :)

Tormod Volden (tormodvolden) wrote :

Thanks, with -10.28 my prism2_usb device works!

The missing /proc/net/p80211 breaks the firmware uploading, see bug #29706, like it did in dapper.

Changed in linux-source-2.6.17:
status: Fix Committed → Fix Released
Tormod Volden (tormodvolden) wrote :

With -10.31 the /proc/net/p80211 is back, and the kernel part of bug #29706 is fixed, thanks. Is there any chance this last fix could be backported to the dapper kernel?

Tormod Volden (tormodvolden) wrote :

I am referring to this part that should be backported to dapper:

linux-source-2.6.17 (2.6.17-10.31) edgy; urgency=low

  * wlan-ng: Add init/exit module calls so that things get initialized
    properly.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers