Suspend-To-Ram (S3) doesn't work on Dell Latitude C640

Bug #34155 reported by Lucas Nussbaum on 2006-03-08
54
This bug affects 3 people
Affects Status Importance Assigned to Milestone
acpi (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Medium
Stefan Bader
linux-meta (Ubuntu)
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Medium
Unassigned
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned

Bug Description

Suspend and Hibernate don't work on a Dell C640. Hibernate used to work perfectly in Breezy. I never tried Suspend with Breezy.

When resuming from Suspend/Hibernate, the screen comes back garbled.

xorg.org device section for the graphic card:
Section "Device"
        Identifier "ATI Technologies, Inc. Radeon Mobility M7 LW [Radeon Mo
bility 9000]"
        Driver "ati"
        BusID "PCI:1:0:0"
EndSection

Andreas Schildbach (schildbach) wrote :

Garbled with random green rectangles?

Then it's the same on the Dell Latitude X1, which uses an Intel i915GMS.

One time I was able to recover by pressing (Ctrl-)Alt-Fx-Combinations, but on all other tries this only changed the distribution of the green rectangles.

Lucas Nussbaum (lucas) wrote :

The rectangles are white here, and there are some color lines too.

I never managed to get out of it.

Lucas Nussbaum (lucas) wrote :

Hi,

This has been reported a month ago, and is extremly annoying. Are there some guidelines somewhere about helping to debug this ?

Erik Andrén (erik-andren) wrote :

I've been able to improve the situation by adding vga=0 to the grub boot line.
Please try if this improves the situation for you too.

Lucas Nussbaum (lucas) wrote :

I don't have this laptop anymore, so can't help fixing this bug.

Andrew Ash (ash211) wrote :

Marking rejected until new information arises. If this continues to occur on the latest dapper or edgy beta, please feel free to reopen the bug and continue discussion.

Thanks for the bug report!

Changed in linux-source-2.6.15:
status: Needs Info → Rejected
Erik Andrén (erik-andren) wrote :

I'm still experiencing this problem using Edgy current. This is not something distro specific though. I've been experiencing the same thing on both Gentoo and Slackware.

Andrew Ash (ash211) on 2006-10-13
Changed in linux-source-2.6.15:
status: Rejected → Needs Info
Kamil Páral (kamil.paral) wrote :

Dell Latitude C640, Ubuntu Edgy.

In default configuration, I could not suspend nor hibernate. After resuming suspend, there were a few lines and a box (mouse cursor) on the screen, could not restore image in any way. Trying to hibernate simply shut down the computer like power off.

After adding "vga=0" to boot parametres, the suspend works. At least a few tries worked. Will see in the future.
The hibernation does nothing, but there's a message in console that it couldn't find swap partition or something. I don't have swap partition, so that's maybe my fault. Cannot try hibernation hence.

I also tried follow this thread
http://www.ubuntuforums.org/showthread.php?t=187655
and commented
# SAVE_VBE_STATE=true
# POST_VIDEO=true
lines in /etc/default/acpi-support. This works too, I don't have to add the "vga=0" line. Which is better solution? Are there any drawbacks in either of them?

Kamil Páral (kamil.paral) wrote :

Well I have been too optimistic. Does not work in all cases. You have about 70% chance to succesfully resume after suspend, doesn't depend on which method you choose to workaround the bug. In other case I got blank screen or again garbled screen with lines and boxes.

Maybe it is not important, but I noticed, that after suspend resume there is pc speaker playing, even if it's muted in alsamixer.

Andrew Ash (ash211) wrote :

Edgy uses the 2.6.17 kernel, so this bug belongs under linux-source-2.6.17

Andrew Ash (ash211) wrote :

Could someone please test this with feisty? Now's the time to get it fixed.

Erik Andrén (erik-andren) wrote :

This is still an issue in feisty current.

towsonu2003 (towsonu2003) wrote :

per last comment

Changed in linux-source-2.6.20:
status: Unconfirmed → Confirmed
importance: Undecided → Medium
Tim Gardner (timg-tpi) on 2007-02-21
Changed in linux-source-2.6.20:
assignee: nobody → timg-tpi
Tim Gardner (timg-tpi) on 2007-02-21
Changed in linux-source-2.6.17:
assignee: nobody → timg-tpi
Ben Collins (ben-collins) wrote :

Confirmed bugs need to be assigned to ubuntu-kernel-team.

Changed in linux-source-2.6.20:
assignee: timg-tpi → ubuntu-kernel-team
Erik Andrén (erik-andren) wrote :

Still an issue with Gutsy

Tim Gardner (timg-tpi) on 2007-08-14
Changed in linux-source-2.6.17:
assignee: timg-tpi → nobody
status: Incomplete → Won't Fix
lucio (luciopalmitessa) wrote :

I have a acer with Radeon Mobility M9 [Radeon Mobility 9000] and I can't nor hibernate or suspend, but if I disable radeon driver I can hibernate and suspend correctly!
The problem is the almost absent 3d acceleration! I have this problem since the first hoary and I tried gusty and the problem is still the same!

Erik Andrén (erik-andren) wrote :

Lucio: This bug report is only for the Dell C640 with a radeon 7500 mobility. If your hardware is different, open a separate bug.

DavidYerger (dyerger) wrote :

Problem is buggy Dell BIOS, specifically the ACPI DSDT.

Given there is no hope for Dell to fix this, the workaround is you need to get a hacked ACPI DSDT table from

http://acpi.sourceforge.net/wiki/index.php/FixedDsdts

, compile it, and slap it on the back of your initrd.

Works for me. I understand if your hardware is different than the one the hacked DSDT was created from, you may have to extract yours, and then manually patch vs. the given "vanilla" DSDT.

Now, to the good folks at Ubuntu, you could of course put a post-install script in with the kernel RPM to do hack the generic initrd thusly if the system is detected to be a C640, but I fully understand if you wouldn't want to do that.

Erik Andrén (erik-andren) wrote :

DavidYerger, I installed your initrd and checked that it was successfully loaded, unfortunately it still doesn't work. Suspending once usually works but the second suspend ends in the same failure as stated before.

DavidYerger (dyerger) wrote :

Whoopsie--sorry Erik, I only tested hibernate.

Suspend worked for me twice (with the exception of an external drive), then locked me up with a striped screen on the third try after waiting longer.

I think I read somewhere that the problem might be with the video chip. Maybe I should try the "ati" driver instead of "radeon". DOUBLE_CONSOLE_SWITCH might help if that's the problem, too.

Also, read here http://ubuntuforums.org/showthread.php?t=211592 on how to get suspend to work, seems to work fine for me, but it's "cheating" with regard to the present topic as it drops into S1 not S3 sleep.

HTH

Recently waking up from Standby (S1) gives a screen with a white line, and the area under it eerily gets brighter, kind of like a mood ring...

I changed the parameter in gconf to hibernate instead:
  1. I get a notification that hibernation failed when it wakes up
  2. The external drive doesn't wake up
  3. The network adapter didn't wake up last time (/etc/init.d/networking restart didn't help), last one might be related to me having a wireless card in, usually this works

coonj (coonj) wrote :

I have a similar problem on a Fujitsu P7010D (w/ Intel Extreme graphics 2 chip), and was able to get the video back only if I initiated a reboot:

  - Successful suspend
  - on resume, mouse is visible but the screen is white/black/green stripes
  - If i bring up the "Quit" dialog (via Alt+Ctrl+Del), I can kind of see where the box is on the screen, and I know where to click for "Shutdown", so I do that
  - Immediately, the video comes back! Everything looks great, but I had initiated Shutdown for the to happen, so that is not a solution!

But, I think it is worth mentioning that the video does come back during the Shutdown process, and it is almost immediate, so it is something that runs near the beginning of the shutdown script.

Erik Andrén (erik-andren) wrote :

Seems like I spoke too soon (again).
I suspended the computer successfully 10 times in a row, but when I retried the procedure 30 minutes later it failed.
Back to step 1...

ɞєᾐ ἂ. (talkingwires) wrote :

I added linux-source-2.6.24 to the list of affected packages, since this bug is still present in Hardy.

ɞєᾐ ἂ. (talkingwires) wrote :

I don't think this bug is related to X.org's ATI driver at all.

I followed some of the suggestions above, changing /etc/default/acpi-support and editing Grub. The thing is, I tested everything in recovery mode, before X.org ~and~ the radeon kernel module are loaded. I was only able to suspend half the time. I tried removing my wireless module (ipw2200) and loading the radeon module. It all had the same effect: suspend-to-ram only resumed half of the time, regardless of the radeon module's presence. An ACPI problem, perhaps?

(I'm on a Dell C640, as well.)

ɞєᾐ ἂ. (talkingwires) wrote :

Oh, and I just noticed that this bug just celebrated its second birthday. I added ACPI to the affected packages as a birthday present, and invited the Kernel ACPI team to come to the party.

Moving linux-source-2.6.24 task to just linux since beginning with the Hardy release the kernel source package naming convention changed from linux-sourc-2.6.xx to just linux. Thanks.

Ben Aultowski - Running the latest 2.6.24-12 Hardy Beta kernel, care to attach your dmesg output after an attempted suspend/resume cycle as outlined here: https://wiki.ubuntu.com/DebuggingKernelSuspend . Thanks.

Changed in linux:
status: New → Incomplete
ɞєᾐ ἂ. (talkingwires) wrote :

I'm sorry, maybe I don't understand the instructions. I used the command to simulate a suspend, but when I powered back on, I faced the usual problem. How am I supposed to get the output from dmesg when my laptop doesn't boot properly from a suspend? Is there a way to record its output as it begins the suspend cycle? Or automatically record it when it tries to resume? Because all I've got is the dmesg from when I had to do a hard reset after it failed to resume....

(My computer thinks it's 1996 now, so at least that part worked....)

Erik Andrén (erik-andren) wrote :

Ben, you can access the machine via ssh from another computer and capture the logs.

ɞєᾐ ἂ. (talkingwires) wrote :

It might be a couple more days before I can follow up on this bug. My laptop's power adapter was died the other night (the "barely supported by Ubuntu docking station" comes to to rescue!), and I haven't been able to hook up my desktop since my most recent move because I can't afford a the mouse and keyboard to use it...

I will report back before Hardy (a LTS) is launched, as this bug is making me consider jumping distros. A Dell C640 suspends "out of the box" on Arch Linux....

Bryce Harrington (bryce) wrote :

I don't know if this will fix this specific issue, but I've backported a bunch of high importance patches that upstream recommended, that fix problems sort of like this one, so I think it would be worth the time to test. Please try this .deb and report what you find:

http://people.ubuntu.com/~bryce/Testing/ati/

If we can determine that the patches in this deb fix this bug, they may be candidates for backporting to Hardy.

ɞєᾐ ἂ. (talkingwires) wrote :

I tried your package, Bryce, but it didn't fix the suspend issue.

I still haven't been able to investigate this issue using another other computer to log in, as I still don't have a spare keyboard...

Bryce Harrington (bryce) wrote :

Dropping task against -ati as per comment #26. Looks like it's a kernel issue since the bug can be seen without X running.

Changed in xserver-xorg-video-ati:
status: Confirmed → Invalid

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

ɞєᾐ ἂ. (talkingwires) wrote :

I tried the 2.6.27 kernel from Intrepid's repos, and the problem remains unfixed.

Erik Andrén (erik-andren) wrote :

I can confirm that Ubuntu Intrepid Beta still doesn't resolve the problem.

Changed in linux:
status: Incomplete → New
ɞєᾐ ἂ. (talkingwires) wrote :

The problem still remains in Intrepid's Release Candidate.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Daniel T Chen (crimsun) wrote :

How about in 9.04 with linux-image-2.6.28-1-ub-generic?

Youri Volkov (omgomgomg) wrote :

Update: 9.04 with 2.6.27-8-generic works on my end.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Ben Aultowski - would you be able to test the latest pre-release of Jaunty to confirm if this is resolved for you like it was for Youri. http://cdimage.ubuntu.com/releases/jaunty/alpha-2/ , you should be able to test suspend via a LiveCD. Thanks.

Changed in linux:
status: Triaged → Incomplete
ɞєᾐ ἂ. (talkingwires) wrote :

@Launchpad Janitor: Good to know that top men are working on this. TOP MEN. Oh, wait, you're just a robot and the developers have pretty much ignored this bug for three years now. On a related note, I now have two of these machines (Military surplus), and the second one came with Windows 2000 installed. I booted it up and closed the lid. A tear ran down my cheek when I opened the lid and watched a ten year-old OS resume from suspend.

@Leann Ogasawara: Jaunty Alpha 3 is scheduled to drop tomorrow. I'll wait for that to be uploaded and report back.

Erik Andrén (erik-andren) wrote :

I've tested with a daily jaunty build from 12 august and the bug can still be reproduced. It may work once or twice in a row.
This leads me to belive that this is a race issue of some kind.

TJ (tj) wrote :

For those that can reproduce this could you provide the following reports/attachments?

For both hibernate (to disk) and suspend (to RAM) gather the kern.log files from the current start-up and the previous after a suspend/resume and hibernate cycle. By providing the previous kern.log file we should capture useful information even if you had to restart the PC to get to the logs.

tar -czf kern.logs.tar.gz /var/log/kern.log{,.0}

sudo lspci -vvnn >/tmp/lspci.log

uname -a
lsb_release -a

Stefan Bader (smb) wrote :

Closing the acpi task. There is nobody going to look at that.

Changed in acpi (Ubuntu):
status: New → Invalid
Stefan Bader (smb) wrote :

Can someone confirm this problems on the latest release (Jaunty)? Please provide the information TJ mentioned as well as the list of modules loaded. Often those problems are related to loaded modules not working well on suspend.

Changed in linux (Ubuntu):
assignee: nobody → stefan-bader-canonical
DavidYerger (dyerger) wrote :

davidy@faustillium:~$ uname -a
Linux faustillium 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

davidy@faustillium:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.04
Release: 9.04
Codename: jaunty

DavidYerger (dyerger) wrote :

What happened in the last few boots regarding my attachment earlier:

* standby
* successful resume
* standby
* bad resume (vertical colored stripes, corrupted cursor)
* forced power off and normal start
* hibernate
* locked up on restart
* tried earlier kernel to bypass hibernation stuff, didn't work
* disabled splash and quiet in GRUB boot line, booted.

Also attaching suspend log, maybe that will help.

Nils (tourdefrance1234) wrote :

Is there any progress in fixing this bug? My Dell Latitude C640 running kernel 2.6.30 on Arch Linux, is affected as well. Suspend works only one time, after that, the screen gets garbled. Very annoying. It would be great if this bug gets fixed!

ɞєᾐ ἂ. (talkingwires) wrote :

I now have two of these systems. My old one has a cracked display and keyboard stopped working, but I will donate it to a developer than can work on this bug as well as this one: https://bugs.launchpad.net/ubuntu/+source/hal/+bug/309973

OkropNick (okropnick) wrote :

the same problem here on dell c640

Erik Andrén (erik-andren) wrote :

Would be interesting if someone gave this a go with the ATI kernel mode setting.
See: http://www2.bryceharrington.org:8080/drupal/node/84

ɞєᾐ ἂ. (talkingwires) wrote :

@Erik Andrén

I tried to follow the instructions, but was a little confused, mostly because configuring GRUB2 is different from the previous version. I installed the drivers and added the 'radeon.modeset=1' line to GRUB2's new config file at /etc/default/grub in the area where bootloader settings are supposed to go. But I just got an error saying that it was unrecognized and it tossed it out. When my system fully booted, the display was, well, bizarre. I could make out what I was doing, but everything seemed like it was being passed through a mosaic filter. Other pages linked to by the one you provide seem to suggest that this only works with the 2.6.31-13 kernels and up, but these are not Karmic's repositories.

I've been following this bug for three years and I really, really want to get it fixed. Could you provide a little assistance to an ordinary user that just wants to help?

Pauli (paniemin) wrote :

That sounds like bad problem with DFS or UTS. You can disable them in xorg.conf with exa optinos to device context. More details are in man exa to what can be put to xorg.conf.

Can you attach dmesg and xorg.log when modeset=1 is passed to kernel? It works but kernel doesn't know about module to handle it before radeon is loaded so you get that warning for working parameter.

ɞєᾐ ἂ. (talkingwires) wrote :

My C640 actually resumed from suspend tonight with the latest build of Karmic, albeit with a kernel oops message. I reported the bug in a separate report so Apport could upload all the pertinent logs. It can be found here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/457861

Andy Whitcroft (apw) wrote :

This is a kernel issue, the packaging is not affected. Closing out the linux-meta task only. The linux task where the work is ongoing remains ope.

Changed in linux-meta (Ubuntu):
status: New → Invalid
DavidYerger (dyerger) wrote :

Tried again with Lucid, got corrupted screen upon restore.

Ubuntu ix86 (ubuntuix86) wrote :

I'm attempting to get standby/resume to work on my c640 running Ubuntu 10.04.
I'm pretty sure that it had been working in past releases, but isn't working reliably now...

I tried modifying /etc/X11/xorg.conf with the instructions on the quirks page here
https://wiki.ubuntu.com/X/Quirks#ATI%20Radeon%20Driver%20Quirks

resulting in

Section "Device"
    ...
    Option "AGPMode" "x"
EndSection

where x is some number 1, 2, 4 or 8.

I found that when using AGPMode 4:

I can suspend and resume with the power plugged in selecting standby from the shutdown menu and resume by pressing the power button.

If I select suspend from the menu, and then close the lid, the computer will turn back on, and the backlight will turn on, but the screen remains blank and black. There is no response to keyboard or mouse input, no ctrl+alt+F#. The only option that works is to hold down the power button, and reboot.

When I shut the lid, the laptop goes into standby, and when the lid is opened again the laptop resumes, but the video is all garbled into various colors and strips. The area where the mouse pointer is occasionally has a blotchy square where it should be. I can switch to a terminal and that works fine, no graphical issues there. But the only way to get back to X11 is to use ctr+alt+backspace or run "sudo service gdm restart" from a terminal.

I can't think of anything else to tell...

I've tried attaching the xorg.conf file that I'm using.

Ubuntu ix86 (ubuntuix86) wrote :

Forgot to add,
Using AGPMode 1 and 8 resuming from either lid or menu standby results in the blank screen, backlight is on, but no disk activity or anything, requiring a hardboot.

In AGPMode 2 almost the same as AGPMode 4, but there are random occurrences of the above symptoms.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: added: kernel-needs-review kernel-power

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers