No adapter or battery found on laptop

Bug #31547 reported by Jelle Raaijmakers on 2006-02-15
26
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Medium
Unassigned

Bug Description

I'm running Ubuntu Dapper with linux-image-2.6.15-15-686. After some serious troubles with getting my system to run properly (see bug #31453) it was made clear that the kernel did not detect my AC adapter or my battery. I found this in kern.log:

Feb 15 18:31:38 localhost kernel: [4294692.718000] ACPI: AC Adapter [ACAD] (off-line)
Feb 15 18:31:38 localhost kernel: [4294692.720000] ACPI: Battery Slot [BAT1] (battery absent)

Actually, in GNOME the battery seems to work when charging, but only in that situation.

Jelle Raaijmakers (jelle-gmta) wrote :

I am unable to find any hardware details of my laptop's (a NEC Versa P550) adapter or battery. If requested I can try to find some manufacturer/device IDs.

Ben Collins (ben-collins) wrote :

Please try the 2.6.15-16 kernel, as it contains a large ACPI update.

Jelle Raaijmakers (jelle-gmta) wrote :

No positive results yet. I'm running linux-image-2.6.15-16, and it sais exactly the same as before in kern.log.

Sitsofe Wheeler (sitsofe) wrote :

JeRa:

Is this still an issue in 2.6.15-22 ?

Changed in linux-source-2.6.15:
status: Unconfirmed → Needs Info
Jelle Raaijmakers (jelle-gmta) wrote :

Yes, it still is:

JeRa@s050686:~$ uname -a
Linux s050686 2.6.15-22-686 #1 SMP PREEMPT Sun May 7 16:37:57 UTC 2006 i686 GNU/Linux
JeRa@s050686:~$ dmesg | grep ACPI
...
[4294704.451000] ACPI: AC Adapter [ACAD] (off-line)
...
[4294704.710000] ACPI: Battery Slot [BAT1] (battery absent)

Jelle Raaijmakers (jelle-gmta) wrote :

I installed 2.6.15-23 today and noticed that the Changelog stated that this was _the_ kernel. I did another 'dmesg | grep ACPI' and at first there was no change:

[4294697.542000] ACPI: AC Adapter [ACAD] (off-line)
[4294697.823000] ACPI: Battery Slot [BAT1] (battery absent)

But a few lines later it stated these errors four times:

[4294868.351000] ACPI-0240: *** Error: Cannot release Mutex [MUT0], not acquired
[4294868.351000] ACPI-0517: *** Error: Method parse/execution failed [\_SB_.BAT1._STA] (Node dffe5960), AE_AML_MUTEX_NOT_ACQUIRED

Isn't it odd it bugs out on BAT1 but stated there wasn't any battery present a few minutes earlier?

Riccardo Setti (giskard) on 2006-10-02
Changed in linux-source-2.6.15:
importance: Medium → Wishlist
status: Needs Info → In Progress
importance: Wishlist → Medium
status: In Progress → Needs Info
Simon Law (sfllaw) wrote :

Does this work on Linux 2.6.17, which is in Ubuntu Edgy?

Jelle Raaijmakers (jelle-gmta) wrote :

Adapter and battery are still not working properly. Only if I remove A/C and plug it back in, it seems to have found my battery. Dmesg reports:

[17179592.904000] ACPI: AC Adapter [ACAD] (off-line)
[17179592.940000] ACPI: Battery Slot [BAT1] (battery absent)

Ubuntu Edgy, kernel 2.6.17-10-generic.

Changed in linux-source-2.6.15:
assignee: nobody → ubuntu-kernel-team
status: Needs Info → Confirmed
Adam Niedling (krychek) wrote :

Last check is more than a year old. Still doesn't work?

Changed in linux-source-2.6.17:
status: Confirmed → Incomplete
Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Edgy Eft 6.10 has reached it's end of life. As a result, we are closing the linux-source-2.6.17 Edgy Eft kernel task.

Hardy Heron 8.04 was recently released. It would be helpful if you could test the new release and verify if this is still an issue - http://www.ubuntu.com/getubuntu/download . You should be able to test your bug using the LiveCD. Please let us know your results. Thanks.

Changed in linux-source-2.6.17:
status: Incomplete → Invalid
Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.17:
status: Invalid → Won't Fix

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Ralph Janke (txwikinger) wrote :

Unfortunately this bug report is being closed because we received no response to the last inquiry for information. However, the Intrepid Ibex 8.10 Beta release was most recently announced - http://www.ubuntu.com/testing/intrepid/beta . If you are able to confirm this is still an issue with this most recent release please feel free to reopen this report. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks.

Changed in linux:
status: Incomplete → Invalid

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers