Soft Lockup Detected on CPU#0 when hibernate and occasionaly during boot

Bug #120310 reported by mozzwald on 2007-06-14
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.17 (Ubuntu)
Medium
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

I have an Averatec 2100 series laptop which uses the ATI Mobility chipset (x200) and the Ralink rt61 wireless card. I have seen similar issues to to the one I am having but not exactly. Sometimes during boot the system will freeze at the splash screen. In Dec 06 I installed Ubuntu 6.10 for the first time and had this problem a lot. After a few updates it didn't happen as frequently but it still posed a problem. I had checked the dmesg log at the time and it stated "Soft lockup detected on CPU#0" but never researched the issue. In March of this year I installed Kubuntu Edgy in hopes of fewer problems. The problem persisted but again, not as frequent. I had trouble with hibernating but with some tweaking was able to get it to work. About a month or so ago after installing some updates the hibernate function stopped working. I get an error about pci power state (which it always has, but would continue) and then lockup with the "Soft lockup detected on CPU#0" error. Any suggestions?

uname a:
Linux mozzwald-laptop 2.6.17-11-generic #2 SMP Fri May 18 23:39:08 UTC 2007 i686
 GNU/Linux

mozzwald (mozzwald) wrote :

Attached is my most recent dmesg log.

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include as attachments the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

mozzwald (mozzwald) wrote :

uname -a:

Linux mozzwald-laptop 2.6.17-11-generic #2 SMP Fri May 18 23:39:08 UTC 2007 i686 GNU/Linux

mozzwald (mozzwald) wrote :

lspci

Changed in linux-source-2.6.17:
assignee: brian-murray → ubuntu-kernel-team
importance: Undecided → Medium
status: Needs Info → Confirmed
mozzwald (mozzwald) wrote :

I noticed my swap partition was not loading after a failed attempt at hibernating so I looked around at some other bugs and found this one: http://launchpad.net/ubuntu/+bug/66637

I was having the same issue with the swap disappearing so I did as suggested in the following quote:
"I had to do the following to solve it:
- correct fstab with the UUID outputted by mkswap (vol_id might work, but /dev/disk/by-uuid definitely don't)
- put "RESUME=UUID=<uuid>" in /etc/initramfs-tools/conf.d resume.
- update-initramfs -u after you have edited /etc/initramfs-tools/conf.d/resume"

After rebooting the splash screen froze so I restarted into recovery mode. When fsck started running I got the "Soft lockup detected on cpu#0" error. I rebooted again into recovery mode which worked (fsck ran fine this time) and created another dmesg log file which I have attached. Hope this helps determine the problem.

DaveAbrahams (boostpro) wrote :

I am seeing the same issue on my ThinkPad T60p with ATI FireGL v5200 using fglrx in the Hardy beta. Fortunately, the suspend/resume cycle actually works, but it is indeed worrisome.

# uname -a
Linux tsneaky 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

DaveAbrahams (boostpro) wrote :
Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Edgy Eft 6.10 has reached it's end of life. As a result, we are closing the linux-source-2.6.17 Edgy Eft kernel task.

Changed in linux-source-2.6.17:
status: Confirmed → Invalid
Sergio Zanchetta (primes2h) wrote :

Hardy Heron 8.04 was recently released. It would be helpful if you could test the new release and verify if this is still an issue - http://www.ubuntu.com/getubuntu/download . You should be able to test your bug using the LiveCD. Please let us know your results. Thanks.

Changed in linux:
status: New → Incomplete

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

mozzwald (mozzwald) wrote :

I have not had this problem since the Feisty Fawn release. Currently, I have Hardy installed and it is by far the best release I have used on my laptop. Suspend is working fine, but hibernate does not (attempts to save to disk and shuts down, but does a full boot upon startup). I haven't really tried to get the hibernate working. If I get a chance, I will test the new kernel. Here is my current uname:
Linux mozz-laptop 2.6.24-19-generic #1 SMP Wed Aug 20 22:56:21 UTC 2008 i686 GNU/Linux

Thanks for the update mozzwald. From your comments it seems the original issue this bug report was about has been resolved. If you are able to test the newer 2.6.27 kernel and notice any issues, please open a new bug report. Thanks.

Changed in linux:
status: Incomplete → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers