Realtek ethernet controller detected but no automatic dhcp on edgy

Bug #81782 reported by Marc Tardif on 2007-01-27
2
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Wishlist
Ben Collins
Dapper
Wishlist
Unassigned
Edgy
Wishlist
Unassigned
linux-source-2.6.17 (Ubuntu)
Wishlist
Unassigned
Dapper
Wishlist
Unassigned
Edgy
Wishlist
Unassigned

Bug Description

After installing edgy on Compal HGL30 and HGL31 lapotps, the Realtek ethernet controller seems supported and appears in the output of ifconfig -a. However, no IP address is assigned automatically to the interface on a network where a DHCP server is running. So, dhclient needs to be called manually and an IP address is then assigned to the interface.

This happens for both machines which have exactly the same ethernet controller. This also happens consistently after each reboot.

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Ben Collins (ben-collins) wrote :

Please attach these additional files from a fresh boot (create the files before bringing up the network manually)

/etc/network/interfaces
dmesg
ps axu

Does static configuration work? Can you please add /etc/network/interface?

Fabio

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

Configuring the following static interface works automatically when booting the machine:

auto eth0
iface eth0 inet static
        address 192.168.2.121
        netmask 255.255.255.0
        network 192.168.2.0
        broadcast 192.168.2.255
        gateway 192.168.2.10

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

iface eth0 inet dhcp

Why is "auto eth0" missing?

What if you add it? does it work?

Fabio

Marc Tardif (cr3) wrote :

After performing some additional testing, the problem only occurs with the edgy alternate install and not with the desktop install. During the alternate install, the following message appears:

[!] Configure the network
No network interfaces detected
No network interfaces were found. The installation system was unable to find a network device.
You may need to load a specific module for your network card, if you have one. For this, go back to the network hardware detection step.

So, this is most likely what prevents the network controller from being configured properly in the interfaces file.

Also note that the desktop install failed once with the following message:

BUG: soft lockup detected on CPU#0!

This is the same problem logged in Bug #80502. However, the problem didn't happen during subsequent attempts of the edgy desktop install.

Can you check what kernel module is loaded with the live cdor a complete install?

It might be the module is just missing from CD.

Fabio

This isn't a kernel bug.

Changed in linux-source-2.6.17:
assignee: ben-collins → nobody
Colin Watson (cjwatson) wrote :

netcfg never emits an iface line without an auto line right above it. If that "iface eth0 inet dhcp" line was written automatically, then it wasn't by the installer. Marc, did you add this line by hand?

In any case, this isn't the main point of this bug, but I wanted to get it out of the way.

The previous comment was meant to say that we are not sure yet that it is a kernel bug.

Colin Watson (cjwatson) wrote :

Edgy's r8169 driver did not include the PCI ID in use here (10EC:8168). Therefore, this *is* a kernel bug.

Feisty's kernel does include this PCI ID, and should work.

Probably the new PCI ID has been made available to the public after .17 release.

Changed in linux-source-2.6.17:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Wishlist

The missing module in the udeb is the r1000 (.17) and it's already included in feisty udebs.

Fabio

Changed in linux-source-2.6.17:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Kyle McMartin (kyle) wrote :

This was an oversight, and r1000.ko wasn't included in nic-modules. Fix committed for eventual inclusion in -stable if a point release is done.

Changed in linux-source-2.6.17:
status: Confirmed → Fix Committed
Kyle McMartin (kyle) wrote :

Fix committed for dapper too. Oops.

Changed in linux-source-2.6.17:
status: Confirmed → Fix Committed
Changed in linux-source-2.6.15:
status: Unconfirmed → Fix Committed
importance: Undecided → Wishlist
Changed in linux-source-2.6.17:
importance: Undecided → Wishlist
status: Unconfirmed → Fix Committed
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Wishlist
status: Unconfirmed → Fix Committed
importance: Undecided → Wishlist
status: Unconfirmed → Fix Committed
Valentijn Sessink (valentijn) wrote :

Well, of course we're waiting for the fix to be in the next point-release, but for those of you that can't wait, here's a quick half-scripted way to get the r1000.ko module in your initrd.gz. It's not tested for completeness, so there could be typos in it, but the result will work.

initrdfile="where/is/your/initrd.gz"
# download kernel, the one that is used in the latest initrd
# there might be better or other ways to do this (I never really figured out how to download something with Apt in the current directory)
# anyway, this works.
sudo apt-get install -d linux-image-2.6.15-26-386
# goto a temp directory
kerneldir=`mktemp -d`
initrdtmp=`mktemp -d`
cd $kerneldir
# unpack kernel
ar x /var/cache/apt/archives/linux-image-2.6.15-26-386_2.6.15-26.47_i386.deb
# now unpack your favorite initrd
cd $initrdtmp
zcat $initdrfile|cpio -i
tar -zxf $kerneldir/data.tar.gz lib/modules/2.6.15-26-386/kernel/drivers/net/r1000.ko
find ./ | cpio -H newc -o |gzip >> ../initrd.new.gz
# now remove $kerneldir and $initrdtmp if you want - or leave this to tmpreaper :)
# the script above is a hack, but it might help some of you (especially when installing from the net, as I do :)

Martin Pitt (pitti) wrote :

Closing bogus tasks.

Changed in linux-source-2.6.15:
status: Fix Committed → Invalid
Changed in linux-source-2.6.17:
status: Fix Committed → Invalid
Changed in linux-source-2.6.15:
status: Fix Committed → Invalid
Changed in linux-source-2.6.17:
status: Fix Committed → Invalid
Martin Pitt (pitti) wrote :

This sounds worth considering for the dapper point release. Can you please give a pointer to the patch here? (GIT URL, or an attachment).

Setting back to Triaged because 'fix committed' means 'in -proposed' for SRUs.

Changed in linux-source-2.6.15:
assignee: ubuntu-kernel-team → nobody
status: Fix Committed → Triaged
Martin Pitt (pitti) on 2007-07-23
Changed in linux-source-2.6.15:
assignee: nobody → ubuntu-kernel-team
Martin Pitt (pitti) wrote :

According to Kyle this is a simple one-liner:

<kyle> it was just adding r1000 to the nic-modules udeb iirc

Changed in linux-source-2.6.15:
assignee: ubuntu-kernel-team → ben-collins
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

linux-source-2.6.15 (2.6.15-51.63) dapper-proposed; urgency=low

  * Fix kernel-versions for ABI bump
  * Fix for kernel crash on lvremove
    - LP: #103729
  * e1000: Disable MSI by default. Allow it to be enabled with module param.
    Some chip implementations seem to not work well with MSI.
    - LP: #56885
  * tg3: Backport from 2.6.16.y
    - LP: #72696
  * Add r1000 to nic-modules
    - LP: #81782
  * Add bnx2 to nic-modules
    - LP: #73647
  * usb-serial: Fix oops with pilot-link
    - LP: #39518
  * megaraid: Move AMI/Megaraid3 IDs from megaraid_mbox.ko to megaraid.ko
    - LP: #57233

 -- Ben Collins <email address hidden> Tue, 23 Oct 2007 16:57:09 -0400

Please test and give feedback here.

Martin Pitt (pitti) wrote :

r1000 module is included in current nic-modules. Based on the observations of the previous comments I consider this verified, in absence of real-hardware testing feedback.

Martin Pitt (pitti) wrote :

Not interesting enough any more for Edgy.

Changed in linux-source-2.6.17:
milestone: edgy-updates → none
status: Fix Committed → Won't Fix
Martin Pitt (pitti) wrote :

Fixed kernel is in dapper-updates now.

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers