suspend-to-ram high power upon resume + ehci_hcd

Bug #61586 reported by Dave Rosky on 2006-09-21
4
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.15-27-686

This bug applies to dapper, I haven't tested edgy.

On this laptop (Dell Inspiron 9400), suspend to ram and resume appears to work, but I noticed that the idle power is much higher upon resume than before suspending (around 25% higher). Note, the cpu usage is normal upon resume (~100% idle), and the C states look normal.

I tried many things, but finally traced the problem down to the USB system, in particular ehci_hcd. I tried removing all USB modules before suspending, and when I resumed, the power was normal. I then started re-inserting the USB modules. I first re-inserted uhci_hcd and the power stayed normal (and the USB mouse got detected). I then re-inserted ehci_hcd and the abnormally high power returned.

I don't know if this is a problem with hardware or with the driver. Is there a way of resetting the USB controller hardware after a resume? If there is, I can try that.

Dave

Dave Rosky (d-rosky) wrote :

An additional observation:

On the same laptop (Inspiron 9400), SuSE 10.1 can suspend-to-ram and resume without the abnormally high power upon resume.

Dave

Dave Rosky (d-rosky) wrote :

Changed package to acpi-support since most suspend problems seem to be assigned to that category.

Matthew Garrett (mjg59) wrote :

No, kernel bugs should be assigned to the kernel.

Dave Rosky (d-rosky) wrote :

OK, thanks, I wasn't sure.

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in linux-source-2.6.15:
status: New → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux-source-2.6.15:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers