sound problem with realtek alc850 on nforce4

Bug #58832 reported by minority on 2006-09-04
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.15 (Ubuntu)
Undecided
Unassigned

Bug Description

I have a realtek alc 850 with my motherboard. I can't have 5.1 sound. A "speaker-test -c 6" give me sound on bad speaker : no prob on front speakers, no sound on rear speakers, LFE on rear right, and center on rear right!!! However option "duplicate front" works very well in stereo, I'have sound on rear speakers... I'don't understand....

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you?
Thanks in advance.

Changed in linux-source-2.6.15:
status: New → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux-source-2.6.15:
status: Incomplete → Invalid
Dominique Belhachemi (domibel) wrote :

A quick test on hardy gave the same result.
Front speakers works fine.
No signal on the other channels: Rear speakers, Center and Subwoofer

Changed in linux-source-2.6.15:
status: Invalid → Confirmed

On Hardy, care to make sure you have linux-ubuntu-modules installed as it has an updated version of ALSA.

Also, this may sound silly but have you also made sure your volume controls are all enabled and unmuted? You can run something like gnome-volume-control and go to Edit->Preferences.

If the issue still exists, per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies .

Also please note that we will keep this open against the actively developed kernel but against 2.6.15 this will be closed. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.15:
status: Confirmed → Won't Fix
Dominique Belhachemi (domibel) wrote :
Dominique Belhachemi (domibel) wrote :
Dominique Belhachemi (domibel) wrote :
Dominique Belhachemi (domibel) wrote :

Also care to attach the ouput of alsa-info.sh as described in the "Automatic Sound Information Collection" section in https://wiki.ubuntu.com/DebuggingSoundProblems . Thanks!

Dominique Belhachemi (domibel) wrote :
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Eje Svensson (eje) wrote :

First test to run "speaker-test -c 6 -Dhw:0,0"
In my case I get the expected results (5.1 sound) when I do that.

A tips is to have the speaker test enabled as one plays with the mixer settings.

I have created an asound.conf for just alc850.
It also upmixes the sound to 5.1 and allows multiple programs to use the soundcard at the same time.

Look at my post here:
http://ubuntuforums.org/showthread.php?p=4690673#post4690673

Phenex (hkandshawn) wrote :

Hello.

I have the same issue and have scoured the internet for a week trying to get this resolved. When I read the comments here I laughed so hard I almost spit coke out of my nose and knocked over one of my LCD's.. This is a real problem and to have so many people with it I find it hard to believe that this would be closed saying it's because something is muted or basically your a noob go unmute your audio. Now please do not take these comments the wrong way I am not attacking anyone but I sure am frustrated. so take a look at this please

A8N-SLI Deluxe Specs
URL for full specs: http://www.asus.com/products.aspx?modelmenu=2&model=375&l1=3&l2=15&l3=148&l4=0

-Supports AMD Socket 939 Athlon 64FX/Athlon 64 X2/Athlon 64
- NVIDIA nForce4 SLI
- PCI Express Architecture
- SATA 3Gb/s
- Dual RAID
- Dual Gigabit LAN & AI NET2
- NV Firewall
- AI NOS™
- AI Audio (8-channel Audio) <-----Please note

Chipset

NVIDIA nForce 4 SLI MCP

Audio

Realtek ALC850, 8 -Channel CODEC
Coaxial / Optical S/PDIF out ports
Audio Sensing and Enumeration Technology

Currently a fresh install of ubuntu workstation 8.0.4 and it is updated. I have all my sound options maxed and unmuted and I get squat out of my speakers. I have to put my ear on one of the rear speakers to hear a barely audible sound. If I have to I will make a video with my camera to prove it is failing I will but this is ridicules.

Phenex (hkandshawn) wrote :
Phenex (hkandshawn) wrote :
Phenex (hkandshawn) wrote :
Phenex (hkandshawn) wrote :
Phenex (hkandshawn) wrote :

So can someone either tell me what I have done wrong or if there is a specific way to solve this issue. and please I beg you don't give me the india programmer reply of there is no issue and works as designed. I get enough of that crap at work. LOL there has to be a way to resolved this, If I was not mostly a noob at linux and could program I would fix it myself but I am not. Thank you

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

braweheart (braweheart) wrote :

I can confirm this bug on a clean Install with Intrepid, . With "Duplicate front" I was able to get stereosound from the front speakers

It's not my computer so I don't have access to it every day, but I will attach output from the above commands when I get a chance to.

The motherboard is an Asus A8n SLI Premium, and according to http://www.asus.com/products.aspx?l1=3&l2=15&l3=148&l4=0&model=539&modelmenu=2 it has the is Realtek ALC850

braweheart (braweheart) wrote :

After playing around with settings and volume meters, I now get sound from three speaker, front left has very low volume but I suppose this could possibly be hardware error in the motherboard (speaker itself works fine).

I have to choose device "nvidia CK804" to see all available volume meters. Alsa-mixer shows only two meters, both at maximum and not muted.

Center channel does not produce (speaker works).

Surround doesn't work

braweheart (braweheart) wrote :
braweheart (braweheart) wrote :
braweheart (braweheart) wrote :

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete

The bug expires tomorrow. I would suggest not to close it. I am not able to get 5.1 surround sound although my hardware supports that and it worked with windows.

You'll find my sound configuration here: http://www.alsa-project.org/db/?f=24539206be2239bf5ec5e56a8eb860f1a461cbc8

I already posted a question: https://answers.launchpad.net/alsa-driver/+question/96374

So... any suggestions?

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions