ACPI: Looking for DSDT ... not found! (message during boot)

Bug #58386 reported by jerryb on 2006-08-31
48
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux (Ubuntu)
Low
Colin Ian King
linux-source-2.6.15 (Ubuntu)
Wishlist
Unassigned
linux-source-2.6.22 (Ubuntu)
Wishlist
Unassigned

Bug Description

on my ASUS M2nPV-VM mainboard with AMD64-X2 CPU running 2.6.15.26, I receive this error message:

ACPI: Looking for DSDT ... not found!

I filed this as a kernel bug

http://bugzilla.kernel.org/show_bug.cgi?id=7089

but was told that:

"This message is not in the kernel.org kernel source tree, either
as of 2.6.15, or as of 2.6.18. While your system seems to have
plenty of other problems, ACPI did find the DSDT and it is running
normally.

"I expect this message comes from the "initrd DSDT override patch"
that some distributions, such as SuSE and Ubuntu tend to add to
the kernel."

Since this is apparently not a real kernel bug, but something to do with ubuntu's initrd, I am posting the bug here

Henk Koster (h-a-j-koster) wrote :

I like to add that this message still appears in the 2.6.17-10-generic (amd64 or x86_64) kernel in Edgy Beta. Yet, earlier in the boot messages it appears that ACPI: DSDT ... is indeed found and used. The file /proc/acpi/dsdt is indeed present, and not empty.

As a matter of interest, I also use a 2.6.17 (amd64) kernel on a Gentoo box, here the offending message is absent. So, it would indeed appear the result of some Ubuntu patch.

Russ (russelldyson) wrote :
Download full text (20.6 KiB)

System: IBM T22, Ubuntu Edgy, 256MB RAM

Using Edgy, when I boot my system I get far more frequent fsck checks than I ever used to on Dapper....it seems to do it nearly every boot, not every 30 or so mounts as it used to.

Anyway, after the fsck check I get an error stating:

ACPI: Fatal Opcode Executed

It has a bunch of number that precede the error, for example:

[009087763:977683] ACPI: Fatal Opcode Executed.

These numbers aren't the exact example (I just made them up). It is hard to log down the actual numbers during boot because it passes quickly once the error appears and edgy boots into X.

Can anyone tell me what this problem is? Is it serious, as in Fatal!? Is there a solution? I was advised to comment here by Alan Pope who was responding to my initial enquiry here:

https://launchpad.net/distros/ubuntu/+ticket/2732

Here's the output of the boot log, near the bottom you can see the fatal opcode entries:

[17179569.184000] Linux version 2.6.17-10-generic (root@vernadsky) (gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)) #2 SMP Fri Oct 13 18:45:35 UTC 2006 (Ubuntu 2.6.17-10.33-generic)
[17179569.184000] BIOS-provided physical RAM map:
[17179569.184000] BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
[17179569.184000] BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
[17179569.184000] BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
[17179569.184000] BIOS-e820: 0000000000100000 - 000000000fff0000 (usable)
[17179569.184000] BIOS-e820: 000000000fff0000 - 000000000fffec00 (ACPI data)
[17179569.184000] BIOS-e820: 000000000fffec00 - 0000000010000000 (ACPI NVS)
[17179569.184000] BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
[17179569.184000] 0MB HIGHMEM available.
[17179569.184000] 255MB LOWMEM available.
[17179569.184000] On node 0 totalpages: 65520
[17179569.184000] DMA zone: 4096 pages, LIFO batch:0
[17179569.184000] Normal zone: 61424 pages, LIFO batch:15
[17179569.184000] DMI 2.3 present.
[17179569.184000] ACPI: RSDP (v000 PTLTD ) @ 0x000f7160
[17179569.184000] ACPI: RSDT (v001 PTLTD RSDT 0x06040000 LTP 0x00000000) @ 0x0fff4d07
[17179569.184000] ACPI: FADT (v001 IBM TP-T21 0x06040000 0x00000000) @ 0x0fffeb65
[17179569.184000] ACPI: BOOT (v001 PTLTD $SBFTBL$ 0x06040000 LTP 0x00000001) @ 0x0fffebd9
[17179569.184000] ACPI: DSDT (v001 IBM TP-T21 0x06040000 MSFT 0x0100000c) @ 0x00000000
[17179569.184000] ACPI: PM-Timer IO Port: 0x1008
[17179569.184000] Allocating PCI resources starting at 20000000 (gap: 10000000:eff80000)
[17179569.184000] Built 1 zonelists
[17179569.184000] Kernel command line: root=/dev/hda1 ro quiet splash
[17179569.184000] Local APIC disabled by BIOS (or by default) -- you can enable it with "lapic"
[17179569.184000] mapped APIC to ffffd000 (0120a000)
[17179569.184000] Enabling fast FPU save and restore... done.
[17179569.184000] Enabling unmasked SIMD FPU exception support... done.
[17179569.184000] Initializing CPU#0
[17179569.184000] PID hash table entries: 1024 (order: 10, 4096 bytes)
[17179569.184000] Detected 796.625 MHz processor.
[17179569.184000] Using pmtmr for high-res timesource
[17179569.184000] Console: colour VGA+ 80x25
[17179572.020000] Dentry cache ...

Rouben (rouben) wrote :

This is not a definite fix, but rather a workaround. Try disabling ACPI altogether. There's a nice forum thread on the topic: http://ubuntuforums.org/showthread.php?t=2620

Another thing to try is to dig around in your motherboard's BIOS, since most motherboards nowadays have Linux listed as one of the choices under "Installed OS". Also check the motherboard manufacturer's website to see if there is a BIOS upgrade available for your motherboard.

Please let me know if this fixes the issue and good luck!

My bios only has a switch for the OS type: OS2/Non-OS2 -- I set it to
Non-OS2.

I'll give the disabling ACPI thing a shot, though actually I DO want to use
it. The kernel bug team confirmed that the problem is ubuntu's initrd since
the message can't be found in any kernel source. Other than the weird
message, the system runs fine

On 12/15/06, Rouben <email address hidden> wrote:
>
> This is not a definite fix, but rather a workaround. Try disabling ACPI
> altogether. There's a nice forum thread on the topic:
> http://ubuntuforums.org/showthread.php?t=2620
>
> Another thing to try is to dig around in your motherboard's BIOS, since
> most motherboards nowadays have Linux listed as one of the choices under
> "Installed OS". Also check the motherboard manufacturer's website to see
> if there is a BIOS upgrade available for your motherboard.
>
> Please let me know if this fixes the issue and good luck!
>
> --
> ACPI: Looking for DSDT ... not found! (message during boot)
> https://launchpad.net/bugs/58386
>

Rouben (rouben) wrote :

Dear Jeremie,

Since you were listed as the uploader of initrd-tools, I'm hoping you can help. I'd like to figure out two things:
1. Was the package initrd-tools imported directly from Debian?
2. As indicated in the Linux kernel bug report ( http://bugzilla.kernel.org/show_bug.cgi?id=7089#c6 ), this is most likely an issue with this package. As such, should this be referred to Debian bugzilla or was this a locally (Ubuntu-only) change?

Thanks!

Changed in initrd-tools:
assignee: nobody → jcorbier
status: Unconfirmed → Confirmed
Matthew Garrett (mjg59) wrote :

The message is a harmless indication that no DSDT was found in the initramfs.

Changed in initrd-tools:
status: Confirmed → Rejected
Changed in linux:
status: Unknown → Rejected
Bogdan Butnaru (bogdanb) wrote :

Re-opening (I think). Even if this is not a real "error" (ie, if not having a DSDT is a normal situation), this is still a user-interface bug: it should not be reported as a boot-time error. The message should be changed to something more descriptive, like "file /DSDT.aml not found, using defaults" or whatever is appropriate.

I couldn't find any recent docs on this, what is it supposed to do, anyway? I'm always having issues with ACPI and I'm always on the look for hacks. Is there anything I can do (ie, compile a file) and perhaps include it in a package to help support my laptop type better (Dell Latitude D620).

I'm attaching 2.6.22 too, as I still get this message on Gutsy with the newest kernel.

Changed in linux-source-2.6.15:
status: Invalid → New
Changed in linux-source-2.6.15:
assignee: jcorbier → nobody
TJ (tj) wrote :

The purpose of this optional kernel feature, enabled by "CONFIG_ACPI_CUSTOM_DSDT_INITRD=y" in the kernel .config at build-time, is to allow the user to replace the BIOS Advanced Configuration & Power Interface (ACPI) Differentiated System Description Table (DSDT) with one that has been modified to solve problems in the BIOS shipped by manufacturers.

The message you see is correct. As far as the kernel is concerned it is an error because it is told to expect to find a replacement DSDT.aml and it isn't there. However the message could be altered somewhat to make it sound less harsh.

Once a modified DSDT has been built using the Intel iasl tool it is copied to /etc/initramfs-tools/DSDT.aml and the initrd image rebuilt:

$ sudo dpkg-reconfigure linux-image-$(uname -r)

This installs the DSDT to /DSDT.aml in the initrd image.

The functionality (and messages you see) is implemented in drivers/acpi/osl.c::acpi_find_dsdt_initrd(void)

For more information, see: https://help.ubuntu.com/community/ACPIBattery

TJ (tj) wrote :

Update to reflect status for 2.6.22

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-acpi
importance: Undecided → Wishlist
status: New → Confirmed
Changed in linux-source-2.6.15:
assignee: nobody → ubuntu-kernel-acpi
importance: Undecided → Wishlist
status: New → Won't Fix

This bug does not qualify as a stable release update candidate for Gutsy and is being closed. Thanks.

Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Linard Verstraete (linardv) wrote :

Still there in Hardy

Changed in linux-source-2.6.24:
assignee: nobody → ubuntu-kernel-acpi
Matt Zimmerman (mdz) wrote :

The problem here is that the message is not clear enough. It looks like an error message, but it is not. In fact, nearly every Ubuntu system logs this message on every boot.

It simply means that there is no DSDT override included in the initramfs, and it should say that instead. This should be a one-line patch. I suggest:

ACPI: Checking for DSDT override... (none found)

Changed in linux:
importance: Undecided → Low
status: New → Triaged
Mark Falcey (mfalcey) wrote :

Well, the message says error so what should people expect.

I found this while perusing the logs after upgrading to 2.6.24-18.32 generic about an hour ago:

ACPI: Looking for DSDT in initramfs... error, file /DSDT.aml not found.

On Wed, Jun 04, 2008 at 12:15:24AM -0000, Mark Falcey wrote:
> Well, the message says error so what should people expect.

It may not have been sufficiently clear from my comment, but I was
suggesting changing it (including removing the word "error") for that
reason.

--
 - mdz

vmc (vmclark) wrote :

I have a Dell Optiplex GX270. When I grep the dmesg I get the error that this bug report shows.

I then did this:
~ sudo cp /proc/acpi/dsdt .
~ sudo iasl -d dsdt
~ sudo iasl -sa dsdt.ds

After it compiles I get this Warning:

dsdt.dsl 1052: Method (_S5D, 0, NotSerialized)
Warning 1097 - Unknown reserved name ^ (_S5D)

ASL Input: dsdt.dsl - 3213 lines, 108415 bytes, 1051 keywords
AML Output: dsdt.aml - 9858 bytes 394 named objects 657 executable opcodes

Compilation complete. 0 Errors, 1 Warnings, 0 Remarks, 257 Optimizations

I tried tracking down "Method (_S5D", but couldn't find anything. I get close but no cigar.

Changed in linux:
assignee: ubuntu-kernel-acpi → colin-king
status: Triaged → In Progress
Changed in linux:
status: In Progress → Fix Committed

Setting this to Fix Released for Intrepid as I believe the message has been reworded to "ACPI: Checking initramfs for custom DSDT" . Thanks.

Changed in linux:
status: Fix Committed → Fix Released
Changed in linux:
importance: Unknown → Medium
Curtis Hovey (sinzui) on 2012-04-09
Changed in linux-source-2.6.15 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
Changed in linux-source-2.6.22 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.