Minor revision 2.6.15-26 doesn't detect attached SCSI disks to LSI 1030ST

Bug #57233 reported by Vide on 2006-08-22
24
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
High
Ben Collins

Bug Description

Binary package hint: linux-image-2.6-386

I own a Dell PowerEdge 1600SC with a LSI 1030ST controller and I can't see the attached disk with the latest Dapper kernel image revision, while wi th standard 6.06 version (2.6.15-23) I can mount the disk smoothly.

Vide (vide80) wrote :
Vide (vide80) wrote :
Vide (vide80) wrote :

I can say that even with more recent kernels (2.6.17 on latest knoppix, for example) I cannot see the disk, while with Ubuntu 2.6.15-23 (server or desktop flavour) as said, it works.

Vide (vide80) wrote :

Here it is lspci output

0000:00:00.0 Host bridge: Broadcom GCNB-LE Host Bridge (rev 32)
0000:00:00.1 Host bridge: Broadcom GCNB-LE Host Bridge
0000:00:02.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
0000:00:0e.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
0000:00:0f.0 Host bridge: Broadcom CSB5 South Bridge (rev 93)
0000:00:0f.1 IDE interface: Broadcom CSB5 IDE Controller (rev 93)
0000:00:0f.2 USB Controller: Broadcom OSB4/CSB5 OHCI USB Controller (rev 05)
0000:00:0f.3 ISA bridge: Broadcom CSB5 LPC bridge
0000:00:10.0 Host bridge: Broadcom CIOB-X2 PCI-X I/O Bridge (rev 05)
0000:00:10.2 Host bridge: Broadcom CIOB-X2 PCI-X I/O Bridge (rev 05)
0000:01:02.0 RAID bus controller: American Megatrends Inc. MegaRAID (rev 02)
0000:01:04.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 07)

Kyle McMartin (kyle) wrote :

Hi, we need "lspci -vvn" output to be able to debug this further.

Thanks,
 Kyle

Kyle McMartin (kyle) wrote :

btw, your drives are attached to the megaraid controller, not the 1030.

Ben Collins (ben-collins) wrote :

Kyle is looking into this and creating some test packages. Looks like some PCI ids got moved around to the wrong driver.

Changed in linux-source-2.6.15:
assignee: nobody → kyle
importance: Undecided → Medium
status: New → In Progress
Vide (vide80) wrote :
Download full text (6.0 KiB)

0000:00:00.0 0600: 1166:0017 (rev 32)
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-

0000:00:00.1 0600: 1166:0017
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-

0000:00:02.0 0200: 8086:100e (rev 02)
        Subsystem: 1028:0135
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (63750ns min), Cache Line Size: 0x10 (64 bytes)
        Interrupt: pin A routed to IRQ 193
        Region 0: Memory at fe100000 (32-bit, non-prefetchable) [size=128K]
        Region 2: I/O ports at ecc0 [size=64]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=1 PME-
        Capabilities: [e4] PCI-X non-bridge device.
                Command: DPERE- ERO+ RBC=0 OST=0
                Status: Bus=0 Dev=0 Func=0 64bit- 133MHz- SCD- USC-, DC=simple, DMMRBC=2, DMOST=0, DMCRS=1, RSCEM-
        Capabilities: [f0] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000 Data: 0000

0000:00:0e.0 0300: 1002:4752 (rev 27)
        Subsystem: 1028:0135
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop+ ParErr- Stepping+ SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (2000ns min), Cache Line Size: 0x10 (64 bytes)
        Region 0: Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: I/O ports at e800 [size=256]
        Region 2: Memory at fe121000 (32-bit, non-prefetchable) [size=4K]
        Expansion ROM at 60000000 [disabled] [size=128K]
        Capabilities: [5c] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

0000:00:0f.0 0600: 1166:0201 (rev 93)
        Subsystem: 1166:0201
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 32

0000:00:0f.1 0101: 1166:0212 (rev 93) (prog-if 8a [Master SecP PriP])
        Subsystem: 1028:4135
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64, Cache Line Size: 0x08 (32 bytes)
        Region 0: I/O ports at <ignored>
        Region 1: I/O ports at <ignored>
        Region 2: I/O ports at <ignored>
        Region 3: I/O ports at <ignored>
        Region 4: I/O ports at 08b0 [size=1...

Read more...

Martin Pitt (pitti) wrote :

This is a regression in a dapper security update and should be fixed for the Dapper point release.

Martin Pitt (pitti) wrote :

One-liner fix, doable for dapper.2.

Changed in linux-source-2.6.15:
assignee: kyle → ben-collins
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

linux-source-2.6.15 (2.6.15-51.63) dapper-proposed; urgency=low

  * Fix kernel-versions for ABI bump
  * Fix for kernel crash on lvremove
    - LP: #103729
  * e1000: Disable MSI by default. Allow it to be enabled with module param.
    Some chip implementations seem to not work well with MSI.
    - LP: #56885
  * tg3: Backport from 2.6.16.y
    - LP: #72696
  * Add r1000 to nic-modules
    - LP: #81782
  * Add bnx2 to nic-modules
    - LP: #73647
  * usb-serial: Fix oops with pilot-link
    - LP: #39518
  * megaraid: Move AMI/Megaraid3 IDs from megaraid_mbox.ko to megaraid.ko
    - LP: #57233

 -- Ben Collins <email address hidden> Tue, 23 Oct 2007 16:57:09 -0400

Please test and give feedback here.

Vide (vide80) wrote :

Just upgrade from dapper-proposed to 2.6.15-51.63and now I've got a kernel panic. I attach the screenshot of the panic

Martin Pitt (pitti) wrote :

Bumping back to confirmed, since it didn't seem to have helped.

Changed in linux-source-2.6.15:
status: Fix Committed → Confirmed
Ben Collins (ben-collins) wrote :

Do you have linux-backports-modules installed as well? I suspect you'll need this installed by default. We may have to make sure upgrades work in this case for dapper.2 kernel.

Vide (vide80) wrote :

Ok, I was missing linux-backports-modules-server, once installed, the system booted up, and now is up & running with all the disks correctly detected. Thanks for the fix! :)

Martin Pitt (pitti) wrote :

Vide, that's more like a workaround. Thank you for testing!

So it seems that some modules are not shuffled between linux-image and linux-backports-modules properly. Upgrades must not break when l-b-m is not installed (which is the entire point of having a separate l-b-m).

Vide (vide80) wrote :

Ok, this seemed strange to me in fact... well, I'll wait for a linux-modules-server update in the proposed updates repo, let me know when there are news, it's a non-production machine so I can reboot it quite easily if you need more testing

Matt Zimmerman (mdz) wrote :

Update from the kernel team regarding this bug? Ben?

Ben Collins (ben-collins) wrote :

Since this was caused by what was hoped to fix the problem (moving PCI id's), the regression appears to be worse than the fix. Reverting back to previous PCI id layout.

As a side note, the updated megaraid driver in linux-backports-modules-2.6.15 will hopefully fix this problem, without the regression. However, current build of the package has another bug preventing megaraid from being loaded.

Working on an updated package to test this from.

Changed in linux-source-2.6.15:
importance: Medium → High
status: Confirmed → In Progress
Ben Collins (ben-collins) wrote :

Please try using this package with 2.6.15-51-686 kernel:

http://kernel.ubuntu.com/~bcollins/linux-backports-modules-2.6.15-51-686_2.6.15-51.3_i386.deb

Check for this line in dmesg:

Fusion MPT base driver 3.03.09

Martin Pitt (pitti) wrote :

Ben, doesn't this need a newer linux-source-2.6.15, too? I cannot find it at the URL you gave above.

Also, do you have the source package somewhere? I need to build amd64 packages.

Thank you!

Ben Collins (ben-collins) wrote :

No, you just need the linux-image2.6.15-51-686 from the archive. If you need source, it's available via git from http://kernel.ubuntu.com/git (look for ubuntu/ubuntu-dapper-lbm)

Fabián Rodríguez (magicfab) wrote :

I am working on a test environment to check this, will provide feedback as I get it.

Fabián Rodríguez (magicfab) wrote :

When I try the package it complains about dependency on the -686 image. I am trying to help a customer test this but they only have a-server image installed. Can you provide a -server package ?

Martin Pitt (pitti) wrote :

Fabian, there is linux-backports-modules-2.6.15-51-server, too.

Fabián Rodríguez (magicfab) wrote :

I ran into another problem. After (mistankingly) trying to install the -686 package, I couldn' t seem to remove it. I had to do this:

1) sudo touch /lib/modules/2.6.15-51-686
2) sudo dpkg -r linux-backports-modules-2.6.15-51-686
You should get a FATAL error, however it will remove part of the package

3) sudo dpkg --purge linux-backports-modules-2.6.15-51-686
You should now get complete removal. Issuing this last command again will give an error about unexisting package confirming its complete removal.

We tried the proposed fix and it didn't work. I am waiting for a copy of the output of initial booting sequence, although it didn't get very far.

Martin Pitt (pitti) wrote :

Marc also did the test on the LSI controller and ran into the same problem when RAID was actually enabled. Without RAID it works fine.

Changed in linux-source-2.6.15:
milestone: ubuntu-6.06.2 → dapper-updates
status: In Progress → Confirmed
Changed in linux-source-2.6.15 (Ubuntu):
status: Confirmed → Invalid
Vide (vide80) wrote :

why did you mark this as invalid?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers