Ubuntu

Activity log for bug #56885

Date Who What changed Old value New value Message
2006-08-19 09:18:00 Herbert V. Riedel bug added bug
2006-08-19 15:17:27 Mark Reitblatt linux-source-2.6.15: importance Untriaged Medium
2006-08-19 15:17:27 Mark Reitblatt linux-source-2.6.15: statusexplanation
2006-09-20 23:14:29 Ben Collins linux-source-2.6.15: status Unconfirmed Fix Committed
2006-09-20 23:14:29 Ben Collins linux-source-2.6.15: assignee ben-collins
2006-09-20 23:14:29 Ben Collins linux-source-2.6.15: statusexplanation This change will show up soon in dapper-proposed. I didn't remove the capability for MSI to work, but it's disabled by default now. Re-enable by doing enable_msi=1 when loading the module (for anyone that knows it works, or wants to find out).
2006-09-20 23:15:38 Ben Collins bug assigned to linux-source-2.6.17 (Ubuntu)
2006-09-20 23:17:01 Ben Collins linux-source-2.6.17: status Unconfirmed Fix Committed
2006-09-20 23:17:01 Ben Collins linux-source-2.6.17: assignee ben-collins
2006-09-20 23:17:01 Ben Collins linux-source-2.6.17: statusexplanation
2007-07-07 10:56:04 Marco Rodrigues linux-source-2.6.15: status Fix Committed Fix Released
2007-07-07 10:56:04 Marco Rodrigues linux-source-2.6.15: statusexplanation This change will show up soon in dapper-proposed. I didn't remove the capability for MSI to work, but it's disabled by default now. Re-enable by doing enable_msi=1 when loading the module (for anyone that knows it works, or wants to find out).
2007-07-07 11:51:21 Marco Rodrigues linux-source-2.6.15: status Fix Released Fix Committed
2007-07-07 12:00:45 Marco Rodrigues linux-source-2.6.15: status Fix Committed Fix Released
2007-07-07 12:01:01 Marco Rodrigues linux-restricted-modules-2.6.15: status New Fix Released
2007-07-07 12:01:01 Marco Rodrigues linux-restricted-modules-2.6.15: assignee ben-collins
2007-07-07 12:01:01 Marco Rodrigues linux-restricted-modules-2.6.15: statusexplanation
2007-07-07 12:27:27 Marco Rodrigues linux-restricted-modules-2.6.15: status Fix Released Invalid
2007-07-07 12:27:39 Marco Rodrigues linux-source-2.6.15: status Fix Released Fix Committed
2007-07-07 13:03:30 Marco Rodrigues linux-source-2.6.17: status Fix Committed Fix Released
2007-07-23 12:42:50 Martin Pitt linux-source-2.6.15: status Fix Committed In Progress
2007-10-17 15:12:54 Ben Collins linux-source-2.6.15: status In Progress Fix Committed
2007-10-24 07:46:43 Martin Pitt description on a freshly installed dapper/x86_64 install, the e1000 supported intel Intel Pro/1000 PT Server NIC was detected and configured, link gets detected, but it doesn't seem to receive ethernet frames (although the RX packet counters do increase, but no rx frame shows up in tcpdump) alas it's a remote system which I don't have physical access to right now, so I can't easily try out a 32bit kernel, in order to verify my suspicion that it's simply a 64bit-bug kernel driver bug... processor : 0 vendor_id : AuthenticAMD cpu family : 15 model : 36 model name : AMD Turion(tm) 64 Mobile Technology MT-37 stepping : 2 cpu MHz : 803.680 cache size : 1024 KB fpu : yes fpu_exception : yes cpuid level : 1 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm bogomips : 1609.81 TLB size : 1024 4K pages clflush size : 64 cache_alignment : 64 address sizes : 40 bits physical, 48 bits virtual power management: ts fid vid ttp tm stc 0000:00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1) (prog-if 00 [Normal decode]) Flags: bus master, fast devsel, latency 0 Bus: primary=00, secondary=02, subordinate=02, sec-latency=0 I/O behind bridge: 0000b000-0000bfff Memory behind bridge: f7000000-f8ffffff Prefetchable memory behind bridge: 0000000030000000-0000000030000000 Capabilities: <available only to root> 0000:02:00.0 Ethernet controller: Intel Corporation: Unknown device 107d (rev 06) Subsystem: Intel Corporation: Unknown device 1082 Flags: bus master, fast devsel, latency 0, IRQ 225 Memory at f8020000 (32-bit, non-prefetchable) [size=128K] Memory at f8000000 (32-bit, non-prefetchable) [size=128K] I/O ports at b000 [size=32] Expansion ROM at 30000000 [disabled] [size=128K] Capabilities: <available only to root> Linux version 2.6.15-26-amd64-generic (buildd@king) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 SMP PREEMPT Thu Aug 3 02:52:35 UTC 2006 [..] Intel(R) PRO/1000 Network Driver - version 7.0.33-k2 Copyright (c) 1999-2005 Intel Corporation. ACPI: PCI Interrupt Link [APC5] enabled at IRQ 16 ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [APC5] -> GSI 16 (level, low) -> IRQ 225 PCI: Setting latency timer of device 0000:02:00.0 to 64 e1000: 0000:02:00.0: e1000_probe: (PCI Express:2.5Gb/s:Width x1) 00:15:17:0b:ff:e5 e1000: eth2: e1000_probe: Intel(R) PRO/1000 Network Connection on a freshly installed dapper/x86_64 install, the e1000 supported intel Intel Pro/1000 PT Server NIC was detected and configured, link gets detected, but it doesn't seem to receive ethernet frames (although the RX packet counters do increase, but no rx frame shows up in tcpdump) alas it's a remote system which I don't have physical access to right now, so I can't easily try out a 32bit kernel, in order to verify my suspicion that it's simply a 64bit-bug kernel driver bug... processor : 0 vendor_id : AuthenticAMD cpu family : 15 model : 36 model name : AMD Turion(tm) 64 Mobile Technology MT-37 stepping : 2 cpu MHz : 803.680 cache size : 1024 KB fpu : yes fpu_exception : yes cpuid level : 1 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm bogomips : 1609.81 TLB size : 1024 4K pages clflush size : 64 cache_alignment : 64 address sizes : 40 bits physical, 48 bits virtual power management: ts fid vid ttp tm stc 0000:00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1) (prog-if 00 [Normal decode]) Flags: bus master, fast devsel, latency 0 Bus: primary=00, secondary=02, subordinate=02, sec-latency=0 I/O behind bridge: 0000b000-0000bfff Memory behind bridge: f7000000-f8ffffff Prefetchable memory behind bridge: 0000000030000000-0000000030000000 Capabilities: <available only to root> 0000:02:00.0 Ethernet controller: Intel Corporation: Unknown device 107d (rev 06) Subsystem: Intel Corporation: Unknown device 1082 Flags: bus master, fast devsel, latency 0, IRQ 225 Memory at f8020000 (32-bit, non-prefetchable) [size=128K] Memory at f8000000 (32-bit, non-prefetchable) [size=128K] I/O ports at b000 [size=32] Expansion ROM at 30000000 [disabled] [size=128K] Capabilities: <available only to root> Linux version 2.6.15-26-amd64-generic (buildd@king) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 SMP PREEMPT Thu Aug 3 02:52:35 UTC 2006 [..] Intel(R) PRO/1000 Network Driver - version 7.0.33-k2 Copyright (c) 1999-2005 Intel Corporation. ACPI: PCI Interrupt Link [APC5] enabled at IRQ 16 ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [APC5] -> GSI 16 (level, low) -> IRQ 225 PCI: Setting latency timer of device 0000:02:00.0 to 64 e1000: 0000:02:00.0: e1000_probe: (PCI Express:2.5Gb/s:Width x1) 00:15:17:0b:ff:e5 e1000: eth2: e1000_probe: Intel(R) PRO/1000 Network Connection
2008-01-16 12:41:45 Martin Pitt linux-source-2.6.15: status Fix Committed Fix Released