via82cxxx disables DMA on Asrock 775Dual-VSTA

Bug #56823 reported by Rob Fargher on 2006-08-18
2
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6-686

This is a feature request.

  Some mainboards (e.g. my Asrock 775Dual-VSTA) come with a
PCI_DEVICE_ID_VIA_82C586_1 IDE controller together with a VIA VT8237A
southbridge. While the corresponding PCI ID is already present in pci_ids.h, the via82cxxx driver doesn't know about it yet and disables DMA.

  There has been a kernel patch submitted for 2.6.18_rc4 at http://www.uwsg.iu.edu/hypermail/linux/kernel/0608.1/0771.html I'm requesting that it be integrated into the Dapper kernel.

Chuck Short (zulcss) wrote :

Ill add this.

Changed in linux-meta:
assignee: nobody → zulcss
Chuck Short (zulcss) wrote :

Looks like this already been commited

Changed in linux-source-2.6.15:
status: Unconfirmed → Fix Committed
Rob Fargher (fargher-gmail) wrote :

DMA is still disabled in Edgy Knot 2.

Rob Fargher (fargher-gmail) wrote :

Aha! DMA is working in kernel 2.6.17-7-generic.

Chuck Short (zulcss) wrote :

Thanks for the bug report.

Regards
chuck

Changed in linux-source-2.6.15 (Ubuntu):
assignee: Chuck Short (zulcss) → nobody
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers