Ubuntu

everything loads fine, but no sound, only 1 channel in alsamixer, part2

Reported by lithorus on 2006-08-16
4
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Daniel T Chen

Bug Description

I have the excact same problem as #33719, but with a VAIO AR11S which uses a different revision of the Intel 82801G. I'm using Edgy

output of /proc/asound/cards :

 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd6300000 irq 90
 1 [SAA7134 ]: SAA7134 - SAA7134
                      saa7133[0] at 0xd6006800 irq 90

output of /proc/asound/card0/codec#0 :

Codec: SigmaTel ID 7664
Address: 0
Vendor Id: 0x83847664
Subsystem Id: 0x104d1300
Revision Id: 0x100201
Default PCM: rates 0x7e0, bits 0x0e, types 0x1
Default Amp-In caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1
Default Amp-Out caps: ofs=0x7f, nsteps=0x7f, stepsize=0x02, mute=1
Node 0x02 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals: [0xff 0xff]
  Power: 0x0
Node 0x03 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals: [0xff 0xff]
  Power: 0x0
Node 0x04 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals: [0xff 0xff]
  Power: 0x0
Node 0x05 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals: [0x46 0x46]
  Power: 0x0
Node 0x06 [Audio Input] wcaps 0x1d0541: Stereo
  Power: 0x0
  Connection: 1
     0x07
Node 0x07 [Audio Selector] wcaps 0x300903: Stereo Amp-In
  Amp-In caps: N/A
  Amp-In vals: [0x0f 0x0f]
  Connection: 1
     0x0e
Node 0x08 [Audio Input] wcaps 0x1d0541: Stereo
  Power: 0x0
  Connection: 1
     0x09
Node 0x09 [Audio Selector] wcaps 0x300903: Stereo Amp-In
  Amp-In caps: N/A
  Amp-In vals: [0x80 0x80]
  Connection: 1
     0x15
Node 0x0a [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x08173c: IN OUT HP Detect
  Pin Default 0x0321101e: [Jack] HP Out at Ext Left
    Conn = 1/8, Color = Black
  Pin-ctls: 0x00:
  Connection: 1
     0x02
Node 0x0b [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x0814: OUT Detect
  Pin Default 0x400000fb: [N/A] Line Out at Ext N/A
    Conn = Unknown, Color = Unknown
  Pin-ctls: 0x00:
  Connection: 1
     0x04
Node 0x0c [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x0814: OUT Detect
  Pin Default 0x2021101f: [Jack] HP Out at Sep N/A
    Conn = 1/8, Color = Black
  Pin-ctls: 0x00:
  Connection: 1
     0x03
Node 0x0d [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x08173c: IN OUT HP Detect
  Pin Default 0x41a1502e: [N/A] Mic at Ext Rear
    Conn = 1/8, Color = Red
  Pin-ctls: 0x00:
  Connection: 1
     0x02
Node 0x0e [Pin Complex] wcaps 0x400081: Stereo
  Pincap 0x0824: IN Detect
  Pin Default 0x90370060: [Fixed] CD at Int N/A
    Conn = Analog, Color = Unknown
  Pin-ctls: 0x20: IN
Node 0x0f [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x0814: OUT Detect
  Pin Default 0xb2110010: [Fixed] Speaker at Oth Front
    Conn = 1/8, Color = Unknown
  Pin-ctls: 0x40: OUT
  Connection: 1
     0x05
Node 0x10 [Audio Output] wcaps 0x40211: Stereo Digital
  PCM: rates 0x3e0, bits 0x0e, types 0x5
Node 0x11 [Pin Complex] wcaps 0x400301: Stereo Digital
  Pincap 0x0810: OUT
  Pin Default 0x20455040: [Jack] SPDIF Out at Sep N/A
    Conn = Optical, Color = Red
  Pin-ctls: 0x00:
  Connection: 2
     0x10* 0x09
Node 0x12 [Audio Input] wcaps 0x140311: Stereo Digital
  PCM: rates 0x160, bits 0x0e, types 0x5
  Connection: 1
     0x13
Node 0x13 [Pin Complex] wcaps 0x440381: Stereo Digital
  Pincap 0x0834: IN OUT Detect
  Pin Default 0x40c000fd: [N/A] SPDIF In at Ext N/A
    Conn = Unknown, Color = Unknown
  Pin-ctls: 0x00:
  Connection: 1
     0x18
Node 0x14 [Pin Complex] wcaps 0x400001: Stereo
  Pincap 0x0820: IN
  Pin Default 0x90a7002e: [Fixed] Mic at Int N/A
    Conn = Analog, Color = Unknown
  Pin-ctls: 0x00:
Node 0x15 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=1
  Amp-Out vals: [0x00 0x00]
  Connection: 4
     0x0a* 0x0d 0x14 0x02
Node 0x16 [Beep Generator Widget] wcaps 0x70000c: Mono Amp-Out
  Amp-Out caps: ofs=0x03, nsteps=0x03, stepsize=0x17, mute=0
  Amp-Out vals: [0x00]
Node 0x17 [Volume Knob Widget] wcaps 0x600000: Mono
Node 0x18 [Audio Output] wcaps 0x40201: Stereo Digital

Daniel T Chen (crimsun) on 2006-08-17
Changed in alsa-driver:
importance: Untriaged → Medium
status: Unconfirmed → In Progress
Daniel T Chen (crimsun) wrote :
Changed in linux-source-2.6.15:
status: In Progress → Fix Committed
lithorus (lithorus) wrote :

Thanks for the patch, fiddled around with something similar myself with the newest alsa source, but also added a new line in the last section of patch_sigmatel.c.

{ .id = 0x83847664, .name = "STAC7661", .patch = patch_stac7661 },

Couldn't rebuild the Ubuntu package since the apt-src dependencies seems broken atm. :(

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
assignee: nobody → crimsun
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers