Ubuntu

Problem with HP Virtual Keyboard on DL320 on Dapper

Reported by Henrik Riomar on 2006-08-07
20
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: linux-source-2.6.15

I have a problem with Dapper Server on a HP DL320 G4 server that seems to be related to the iLO module.

The following is seen in syslog (in an endless loop):

[42949735.860000] usb 5-2: new full speed USB device using uhci_hcd and address 22
[42949736.010000] hub 5-2:1.0: USB hub found
[42949736.020000] hub 5-2:1.0: 7 ports detected
[42949736.130000] usb 5-1: USB disconnect, address 21
[42949736.410000] usb 5-1: new full speed USB device using uhci_hcd and address 23
[42949736.570000] input: HP Virtual Keyboard as /class/input/input646
[42949736.570000] input: USB HID v1.01 Keyboard [HP Virtual Keyboard] on usb-000 0:01:04.4-1
[42949736.590000] input: HP Virtual Keyboard as /class/input/input647
[42949736.590000] input: USB HID v1.01 Mouse [HP Virtual Keyboard] on usb-0000:0 1:04.4-1
[42949736.590000] usb 5-2: USB disconnect, address 22
[42949736.870000] usb 5-2: new full speed USB device using uhci_hcd and address 24
[42949737.020000] hub 5-2:1.0: USB hub found
[42949737.030000] hub 5-2:1.0: 7 ports detected
[42949737.140000] usb 5-1: USB disconnect, address 23
[42949737.420000] usb 5-1: new full speed USB device using uhci_hcd and address 25

After looking for solutions on the web it seems to be fixed in newer kernels and a patch is available (note: I have not verified this patch yet)
http://<email address hidden>/msg41847.html

Changed in linux-source-2.6.15:
assignee: nobody → ben-collins
status: Unconfirmed → Fix Committed
Stephan Adig (sadig) wrote :

Hi Henrik,

I can confirm this bug. For Dapper and Edgy.
Did you see also the strange behaviour, when booting directly with an USB CDRom that the kernel from Dapper/Edgy is stopping after finding the PS/2 Keyboard Controller?

Regards,

\sh

I can confirm this bug on a HP ProLiant ML310G4 with Ubuntu 6.06 LTS - it works with 6.10 (server).

Workaround:
When the installation hangs, switch to console 4 and unload the uhci usb module:

$ modprobe -r uhci_hcd

After that, the setup goes on. You'll have trouble again when booting into the installed system.
syslog and kern.log are getting bloated by the messages provided at the original bug report.
To avoid this, you have to unload the uhci module, make a new initrd and boot using the new initrd:

$ sudo rmmod uhci_hcd
$ sudo depmod -a
$ sudo mkinitramfs -o /boot/initrd.img-2.6.15-26-server-custom

modify the file "/boot/grub/menu.lst" and change the line 114:

initrd /boot/initrd.img-2.6.15-26-server
to
initrd /boot/initrd.img-2.6.15-26-server-custom

$ sudo grub-install hd0
$ sudo reboot

Note that this leads to a non-functional USB configuration. A patch to the Kernel has been done with 2.6.16.34 (vanilla).

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Ben Collins (ben-collins) wrote :

Check that this patch isn't already in dapper kernel. If not, we'll pull it in.

Changed in linux-source-2.6.15:
assignee: ben-collins → ubuntu-kernel-team
importance: Undecided → High
status: Fix Released → Triaged
Matthew Palmer (mpalmer) wrote :

This patch was added in 2.6.15-26.47, according to the current Dapper changelog. I'm just trying to work out how to easily create the new initrd and vmlinuz for the install CD, and I'll be testing this to see if the current version of the kernel (2.6.15-28.57) is OK.

Martin Pitt (pitti) wrote :

Right, so this should solve itself once we build new CDs.

Changed in linux-source-2.6.15:
status: Triaged → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers