Network route table vanishes intermittently

Bug #54763 reported by David Plumpton on 2006-08-01
4
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned

Bug Description

The route table intermittently loses all routing information, resulting in "Network unreachable" errors. Normally things work fine, and my ASDL modem connected via ethernet is problem free. Running the "route" command gives this:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
default 10.1.1.1 0.0.0.0 UG 0 0 0 eth0

But often (say 70% of the time) about 30 seconds after starting Azureus the route table is empty. All network communications fail, including pinging my modem. Azureus is not running as root. It should not be able to clear the route table.

The problem typically remains for one to five minutes, and then everything starts working by itself. The route table gets its entries back. On some occasions the problems appear to persist for hours (e.g. often during overnight downloads). Stopping Azureus always seems to fix the problem within a minute or so.

Azureus seems to be the only app I can find that triggers this issue. But clearly it is not a bug in Azureus, since it should not be able to affect the route table.

The version given by uname -a is:
Linux ubuntu 2.6.15-25-k7 #1 SMP PREEMPT Wed Jun 14 11:43:20 UTC 2006 i686 GNU/Linux

description: updated
Philip Paquette (pcpaquette) wrote :

Setting package to linux-source-2.6.15, so this bug gets out of the list of bugs without a package.
Can you confirm this bug still happens in edgy/feisty?
Thanks.

David Plumpton (david-plumpton) wrote :

It still happens in edgy. I'll try out feisty over the next month or so.

Changed in linux-source-2.6.15:
assignee: shooters → nobody
status: Needs Info → Unconfirmed

Thank you for your bug report. Do you still have this issue with the latest stable release of Ubuntu ?

Changed in linux-source-2.6.15:
importance: Undecided → Medium
status: New → Incomplete

Just tried a torrent with Azureus 2.5.0.4 and Ubuntu 7.04. The problem
did not occur this time (some slowdowns, could be the ISP, but no
problem with the routing table).

On 9/9/07, Jérôme Guelfucci <email address hidden> wrote:
> Thank you for your bug report. Do you still have this issue with the
> latest stable release of Ubuntu ?
>
> ** Changed in: linux-source-2.6.15 (Ubuntu)
> Importance: Undecided => Medium
> Status: New => Incomplete
>
> --
> Network route table vanishes intermittently
> https://bugs.launchpad.net/bugs/54763
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
David P.

Ok, thank you, I'm marking this as fixed.

Changed in linux-source-2.6.15:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers