Dapper Release Canidate fails to boot on iMac G5

Bug #46699 reported by Timothy Smith on 2006-05-26
This bug report is a duplicate of:  Bug #23445: iMac G5 will freeze after booting up. Edit Remove
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)

Bug Description

I just tried to release canidate of Dapper Drake and I had a bit of trouble getting it to boot. I used the desktop cd and got to the boot prompt. I hit enter and it started to load the kernel and then everything went black. The CD stopped reading (aka making noise) and then about a minute later the fans on the iMac went into overload mode.

Specs on the iMac from the Apple System Profiler.

      Machine Name: iMac G5
      Machine Model: PowerMac12,1
      CPU Type: PowerPC G5 (3.0)
      Number Of CPUs: 1
      CPU Speed: 1.9 GHz
      L2 Cache (per CPU): 512 KB
      Memory: 512 MB
      Bus Speed: 633 MHz
      Boot ROM Version: 5.2.6f1

          MAC Address: 00:14:51:7c:43:41
          Media Options:
          Media Subtype: autoselect

ATA Bus:

       MATSHITADVD-R UJ-846:

          Capacity: 768.24 MB
          Model: MATSHITADVD-R UJ-846
          Revision: FA0G
          Serial Number:
          Removable Media: Yes
          Detachable Drive: No
          BSD Name: disk1
          Protocol: ATAPI
          Unit Number: 0
          Socket Type: Internal
          OS9 Drivers: No
          S.M.A.R.T. status: Not Supported
              Capacity: 668.93 MB
              Media Type: CD-ROM
              Writable: No
              File System: HFS
              BSD Name: disk1s1s2
              Mount Point: /Volumes/Ubuntu_PowerPC_dapper

Audio (Built In):

    Built In Sound Card:

        Burr Brown PCM3052:
          Inputs and Outputs:
              Internal Microphone:
                  Controls: Mute, Master
                  Playthrough: No
                  PluginID: Onyx
              Line Level Input:
                  Controls: Mute, Master
                  Playthrough: No
                  PluginID: Onyx
              S/PDIF Digital Output:
                  Controls: Mute
                  PluginID: Onyx
              Internal Speakers:
                  Controls: Mute, Left, Right
                  PluginID: Onyx
              Line Level Output:
                  Controls: Mute, Left, Right
                  PluginID: Onyx


    ATI Radeon X600 Pro:

      Chipset Model: ATY,RV370
      Type: Display
      Bus: PCI
      Slot: PCI-E
      VRAM (Total): 128 MB
      Vendor: ATI (0x1002)
      Device ID: 0x5b62
      Revision ID: 0x0000
      ROM Revision: 113-xxxxx-113
          Display Type: LCD
          Resolution: 1440 x 900
          Depth: 32-bit Color
          Built-In: Yes
          Core Image: Supported
          Main Display: Yes
          Mirror: Off
          Online: Yes
          Quartz Extreme: Supported
          Status: No display connected



      Size: 512 MB
      Type: Built-in
      Speed: Built-in
      Status: OK


      Size: Empty
      Type: Empty
      Speed: Empty
      Status: Empty

PCI Cards:


      Name: ATY,Aphrodite2_B
      Type: display
      Bus: PCI
      Slot: PCI-E
      Vendor ID: 0x1002
      Device ID: 0x5b62
      Subsystem Vendor ID: 0x1002
      Subsystem ID: 0x5b62
      Revision ID: 0x0000


    Serial-ATA Bus:

        WDC WD1600JS-40MVB1:

          Capacity: 149.05 GB
          Model: WDC WD1600JS-40MVB1
          Revision: 10.02E01
          Serial Number: WD-WMAP01002378
          Removable Media: No
          Detachable Drive: No
          BSD Name: disk0
          Protocol: ata
          Unit Number: 0
          Socket Type: Serial-ATA
          OS9 Drivers: No
          S.M.A.R.T. status: Verified
            Macintosh HD:
              Capacity: 148.92 GB
              Available: 67.63 GB
              Writable: Yes
              File System: Journaled HFS+
              BSD Name: disk0s3
              Mount Point: /


    USB High-Speed Bus:

      Host Controller Location: Built In USB
      Host Controller Driver: AppleUSBEHCI
      PCI Device ID: 0x00e0
      PCI Revision ID: 0x0004
      PCI Vendor ID: 0x1033
      Bus Number: 0x4b


          Version: 0.01
          Bus Power (mA): 500
          Speed: Up to 480 Mb/sec
          Product ID: 0x2503
          Vendor ID: 0x0424

            Built-in iSight:

              Version: 1.20
              Bus Power (mA): 500
              Speed: Up to 480 Mb/sec
              Manufacturer: Micron
              Product ID: 0x8501
              Vendor ID: 0x05ac (Apple Computer, Inc.)

            IR Receiver:

              Version: 0.64
              Bus Power (mA): 500
              Speed: Up to 12 Mb/sec
              Manufacturer: Apple Computer, Inc.
              Product ID: 0x8240
              Vendor ID: 0x05ac (Apple Computer, Inc.)

    USB Bus:

      Host Controller Location: Built In USB
      Host Controller Driver: AppleUSBOHCI
      PCI Device ID: 0x0035
      PCI Revision ID: 0x0043
      PCI Vendor ID: 0x1033
      Bus Number: 0x0b

        Hub in Apple Pro Keyboard:

          Version: 4.10
          Bus Power (mA): 500
          Speed: Up to 12 Mb/sec
          Manufacturer: Mitsumi Electric
          Product ID: 0x1003
          Vendor ID: 0x05ac (Apple Computer, Inc.)

            Apple Optical USB Mouse:

              Version: 1.08
              Bus Power (mA): 100
              Speed: Up to 1.5 Mb/sec
              Manufacturer: Mitsumi Electric
              Product ID: 0x0304
              Vendor ID: 0x05ac (Apple Computer, Inc.)

            Apple Pro Keyboard:

              Version: 4.10
              Bus Power (mA): 250
              Speed: Up to 12 Mb/sec
              Manufacturer: Mitsumi Electric
              Product ID: 0x020b
              Vendor ID: 0x05ac (Apple Computer, Inc.)

    USB Bus:

      Host Controller Location: Built In USB
      Host Controller Driver: AppleUSBOHCI
      PCI Device ID: 0x0035
      PCI Revision ID: 0x0043
      PCI Vendor ID: 0x1033
      Bus Number: 0x2b

        Bluetooth HCI:

          Version: 19.65
          Bus Power (mA): 500
          Speed: Up to 12 Mb/sec
          Product ID: 0x8207
          Vendor ID: 0x05ac (Apple Computer, Inc.)

        USB Printer:

          Version: 1.00
          Bus Power (mA): 500
          Speed: Up to 12 Mb/sec
          Manufacturer: EPSON
          Product ID: 0x0005
          Serial Number: L47020502221051100
          Vendor ID: 0x04b8

AirPort Card:

    AirPort Card Information:

      Wireless Card Type: AirPort Extreme
      Wireless Card Locale: USA
      Wireless Card Firmware Version: 404.2 (
      Current Wireless Network: wireless network not available

sam tygier (samtygier) wrote :

at the boot prompt can you press tab, and choose the powerpc64 kernel.

does this boot?

Timothy Smith (tas50) wrote :

It does the exact same thing with the powerpc64-live kernel

sam tygier (samtygier) wrote :

have any versions of ubuntu ever worked?

Timothy Smith (tas50) wrote :

This is the first version I have tried on this machine.

I confirm this report. Ubuntu still has bootup bugs with iMac G5. Dapper is no exception to these long-standing problems. It's time for Canonical to get an iMac G5 machine for testing. Try eBay.

I tried all of the following Ubuntu versions:

Ubuntu PPC Live CD 6.0.6 beta 2
Ubuntu PPC Live CD Flight 7
Ubuntu PPC Text Install CD 6.0.6 beta 2

The Live CDs both failed. The text installer CD worked, though not ideally from a partitioning and sequencing standpoint. (It's an easy way to wreck a hard drive given Apple's very peculiar partitioning requirements. That is another can of worms. At least it boots.)

Live CDs get to the brown screen, blank except for the mouse cursor icon stuck in the middle. At this point the system hangs.

The keyboard worked because I was able to type boot params into yaboot. The mouse -- I can't say. I saw a cursor but could not move it. Both are wireless devices placed extremely close to the box for this test.

It may be the Mac sound driver problem which others reported. I do not know. All I can do is confirm that Dapper simply does not handle iMac G5. Ubuntu never has handled iMac G5. What a shame not to have this powerful 64-bit architecture running Ubuntu.


Dennis de Vaal (d-devaal) wrote :

I can confirm this too with the exact same hardware. The problem is in the ALSA pmac sound module. The module makes the complete system freeze. This problem is going on for some months now. For some reason no developer has ever fixed it. I also find it strange that this Ubuntu release has never been tested on an iMac G5.

Dennis de Vaal (d-devaal) wrote :

Why is this bug still unconfirmed? Also the final release, out now, doesn't work.

Ben Collins (ben-collins) wrote :

Can you try booting the alternate CD? It should avoid the X startup that the livecd has.

Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed

i own the same machine with the same problem.
perhabs i can help you debugging or simply booting new build.

mucky (troglomucky) wrote :

me too, count on me if I can help a bit.

For information, I've had the same type of problem with the Yellow Dog Linux installation : Install is ok, but when the login prompt appears, nor the mous nor the keyboard works (tried in bluetooth and in USB).



Blanchet (blanchet) wrote :

Hi I have the same problem.

And I had the same problem with Breezy and the 6.06Beta (ubuntu had never worked on my imac).

I was at an install party ubuntu on saturday in Paris with a lot of geeks. I am now able to say a bit more:
- First the desktop-ubuntu works perfectly (even bluetooth) under imac G5 rev c.
- BUT it does not work with iMac G5 1.8 GHz/17 M9843. I tried the desktop and the alternate cd (both in normal install and powerpc64 specific install).
Evreytime the same problem: while loading the modules the color of the kubuntu's sign is ugly (not the blue one wich appears usually). Then arrive time to login. The system freezes while initializing peripheals. I also tried without starting X but after a couple of seconds (perhaps 20) the system freezes.

Do not hesitate if requiere further information.

After going through the whole text-mode install process, Dapper 6.0.6 rebooted and snagged me on a bug reported months ago.


If you use bluetooth input devices, don't waste time with Ubuntu for now.

Blanchet (blanchet) wrote :

I don't agree with you Mark.
(1) I tried ubuntu 6.06 on a imacG5 (quite recent. unfortunately I cannot precise which version). The bluetooth worked (and communicated with the palm) and the micro$oft three-button mouse worked too.
(2) BUT on the iMac G5 1.8 GHz/17 M9843 ubuntu freezes (see above). I have to precise to Mark that on iMac G5 1.8 GHz there are no wireless keyboard and no blutooth used at all.

I think this is a duplicate of bug #23445. Try this workaround:

* boot using "Linux single" so gdm is not started
* do not use tab on the console
* disable sound in gdm by setting


In /etc/gdm/gdm.conf

Dennis de Vaal (d-devaal) wrote :

I think everyone understands that dissabling sound will prevend the complete freeze. But the ALSA developers should fix this.

i do not think it is a duplicate bug, because disabling sound did not fix all the problem.
the system does not freeze completly, but the xserver only shows a black screen after starting gdm!!!

Blanchet (blanchet) wrote :

For me the sound was the issue too. Knowing that I managed to log in the graphic interface (but the fan go fast which is a different problem).

An other way than the one suggested by Ludovic (easier for people who are not familiar with vi): at the log choose terminal session then start x (type startx as root). You have now the x interface in which you can make the corrections.

Could someone precise what are the corrections we have to make under Kubuntu. Here /etc/gdm/gdm.conf has to be replaced by /etc/kde3/kdm/kdmrc. But I did not see how to disable the sound.

Clemens: Does <ctrl><alt><F2> give you a login prompt, when you reach the black screen? If it does you can login and run 'dpkg-reconfigure xserver-xorg'.

this screen ist black too. a different kind of black but black.

Have you tried to boot with 'video=ofonly'?

Do you see any boot messages before reaching the black screen?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers