"critical temperature reached" with kernel 2.6.15-22-386

Bug #44805 reported by mastervivi on 2006-05-15
8
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned
linux-source-2.6.17 (Baltix)
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Medium
Unassigned

Bug Description

something weird happens to me with kernel 2.6.15-22-386. i login and everything seems normal. then, after a while, i get a black screen with the message

Critical Temperature Reached
Critical Temperature Reached
Shutting Down

and it just shuts down...
with kernel 2.6.15-21-386 everything works fine...
i'm using a MSI Mega PC 865 barebone desktop computer.

my lspci:
miguel@ubuntu:~$ lspci
0000:00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
0000:00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
0000:00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
0000:00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
0000:00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
0000:00:1f.6 Modem: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Modem Controller (rev 02)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
0000:02:05.0 Network controller: RaLink Wireless PCI Adpator RT2400 / RT2460
0000:02:07.0 FireWire (IEEE 1394): NEC Corporation uPD72874 IEEE1394 OHCI 1.1 3-port PHY-Link Ctrlr (rev 01)
0000:02:0d.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)

mastervivi (mastervivi) wrote :

the same thing happens with kernel 2.6.15-23-386...

Ben Collins (ben-collins) wrote :

Please test against latest dapper. Also, testing against edgy would be helpful as well.

Changed in linux-source-2.6.15:
status: Unconfirmed → Needs Info
mastervivi (mastervivi) wrote :

i have, it's present as well. i filled another bug here:
https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/54855
i've tried other distros and the only ones i found with this problem are ubuntu (dapper adn edgy) and simply MEPIS 6.0.
then i found that with the boot option pci=noacpi everything works fine.

Changed in linux-source-2.6.17:
status: Unconfirmed → Rejected
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Ben Collins (ben-collins) wrote :

Can you test against latest edgy (specifically 2.6.17-8.22 kernel)?

Thanks

Changed in linux-source-2.6.17:
status: Confirmed → Needs Info
mastervivi (mastervivi) wrote :

using edgy knot 3 desktop cd:

- i was able to boot the first time i tried, i even played a few games, but the fans would sometimes start working at full speed during a few seconds for no apparent reason. the computer eventually froze...

- the second time the keyboard didn't work, i tried shutting down and i got a black screen with the messages:
Critical temperature reached (-46009 C), shutting down
Critical temperature reached (--5561 C), shutting down
Critical temperature reached (57 C), shutting down
Critical temperature reached (57 C), shutting down
and it just froze there...

- i tried a few more times, in some of them the computer froze in the middle of the booting process

- it worked just fine with the boot option pci=noacpi

mastervivi (mastervivi) wrote :

i installed edgy to another partition.
with kernel 2.6.17-9-generic the computer always freezes during booting. even with the boot option pci=noacpi.
it works only with acpi=off...

mastervivi (mastervivi) wrote :

the same thing happens with kernel 2.6.17-10-generic

Lorenzo J. Lucchini (ljl) wrote :

Yes, I can "sort of" confirm it, too, with kernel 2.6.17-10-generic.

The system wouldn't boot (it *might* have been the first time I was running 2.6.17-10 after the auto-update, I am not really sure...), and it tried to shutdown saying temperature was 121C.

I tried booting with a Kubuntu Dapper CD, and the same thing happened.
I fiddled a litte with the BIOS "Health" settings, to no avail. Then I fiddled some more, and it came back to life.

Specifically, what I did in the BIOS was raise the CPU-shutdown temperature from (I think...) 65C to 67C, and the CPU-warning temperature from 60C to 65C; also, I disabled the "Shutdown on fan failure" option.

Somehow, though, I feel that what I did in the BIOS is not related, but then who am I to know... I will see if I can reproduce this again by playing with the BIOS.

Lorenzo J. Lucchini (ljl) wrote :

Ok, now I can better confirm what I said yesterday.

Kubuntu Edgy, kernel 2.6.17-10-generic, on an Abit KV7 board (VIA KT600 chipset) with AwardBIOS 6.00PG, and an AMD Sempron 2400+ processor.

Enabling the option "Shutdown When CPU Fan Fail" in the BIOS ("Health" page) results in the system's boot process failing at early stages with the "Critical temperature reached, shutting down (121C)" message. The system then apparently tried to power off, but fails even at that, and just keeps printing that message (at least if you make usplash go away).

The BIOS CPU temperature settings I wrote about in the previous posting don't seem to be related; anyway, the CPU temperature that both the BIOS and lm-sensors report is much lower than the set limits.

As I mentioned in the other posting, the same problem also occurs with the Kubuntu Dapper Live CD (even though, contrary to my Edgy installation, the Dapper CD does succeed in powering off the machine, after the boot process is interrupted).

Changed in linux-source-2.6.15:
status: Needs Info → Confirmed
Lorenzo J. Lucchini (ljl) wrote :

Even though nobody else has confirmed the connection between the behavior described in this report and the "Shutdown When CPU Fan Fail" BIOS option, I think it is a valid starting point, lacking anything else, also considering that the behavior itself has been confirmed by several people. I'm marking this bug as Confirmed.

Changed in linux-source-2.6.17:
status: Needs Info → Confirmed
mastervivi (mastervivi) wrote :

i've just tried the edgy live cd.

it booted fine and everything seemed normal, but it eventually stopped responding: i could move the mouse but no application would start.

the same thing happened with the boot option pci=noacpi.
with the boot option acpi=off everything was fine, except the fans, of course, that were working at full speed.

i then made a fresh edgy install on my spare partiotion using the live cd. basically, i can only boot with the boot option acpi=off, otherwise it just freezes during booting

mastervivi (mastervivi) wrote :

more specifically, it freezes when the message
'Starting kernel event manager'
appears.

note that i don't get the 'critical temperature reached' message anymore, so i don't know if that problem was solved and this is a new, totally unrelated, problem or if the two are related...

Luuk Paulussen (luuk) wrote :

I get the same freeze when starting kernel event manager appears on my ibm thinkpad t40 laptop after upgrading to edgy from dapper. If I wait for 2-3 minutes the laptop continues booting and laptop works normally from this point. Still a very annoying bug.

Rimas Kudelis (rq) wrote :

Confirming the problem with 2.6.20-11-generic in Feisty on a generic P4 desktop computer (I have fancontrol running though).

BTW, isn't this a dupe of a bug #22336 ?

Lorenzo J. Lucchini (ljl) wrote :

Maybe, though I thought I'd mention that, while that bug's title is about laptop, the problem for me did *not* occur on a laptop.

Paul Sladen (sladen) wrote :

Thanks for pointing that out; I've updated the other bug report's title to drop the word 'laptop'.

Paul Sladen (sladen) on 2007-03-18
Changed in linux-source-2.6.15:
status: Confirmed → Rejected
Changed in linux-source-2.6.17:
status: Confirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers