Ubuntu

Mute key led not working anymore

Reported by Lynoure Braakman on 2006-05-10
14
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Low
Unassigned

Bug Description

After the latest kernel upgrade (21->22) my mute key led hasn't worked, the key itself luckily still works otherwise.

Other leds and hotkeys work normally.

# dmidecode 2.7
SMBIOS 2.3 present.

Handle 0x0001, DMI type 1, 25 bytes.
System Information
        Manufacturer: Hewlett-Packard
        Product Name: HP Compaq nc8230 (PV406AW#AK8)
        Version: F.0F
        Serial Number: CNU5511S6P
        UUID: 6BAAF0CF-597A-DA11-3984-6D990A535D29
        Wake-up Type: Power Switch

Handle 0x0010, DMI type 32, 11 bytes.
System Boot Information
        Status: No errors detected

Matthew Garrett (mjg59) wrote :

Daniel, this is probably where we've failed to get a patch upstream and it's then been lost when merging from there?

Paul Sladen (sladen) on 2006-05-10
Changed in linux-source-2.6.15:
status: Unconfirmed → Needs Info
Daniel T Chen (crimsun) wrote :

Lynoure, please attach the output from ``lspci -nv'', thanks.

Output of lspci -nv

Daniel T Chen (crimsun) wrote :

You should get appropriate action by unloading snd_intel8x0 then reloading it with ac97_quirk=hp_mute_led as such:

1) Quit all applications using sound (``lsof /dev/dsp* /dev/snd/*'')
2) Unload snd_intel8x0 (``sudo modprobe -r snd_intel8x0'')
3) Reload snd_intel8x0 (``sudo modprobe snd_intel8x0 ac97_quirk=hp_mute_led'')

The solution applied for bug #41015 clashes with this one, because the subvendor and subdevice ids are identical. I'm not familiar with an easy way to resolve this, since regardless which setting we use for default, _some_ model will not have intended functionality.

Changed in linux-source-2.6.15:
status: Needs Info → Confirmed
Matthew Garrett (mjg59) wrote :

HPs need both mute_led and hp_only. We used to have a quirk that provided both - has that vanished?

Daniel T Chen (crimsun) wrote :
Changed in linux-source-2.6.15:
status: Confirmed → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments