Ubuntu

prism54 loading/reloading 2 times crashes

Reported by sparky on 2006-05-07
10
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned

Bug Description

First of all, running AMD64 Dapper:

On dapper, the first time I do a
modprobe -r prism54
and follow it with
modprobe prism54
its fine. if I later repeat it, it crashes the system totally.

Same if I do an ifconfig eth2 down/up twice.

The lines from syslog before the crash (I then booted into Breezy) are here
The first reset of eth2 is here

------
May 7 14:24:55 localhost kernel: [ 700.766553] eth2: timeout waiting for mgmt response 1000, triggering device
May 7 14:24:55 localhost kernel: [ 700.866480] eth2: timeout waiting for mgmt response 900, triggering device
May 7 14:24:55 localhost kernel: [ 700.966417] eth2: timeout waiting for mgmt response 800, triggering device
May 7 14:24:55 localhost kernel: [ 701.066345] eth2: timeout waiting for mgmt response 700, triggering device
May 7 14:24:56 localhost kernel: [ 701.166282] eth2: timeout waiting for mgmt response 600, triggering device
May 7 14:24:56 localhost kernel: [ 701.266210] eth2: timeout waiting for mgmt response 500, triggering device
May 7 14:24:56 localhost kernel: [ 701.366143] eth2: timeout waiting for mgmt response 400, triggering device
May 7 14:24:56 localhost kernel: [ 701.466076] eth2: timeout waiting for mgmt response 300, triggering device
May 7 14:24:56 localhost kernel: [ 701.566012] eth2: timeout waiting for mgmt response 200, triggering device
May 7 14:24:56 localhost kernel: [ 701.665941] eth2: timeout waiting for mgmt response 100, triggering device
May 7 14:24:56 localhost kernel: [ 701.666162] eth2: timeout waiting for mgmt response
May 7 14:25:01 localhost kernel: [ 706.410563] eth2: removing device
May 7 14:25:01 localhost kernel: [ 706.410708] eth2: islpci_close ()
May 7 14:25:01 localhost dhclient: receive_packet failed on eth2: Network is down
May 7 14:25:01 localhost kernel: [ 706.479692] ACPI: PCI interrupt for device 0000:00:0b.0 disabled
May 7 14:25:01 localhost kernel: [ 706.480619] Unloaded prism54 driver
May 7 14:25:04 localhost kernel: [ 709.363469] Loaded prism54 driver, version 1.2
May 7 14:25:04 localhost kernel: [ 709.364344] ACPI: PCI Interrupt 0000:00:0b.0[A] -> GSI 19 (level, low) -> IRQ 209
May 7 14:25:08 localhost kernel: [ 713.344634] eth2: resetting device...
May 7 14:25:08 localhost kernel: [ 713.344656] eth2: uploading firmware...
May 7 14:25:08 localhost kernel: [ 713.438955] eth2: firmware version: 1.0.4.3
May 7 14:25:08 localhost kernel: [ 713.439151] eth2: firmware upload complete
May 7 14:25:08 localhost kernel: [ 713.678022] eth2: interface reset complete
May 7 14:25:19 localhost kernel: [ 724.504486] eth2: no IPv6 routers present
----------------

Then I did it again and the system crashes

-----------------

May 7 14:35:20 localhost kernel: [ 1325.555923] eth2: timeout waiting for mgmt response 1000, triggering device
May 7 14:35:20 localhost kernel: [ 1325.656850] eth2: timeout waiting for mgmt response 900, triggering device
May 7 14:35:21 localhost kernel: [ 1325.757787] eth2: timeout waiting for mgmt response 800, triggering device
May 7 14:35:21 localhost kernel: [ 1325.858714] eth2: timeout waiting for mgmt response 700, triggering device
May 7 14:35:21 localhost kernel: [ 1325.959654] eth2: timeout waiting for mgmt response 600, triggering device
May 7 14:35:21 localhost kernel: [ 1326.060578] eth2: timeout waiting for mgmt response 500, triggering device
May 7 14:35:21 localhost kernel: [ 1326.161516] eth2: timeout waiting for mgmt response 400, triggering device
May 7 14:35:21 localhost kernel: [ 1326.262443] eth2: timeout waiting for mgmt response 300, triggering device
May 7 14:35:21 localhost kernel: [ 1326.363368] eth2: timeout waiting for mgmt response 200, triggering device
May 7 14:35:21 localhost kernel: [ 1326.464311] eth2: timeout waiting for mgmt response 100, triggering device
May 7 14:35:21 localhost kernel: [ 1326.464539] eth2: timeout waiting for mgmt response
May 7 14:35:27 localhost kernel: [ 1332.592391] eth2: removing device
May 7 14:35:27 localhost kernel: [ 1332.592413] eth2: islpci_close ()
May 7 14:35:27 localhost dhclient: receive_packet failed on eth2: Network is down
May 7 14:35:27 localhost dhclient: receive_packet failed on eth2: Network is down
May 7 14:35:27 localhost kernel: [ 1332.662059] ACPI: PCI interrupt for device 0000:00:0b.0 disabled
May 7 14:35:27 localhost kernel: [ 1332.662996] Unloaded prism54 driver
May 7 14:35:31 localhost kernel: [ 1335.709938] Loaded prism54 driver, version 1.2
May 7 14:35:31 localhost kernel: [ 1335.711104] ACPI: PCI Interrupt 0000:00:0b.0[A] -> GSI 19 (level, low) -> IRQ 209

-----------------------

So we get no more firmware uploading and that stuff.

The above log stuff taken from syslog. This is a recurring problem and may also have something to do with other bugs discussing network connectivity problems, not sure. Can anyone else confirm this?

Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in linux-source-2.6.15:
assignee: nobody → brian-murray
status: Incomplete → Invalid
Oumar Aziz OUATTARA (wattazoum) wrote :

Hello Brian,

Please don't close bugs when they are lacking informations . Mark them as "Incomplete" as mentioned there : https://wiki.ubuntu.com/Bugs/Status .

The only reason I see for closing this bug will be that the logger didn't provide the required informations "for that much time (2006-05-07 - 2007-06-27)" and there is no duplicate so we can assume nobody is able to reproduce it .
Stating the above reasons will be the good way for closing this one.

Changed in linux-source-2.6.15:
status: Invalid → Incomplete
Tormod Volden (tormodvolden) wrote :

sparky, thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description does not yet have enough information. Can you please have a look at https://help.ubuntu.com/community/DebuggingSystemCrash and see if you can provide more information?

Brian Murray (brian-murray) wrote :

This bug has not received any additional debugging information since it was originally reported so we are closing it as Invalid.

Changed in linux-source-2.6.15:
assignee: brian-murray → nobody
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers