Microphone does not work on Dell Inspiron 630m

Bug #42600 reported by Andrew Bennetts on 2006-05-02
44
This bug affects 3 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
linux-restricted-modules-2.6.15 (Ubuntu)
Undecided
Daniel T Chen
linux-source-2.6.15 (Ubuntu)
Medium
Daniel T Chen
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

I cannot get the microphone input on my Dell Inspiron 630m laptop to work. I'm using latest dapper, and have tried every possible permutation of mixer settings. I either get a quiet hiss or complete silence.

The sound hardware uses the snd_hda_intel module. Here's the relevant lspci output:

$ lspci -vv -s 00:1b.0
0000:00:1b.0 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
        Subsystem: Dell: Unknown device 01b5
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 0x10 (64 bytes)
        Interrupt: pin A routed to IRQ 169
        Region 0: Memory at dfebc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <available only to root>

Googling for this issue suggests that many other people with this hardware have this problem too, including this cryptic comment:

"""No mic inputs
(updated 20/03/2006)

This is annoying - all of the outputs are doing their thing but not the inputs... Presently, the mic/line jack appears to be as dead as a doornail. I reckon this is again due to the way this chipset can re-task jacks at will, as under windows when you plug a device in it asks you "is this a MIC or a Line-level device?"... Presently chatting with some Alsa peeps to see if they have any ideas..."""

(from http://www.disgruntledgoat.com/content/useful/gentoo_on_inspiron630m.php#nomicinputs)

Other info:

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1

$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 11 [35%] [on]
  Front Right: Playback 11 [35%] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%]
  Front Right: Playback 255 [100%]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 15 [100%] [on]
  Front Right: Capture 15 [100%] [on]
Simple mixer control 'Capture Mux',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 4
  Front Left: 4 [100%]
  Front Right: 4 [100%]
Simple mixer control 'Input Source',0
  Capabilities: enum
  Items: 'Mic' 'Line'
  Item0: 'Mic'

Let me know if there's anything else I can do to help diagnose this.

danimo (daniel-molkentin) wrote :

Confirmed, I only get static that stops as soon as I set the PCM output to 0.

just installed the new alsa-1.0.13rc1 which includes the patch (yes, ive checked that!) and it does not work on my dell latitude d620 having an intel hda ich7-card. playback works fine, mic input just results in silence.... i dont think this bug is solved so.

victorovitch3 (alex-vice-grab) wrote :

I have the same problem with the Dell Inspiron 630m. I have attempted to install the alsa mixer, but it does not work.
I don't quite understand what the attachment by Daniel T Chen means, could someone clarify it to me, since I was not able to run it in the terminal...
Thank you in advance

i should have said that i use an dell latitude d620. still the problem remains the same.

victor: daniel posted a patch for the alsa-drivers which got included in their lates version 1.0.13rc1. have your tried this version? it is not in the repositories but you can download it from http://www.alsa-project.org/. could you try this and see if it helps?

thanx,
catkiller

victorovitch3 (alex-vice-grab) wrote :

Dear Catkiller,

I'll try intstalling this alsa driver, though being so far a quite inexperienced linux user this might take some time :-)
Just as a note aside: I have read in one of the support forum threads of someone installing this driver, with the result of the microphone working, however terribly (too much noise to run Skype, it appeared). Whether this is due to the hardware or due to the installation, I'll have to find out...
Thank you for the advice!
Victorovitch

mexlinux (mcanedo) wrote :

Did it worked??
I can try, if some one gives me a how to compile it....
Or provied a deb for dapper

I have a Dell Inspiron 8000, and my mic does not work. If I set my mic as the input, and turn it on in output as well, I can tap the mic and I hear it.

However, Audacity (anyone have any other recommended programs i can test as well?) picks up nothing at all.

I'm using Edgy, but it didn't work in Dapper either.

MARTIN Samuel (martin-sam) wrote :

I have a Dell inspiron 630m + Ubuntu Dapper, and I have the same problem. I don't have sound with mic imput. There isn't the 20db amplification in sound configuration. Mic input is completely mute. It is a small lie, If I shout very extremely in mic at the same time as the reading music, I can hear 0,5% of my voice.

I wish a fix bug in ubuntu edgy

Sam [french]

mexlinux (mcanedo) wrote :

Version in Edgy is 1.0.11 please bring the latest version to the repositories, or at least bring some packages somewhere else.

Prinz Igor (pigor) wrote :

I have not a notebook from Dell but a similar audio hardware:

$ lspci -vv -s 00:1b.0
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: QUANTA Computer Inc Unknown device 0753
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 66
        Region 0: Memory at de300000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>

How can i install the newer alsa version? Will it be in Edgy soon?

mexlinux (mcanedo) wrote :

This is still in Edgy offcial 6.10 !!!!

Kirill Uvaev (kuvaev) wrote :

Please, provide a solution! We really need microphone working!

TiagoMacambira (macambira) wrote :

I have a Dell latitude D520 and experienced this bug also.
After a **lot** of googling I came upon ALSA BUG #2038 ( https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2038 ) that seems to dell with this bug. This problem seems to be related with ICH7, Sigmatel codecs (STAC 92xx, as one can see in /proc/asound/card0/codec#0), Dell BIOS not setting things up correctly and ALSA not working around this ;-)

The workaround, it seems, consists in adding "options snd-hda-intel model=ref" to /etc/modprobe.d/alsa-base. You may have to select the correct input source, though (gnome-mixer, options tab...). Also, make sure capture is not muted or with a volume level too low (again in gnome-mixer...) This worked in my Dell latitude D520 with ubuntu 6.06 LTS kernel (more precisely, 2.6.15-27-686). Skype works with alsa, sound recorder works, etc.

More recently I updated my BIOS to revision A02 AND compiled alsa-modules from alsa-source 1.0.11 (source from edgy). This setup seems to be working without the "model=ref" hack but I would need more time to verify that...

Well, I would suggest re-opening this bug, as this is clearly not fixed in the kernel shipped with 6.06. Yes, there's an easy workaround but this is far from the perfect solution - and it is not well documented.

Better yet would be collecting information about other notebooks/systems affected by this bug and submiting their PCI vendor, device and subsystem IDs and forwarding this to ALSA. I attached mine just for the record.

#include <bad_english_excuses.h>

mexlinux (mcanedo) wrote :

Actutal packages in edgy do not work.
The workarount is not working for me.
Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
Where are the updated fixed packages??

Tormod Volden (tormodvolden) wrote :

Some of the commenters here might just have wrong Capture settings, see bug #66714.

Kolin S. Murray (kolinab) wrote :

I'm running Ubuntu 6.10 Edgy and unable to use mic. on my 630m as well. I'm reading information at http://perseverantia.com/index.php?p=429 but I feel pretty lost. I just don't know how to implement a workaround. People are talking about recompiling kernel modules from source, etc. and it's just a little beyond me right now.

I've found instructions on HOW to recompile, but I'm not sure how/where to download the latest driver from. Then once I download it, do I need to modify it and then plug it back into the kernel? I'm just not sure the process.

Can someone give me a couple tips to get started trying a workaround or a recompile or whatnot? :) I'm generally good at computers, just new to Linux!

Kolin S. Murray (kolinab) wrote :

I must now comment that my problem is solved for now. I implemented the solution posted by extremecarver on 08-11-06 at https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2038. It worked! Good luck to all, thanks for the help.

mexlinux (mcanedo) wrote :

This problem is still present in Feisty (clean install)!

Kolin S. Murray (kolinab) wrote :

In my clean install of Feisty my microphone works with no tweaking.

Suzan (suzan72) wrote :

Confirmed here.

On my new Dell Inspirion 6400 with clean Feisty install microphone doesn't work either! :-(

Zoltan (baloghmail) wrote :

Clean install of Kubuntu Feisty, microphone is dead silent.. I'm using a Fujitsu Siemens Amilo Pi 1556 with Xactly the same sound device. Gonna seek for solution.

Suzan (suzan72) wrote :

I've changed status from "fix commited" to "confirmed" because this bug is still present in Feisty.

I've tried adding "options snd-hda-intel model=ref" to /etc/modprobe.d/alsa-base (solution from TiagoMacambira) but this doesn't fix the problem.

Changed in linux-source-2.6.15:
status: Fix Committed → Confirmed
Suzan (suzan72) wrote :

Bug is still present in Feisty!

cadragon (cadragon) wrote :

Confirmed here.

Gateway MX6943m with Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02) on clean Kubuntu Install.
That "options snd-hda-intel model=ref" fix doesn't work.

ajyablo (ajyablo) wrote :

Confirmed here, aswell.
Gateway MX3422 with the Stac 92xx- the sound does not work.
Clean install of Ubuntu.
Sound does work fine in Windows.

"options snd-hda-intel model=ref" did not work.

bernieda (bernieda) wrote :

I have a Dell Inspiron 600m with the Intel 82801DB-ICH4. The Mic does not work here as well in Feisty.

This might help: While running GDM, using the sound up / sound down and mute special keys on the notebook keyboard does not affect the Master volume on the Gnome Volume Control applet, ditto with KMix. However, these keys do affect the mic level (i.e., the mic slider moves when I press those special keys).

It is also worth noting that the sound keys on the keyboard work properly when running KDM.

bernieda (bernieda) wrote :

Please ignore my previous comment. My problem was related with setting the Default Mixer Track in the Sound control panel.

Andrea Ratto (andrearatto) wrote :

confirmed on a dell d620, feisty clean install

Marek Safar (marek-safar) wrote :

It works on my Dell Inspiron 6400 / Ubuntu Feisty (7.04).

The trick was to enable mic recording in Volume Control (2nd tab and un-tick small red cross).

Suzan (suzan72) wrote :

I am still testing and I think, I've catched the bad boy - it's GStreamer!

I thought, my microphone doesn't work at all, but that's wrong. The microphone works absolutely correct with everything but GStreamer! That means, any GStreamer related software doesn't work. That's for instance, gnome-audio-recorder, ekiga or jokosher. In neither of these programs the microphone work.

BUT it works with software, that doesn't require GStreamer. The microphone works perfectly with Audacity, Skype and even Ardour! It works also if I record something with mancoder in the terminal.

So my guess it, that the HDA Intel Chip and Gstreamer have some problems with each other.

The only gnome-program, that gives me an error is jokosher. It says:

"GStreamer encountered a general stream error.

gstbasesrc.c(1642): gst_base_src_loop (): /timeline/playbackbin/Click_Track_Bin/Click_Track_AudioSource:
streaming task paused, reason not-linked (-1)"

I am not sure, if this is an error which depends only Jokosher or GStreamer at all.

Changed in linux-source-2.6.15:
status: Confirmed → Fix Released
assignee: nobody → crimsun
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Changed in linux-restricted-modules-2.6.15:
assignee: nobody → crimsun
status: New → Fix Released
Changed in linux-restricted-modules-2.6.15:
status: Fix Released → Invalid
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
Changed in linux-source-2.6.17:
status: New → Invalid
Ricardo Coelho (ram-coelho) wrote :

For me it is just the opposite. It is a Dell Latitude D520 with Intel sound running Feisty. If I reboot and run Skype, dead mic. Then I run Ekiga, proceed with 6x "next buttons" set audio as default in both boxes, press test button and voilà! It works. I cancel the Ekiga wizard, try an echo123 within Skype, and it is still working. I don't know what exactly Ekiga does, but it seams to fix until the next boot.

Ricardo Coelho (ram-coelho) wrote :

Ok, found something else that works... If I open gnome-volume-control and go to the third tab (options) and change the Input source to Line (it was Mic), close it and then open again and change back to Mic, and finally close, I try Skype and works. After a boot and before doing this, I have a dead mic. This time I didn't even touch Ekiga.

Any ideas? Works for someone else?

On 7/18/07, Ricardo Coelho <email address hidden> wrote:
>
> Ok, found something else that works... If I open gnome-volume-control
> and go to the third tab (options) and change the Input source to Line
> (it was Mic), close it and then open again and change back to Mic, and
> finally close, I try Skype and works. After a boot and before doing
> this, I have a dead mic. This time I didn't even touch Ekiga.
>
> Any ideas? Works for someone else?

That is exactly what I do to get the microphone working here. I seems odd to
de-select and then re-select mic on as input source but, then again, it does
the trick :-)

I'm also on Festy on a Dell Latitude D520.

Jens Rantil (jens-rantil) wrote :

Prinz Igor:
I have the same sound card as you have but have not been able to fix it with the fixes mentioned here. My hardware (laptop Fujitsu-Siemens Amilo Pro V3205) has an internal microphone which works good (though it has a quite low volume). You could try that one by opening up the GNOME Volume Manager, press "Switches"-tab and then "IntMic". Make sure it is not muted or anything (I had to use "alsamixer" and go into "Capture"-mode to do that)...

Everyone else:
You are mentioning that you have a tab called "Options" in GNOME Volume Manager. The only tab I have are "Playback" and "Switches". Are the tabs in the Volume Manager audio device dependent or do you have a different version of it? The version is I'm using is '2.18.0'.

As I wrote to Igor I am experiencing the same problem (external microphone is absolutely quiet but internal microphone works) but the fixes you mention don't work for my (similar) hardware:

$ sudo lspci -vv
[...]
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Fujitsu Siemens Computer GmbH Unknown device 10ad
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 23
        Region 0: Memory at dc240000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000 Data: 0000
        Capabilities: [70] Express Unknown type IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
                Device: Latency L0s <64ns, L1 <1us
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed unknown, Width x0, ASPM unknown, Port 0
                Link: Latency L0s <64ns, L1 <1us
                Link: ASPM Disabled CommClk- ExtSynch-
                Link: Speed unknown, Width x0
[...]

I bought a Packard Bell BU45 this weekend. Everything went smooth for Gutsy, except the microphone, the fingerprint reader and the webcam.
Testing report: https://wiki.ubuntu.com/LaptopTestingTeam/PackardBellENBU45

Ian Phillips (ianfp) wrote :

If you're having problems (like I was), don't forget to try upgrading your BIOS. I finally got it to work on my Inspiron 1300/Feisty system by upgrading my BIOS from A02 to A10.

efreddi (efreddi) wrote :

I have a FS Amilo Pi 1556 and I found no way to bring to life the internal mic nor an external one. It simply doesn't work with no software in Gutsy.
By the way, the installation went find and the only hint of some problem I found is a string in dmesg where it says that there is some timeout and then it's necessary to go to polling mode.
Playback instead is ok.

Elia

Jens Rantil (jens-rantil) wrote :

Hey Elia/efreddi. What soundcard do you have? What does 'lspci -vv' give you? (only paste the lines relevant for soundcard)

efreddi (efreddi) wrote :

Hello Jens,
thank you for your reply. Here you can find the output of "lspci -vv":

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Fujitsu Siemens Computer GmbH Unknown device 10b0
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at b0000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>

running it with sudo:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Fujitsu Siemens Computer GmbH Unknown device 10b0
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at b0000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000 Data: 0000
        Capabilities: [70] Express Unknown type IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
                Device: Latency L0s <64ns, L1 <1us
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed unknown, Width x0, ASPM unknown, Port 0
                Link: Latency L0s <64ns, L1 <1us
                Link: ASPM Disabled CommClk- ExtSynch-
                Link: Speed unknown, Width x0

and this is the message is dmsg:

[ 35.224000] hda_intel: azx_get_response timeout, switching to polling mode...

if you have suggestion... Thanks!

Elia

mexlinux (mcanedo) wrote :

This is still there in Gutsy

For those who still have an issue, you might want to try installing the 'linux-backports-modules' package and see if that helps. Please report back your results. Thanks.

Changed in linux-source-2.6.22:
status: New → Incomplete

Also, the Hardy Heron Alpha2 release will be coming out soon (around Dec 20). It will have an updated version of the kernel. It would be great if you could test with this new release and verify if this issue still exists. I'll be sure to update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete
efreddi (efreddi) wrote :

I followed the suggestion to try with the backported modules, but so far no positive results - no signal from the microphone.

Now waiting for Hardy Alpha2.

efreddi (efreddi) wrote :

I just downloaded and tried Hardy Alpha2 but again no success - no sound from the microphone :-(
Maybe somebody else has been more successful.

Thanks for the update efreddi. I was just noticing it appears that you have a different audio controller than the original bug reporter. Care to open a new bug report regarding your issue? It's helpful to the development teams if bug reports target a specific bug on a specific set of hardware. Feel free to subscribe me to the bug report and I'll be sure to triage accordingly. Also, in your new bug report if you can attach the files described in the "Reporting Sound Bugs" section of the following wiki, that would be great. https://help.ubuntu.com/community/DebuggingSoundProblems Thanks!

Also, for anyone else who is interested, Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Just a note that we'll be keeping this report open against the actively developed kernel. However, against linux-source-2.6.22 this bug does not meet the criteria for a stable release update and is being closed. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.22:
status: Incomplete → Won't Fix
Daniele Dellafiore (ildella) wrote :

Ok, I cannot make the mic register anything with ubuntu hardy up to date. dell xps 1530 but this is a generic and long-standing (see bug 37736) hda intel driver issue, at least in ubuntu.

I attacch a screenshot of any possible control I have in latest ubuntu (alsamixer, gnome sound applet and pulseaudio) that shows that the mic seems to actually get some signals but at a very slow volume and actually nothing is reproduced after the recording.

Anyone has some tip?

chip is SigmaTel STAC9228.

jzabi73 (jzabi73) wrote :

I have a similar problem in my FS Amilo Pi 1505.
The mic only records when capture devices GAIN are NEAR 0dB.
When the gain is high doesn't record.
(alsamixer)
──────────────[AlsaMixer v1.0.15 (Press Escape to quit)]──────────────────┐
│ Card: HDA Intel │
│ Chip: Realtek ALC883 │
│ View: Playback [Capture] All │
│ Item: Capture [dB gain=0.00, 0.00] │
│ ................
│ Mic Boos <Capture > Capture Digital Input So Input So

lspci -vv
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev
02)
        Subsystem: Fujitsu Siemens Computers Unknown device 10c7
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B
-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at f0000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000 Data: 0000
        Capabilities: [70] Express Unknown type IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
                Device: Latency L0s <64ns, L1 <1us
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed unknown, Width x0, ASPM unknown, Port 0
                Link: Latency L0s <64ns, L1 <1us
                Link: ASPM Disabled CommClk- ExtSynch-
                Link: Speed unknown, Width x0

Eggzilla (arampantsmurf) wrote :

I was fighting with this as well for a while, and as I just got things to work out, I figured that I'd post what I did. Pardon the lack of technicality herein, as I know almost nothing about the specifics of this.

I'm running Hardy, 8.04. I was having trouble getting sensitivity on my mic for Skype. I'm using a Acer Aspire 5570-2758 (or so says the sticker), and the cheapest Logitec headset I could find. After struggling through a lot of things, I downloaded the ALSA mixer and fidgeted with that for a while, but it produced almost no results (sound was still very, very quiet, with an electronic background). I uninstalled it, as it was not fixing my issues.

I returned to the basic Volume Control and took a look at the bug reference in https://bugs.launchpad.net/bugs/66714.

I opened volume options and have these tabs checked under Edit -> Preferences: Master, Headphone, PCM, Front, Line-In, Microphone, Mic Boost, Capture, Capture 1, and both Input Sources. That being said, everything under the "Playback" tab is at max. Under the "Recording" tab, "Capture" is all the way down, but nothing is officially muted (no X's over anything); "Capture 1" is at max, again no X's. Under the "Options" tab, both Input Sources are listed as Front Mic. Everything works perfectly at this point.

I'm sorry if this is not the technical jargon people are accustomed to here, but I hope it's explained well enough. Thanks for the help.

danuel (ddarvish-hibm) wrote :

Gateway laptop M-6319 microphone doesn't work at all.

$ lspci -vv -s 00:1b.0
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
 Subsystem: Gateway 2000 Unknown device 0380
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at fa500000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>

Max volume was also too low, and now seems better when I added to the end of /etc/modprobe.d/alsa-base the following line
options snd-hda-intel model=ref

danuel (ddarvish-hibm) wrote :

Update for above re Gateway M-6319 with list of capabilities

$ sudo lspci -vv -s 00:1b.0
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
 Subsystem: Gateway 2000 Unknown device 0380
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at fa500000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express Unknown type IRQ 0
  Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
  Device: Latency L0s <64ns, L1 <1us
  Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
  Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
  Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
  Link: Supported Speed unknown, Width x0, ASPM unknown, Port 0
  Link: Latency L0s <64ns, L1 <1us
  Link: ASPM Disabled CommClk- ExtSynch-
  Link: Speed unknown, Width x0

ngodfather114 (ngodfather114) wrote :

My mic doesn't work either. I have a Dell inspiron 1420. I got the camera and everything else working right. But the mic is still dead. I'm running ubuntu 8.04. Is there nothing at all that will get this mic running. Please some one has to have something.

Hi ngodfather114,

It would be more relevent if in the future you could post these sorts of questions to the forums or answers area of launchpad. Bug reports should really try to contain specific information which helps developers debug and hopefully resolve the issue. But I found this following link which will likely help you http://davestation.wordpress.com/2008/07/12/how-to-enable-digital-microphone-array-on-dell-inspiron-laptops-in-ubuntu-804/ . Thanks.

Changed in linux:
status: Incomplete → Confirmed

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

sibidiba (sibidiba) wrote :

Lot of people experience problems with various codecs using snd-hda-intel.

I have set up this page to summarize the problems:
https://wiki.ubuntu.com/SndHdaIntelSoundProblems

Bugs are only related if they are for the same module and codec/chipset:

cat /proc/asound/card*/codec\#*|grep -i codec

M Nubbe (m-nubbe) wrote :

Everyone, double check that this is really a bug and not a setting error. I am using a dell inspiron 1420 with ubuntu 8.10 (intrepid), kernel 2.6.29, and at first the internal mic did not work. However, doing the following in the sound settings fixed this problem:

start the volume control applet, bring it up
open preferences, turn on digital input source and input source, along with capture
set digital input source=digital mic 1
input source = front mic
make sure capture isn't muted

This is also found on Leann's link: http://davestation.wordpress.com/2008/07/12/how-to-enable-digital-microphone-array-on-dell-inspiron-laptops-in-ubuntu-804/

Tormod Volden (tormodvolden) wrote :

It is a still a bug if it does not work out of the box. If the laptop has a built-in microphone, it is expected that this microphone is ready to be used by voip and other audio applications.

André Gondim (andregondim) wrote :
Download full text (4.8 KiB)

This happens with me:

My Note is Inspiron 1525 Dell

$ lspci -vv -s 00:1b.0
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
 Subsystem: Dell Device 022f
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 21
 Region 0: Memory at fe9fc000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

$ arecord -l
**** Lista de Dispositivos CAPTURE Hardware ****
placa 0: Intel [HDA Intel], dispositivo 0: STAC92xx Analog [STAC92xx Analog]
  Dispositivo secundário: 2/3
  Dispositivo secundário #0: subdevice #0
  Dispositivo secundário #1: subdevice #1
  Dispositivo secundário #2: subdevice #2
$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 127
  Mono: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 102 [80%] [-18.75dB] [on]
  Front Right: Playback 102 [80%] [-18.75dB] [on]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [off]
  Front Right: Playback 127 [100%] [0.00dB] [off]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 127
  Mono: Playback 127 [100%] [0.00dB] [off]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 127
  Mono: Playback 127 [100%] [0.00dB] [off]
Simple mixer control 'Side',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [off]
  Front Right: Playback 127 [100%] [0.00dB] [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958 Playback Source',0
  Capabilities: enum
  Items: 'Digital Playback' 'ADAT' 'Analog Mux 1' 'Analog Mux 2' 'Analog Mux 3'
  Item0: 'Digital Playback'
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 14
  Front Left: Capture 14 [100%] [21.00dB] [on]
  Front Right: Capture 14 [100%] [21.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 14
  Front Left: Capture 0 [0%] [0.00dB] [off]
  Front Right: Capture 0 [0%] [0...

Read more...

I can confirm.
For me seems to be enough se DM1 on digital and just let Mic on Input Source.

anyway, it works on intrepid but we have a default configuration issue.

On Fri, Jan 16, 2009 at 3:40 PM, M Nubbe <email address hidden> wrote:
> *** This bug is a duplicate of bug 69306 ***
> https://bugs.launchpad.net/bugs/69306
>
> Everyone, double check that this is really a bug and not a setting
> error. I am using a dell inspiron 1420 with ubuntu 8.10 (intrepid),
> kernel 2.6.29, and at first the internal mic did not work. However,
> doing the following in the sound settings fixed this problem:
>
> start the volume control applet, bring it up
> open preferences, turn on digital input source and input source, along with capture
> set digital input source=digital mic 1
> input source = front mic
> make sure capture isn't muted
>
> This is also found on Leann's link:
> http://davestation.wordpress.com/2008/07/12/how-to-enable-digital-
> microphone-array-on-dell-inspiron-laptops-in-ubuntu-804/
>
> --
> Microphone does not work on Dell Inspiron 630m
> https://bugs.launchpad.net/bugs/42600
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Daniele Dellafiore
http://blog.ildella.net/

M Nubbe (m-nubbe) wrote :

This is probably not helpful, but for some reason on my dell 1420 inspiron audacity somehow started taking input from the microphone at the proper volume levels (not the low ones I normally see). Unfortunately, I haven't reproduced that result since. Skype also picked it up for that one session, but not thereafter.

Alex Mauer (hawke) wrote :

This is still a problem on Karmic with the Dell Latitude D620. Using the model=ref option to snd-hda-intel works for me.

Jeremy Foshee (jeremyfoshee) wrote :

Please test this against the current daily version of Lucid and let me know if the problem is still seen.

Thanks!

~JFo

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Brad Figg (brad-figg) wrote :

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 42600

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
tags: added: mic-int

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ben 1698 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6500000 irq 22'
   Mixer name : 'IDT 92HD81B1C5'
   Components : 'HDA:111d76d5,102802bc,00100402'
   Controls : 26
   Simple ctrls : 16
CurrentDmesg:
 [ 13.403580] ppdev: user-space parallel port driver
 [ 22.493095] eth2: no IPv6 routers present
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: wl
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=ru_RU.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
Uname: Linux 2.6.31-20-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1714): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1714): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1812): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1841): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

Changed in alsa-driver (Ubuntu):
status: Incomplete → New
Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
ben58 (b1587e8563) wrote :

The system used (s. above) - DELL Vostro 1520.

ben58 (b1587e8563) wrote :

one more addition: there is external mic on the system only. It works properly under Win7.

tags: added: kernel-sound
tags: added: kj-triage
Przemek K. (azrael) on 2010-04-08
Changed in linux-source-2.6.15 (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Foshee (jeremyfoshee) wrote :

Hi Andrew,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 42600

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: New → Incomplete
komputes (komputes) on 2010-05-13
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
komputes (komputes) wrote :

Marking as incomplete for alsa-driver (Ubuntu). Andrew, can you confirm if this issue is still an issue for you in 10.04.

Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
Package: linux None [modified: /var/lib/dpkg/info/linux.list]
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-19-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

I fear this is a general bug in 10.10. Please fix.

dino99 (9d9) wrote :

outdated report & no more maintained distro; please send a new one if that issue still exist (using ubuntu-bug)

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in alsa-driver (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers