sdhci: Nothing happens when a card is inserted

Bug #41211 reported by Richard Laager on 2006-04-25
14
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Baltix)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

I'm trying to get a card reader working on my laptop. I see that the sdhci driver loads, and provides a REGISTER DUMP. I also see "mmc0: SDHCI at 0xd2007800 irq 74 DMA". But, I don't see a block device in /dev and nothing happens / nothing appears via dmesg when I insert a card.

I thought perhaps having a newer version of the sdhci driver would help, so I copied it into a kernel tree. I had to pull in some MMC changes. I got stuck as there seems to be some new uevent stuff in a bus_type struct.

Any ideas on what I should try next?"

Tags: sd Edit Tag help

This file is the output of the dmesg command after booting.

Id2ndR (id2ndr) wrote :

Is this bug linked to bug #137686 ?

Vincenzo Ciancia (vincenzo-ml) wrote :

sdhci and the tifm_ group are two different drivers. The former is standard, and it's currently broken in gutsy, the latter is specific to TI readers, should read more cards, and is currently broken in gutsy. Hence, these are two different bugs.

Richard Laager (rlaager) wrote :

Well, in any case, the tifm driver should work for me and doesn't. I'm running 2.6.22-11-generic on Gutsy, so I've added the newer linux source package to the affected list, but I apparently don't have permission to set the importance to the same level as the older linux source package.

Changed in linux-source-2.6.22:
status: New → Confirmed
Richard Laager (rlaager) wrote :

s/tifm/sdhci/, though both *should* work for me, I think.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
Changed in linux-source-2.6.22:
status: New → Incomplete
Changed in linux-source-2.6.15:
status: New → Incomplete
Changed in linux-source-2.6.22:
status: Confirmed → Incomplete
wolfger (wolfger) wrote :

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

Changed in linux-source-2.6.22:
status: Incomplete → Invalid
Changed in linux-source-2.6.15:
status: Incomplete → Invalid
Changed in linux:
status: New → Incomplete
Vincenzo Ciancia (vincenzo-ml) wrote :

For me the sd card reader works with the tifm drivers in hardy and intrepid so I don't thing I will have anything to say if you close this, but if you need me to test something with other drivers just tell me what you need.

Peter Cordes (peter-cordes) wrote :

Most of the problems with SD card readers are hardware-chipset dependent. Someone should decide what they want this bug to be about, and post some lspci -v and lspci -vn output, and dmesg output (for the relevant devices, see e.g. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/99648/comments/24)

 Unfortunately, Richard Laager's dmesg output (above) doesn't shed any light on the PCI ID of the card reader hardware on his system. Although he thinks tifm should work for him, so presumably he has TI hardware. If it's the same hardware as bug 111756, then they should be merged as duplicates.

Peter Cordes (peter-cordes) wrote :

Richard posted on bug 137686, and it seems he has tifm_7xx1 hardware. I'm just going to close this as invalid since it doesn't have enough details about any specific hardware, and it looks like the original submitter went with bug 137686 and abandoned this. Re-open this bug if I'm incorrect.

Changed in linux:
status: Incomplete → Invalid
Changed in linux-source-2.6.22:
status: Incomplete → Invalid
Richard Laager (rlaager) wrote :

The card reader still doesn't work for me on Intrepid.

Changed in linux:
status: Invalid → New
Richard Laager (rlaager) wrote :
Richard Laager (rlaager) wrote :
Peter Cordes (peter-cordes) wrote :

your lspci output doesn't seem to include any card readers. There should be a device that lspci says is handled by sdhci..., or tifm...

 Also, lspci -vvnn includes the numeric and decoded outputs together; I should have recommended that instead of two separate lspci commands. (But wait until you find your card reader before posting another lspci. :)

Richard Laager (rlaager) wrote :

Holy cow, I'm embarrassed. I didn't even think about it because my environment Just Worked when I moved my hard drive, but I'm currently running on another laptop while mine is being repaired!

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Richard Laager (rlaager) wrote :

I'm back on my regular machine and will be attaching the right files.

Richard Laager (rlaager) wrote :
wolfger (wolfger) wrote :

Setting to "confirmed" since this bug seems to have the necessary info now.

Changed in linux:
status: New → Confirmed
Brad Figg (brad-figg) wrote :

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in supported series, please file a new bug.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers