Ubuntu crash when connecting to port replicator

Bug #41091 reported by mvisa on 2006-04-24
30
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Steve Conklin
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

I'm using a Dell Latitude D610 with a port replicator (kind of light docking station) and Ubuntu Dapper Drake 6.06. The port replicator works fine in normal use (when laptop is started while docked), but when i take the laptop off the replicator and plug it in again the system freezes. After that, the mouse mouse moves, but nothing else is possible. Login via ssh is also not possible, so the system really has crashed (and not just X Window System).

Last tested today (24.4.2006) on a completely up-to-date Dapper with kernel 2.6.15-21-686.

System logs show nothing usefule (kern.log, messages).

Output of lspci while docked:

0000:00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
0000:00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 03)
0000:00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
0000:00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
0000:00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
0000:00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
0000:00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
0000:00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
0000:00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
0000:00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]
0000:02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
0000:03:01.0 CardBus bridge: Texas Instruments PCI6515 Cardbus Controller
0000:03:01.5 Communication controller: Texas Instruments PCI6515 SmartCard Controller
0000:03:03.0 Network controller: Intel Corporation PRO/Wireless 2915ABG MiniPCI Adapter (rev 05)

Let me know if i can test something or if you need other output or information.

Mikko Visa

I have exact the same problem, also using D610 and port replicator (but I believe all the Dxxx models have the problem).

I don't have any solution but I use a little trick though. When you are about to dock the computer put it to sleep, dock it and then wake it up. Works for me (at least before sleep stopped working in dapper, hope it will be fixed before release).

Alex Mauer (hawke) wrote :

Same problem here with a C640 and kernel 2.6.17-10-generic (and previous kernels)

mvisa (mikko-puolikuu) wrote :

Update: the problem still exists in edgy beta release.

Arno (versini) wrote :

Same here with a Sony SZ160 and its dock station on Ubuntu Edgy, kernel 2.6.17-10-generic... The laptop freezes every time I undock it. Nothing can unfreeze it except a 'hard reboot' (long press on the start button).
Is there anything I can try to run or gather to help someone figure this out?

Just for your information, I had the exact same problem with the same laptop on Dapper but it went away 'magically' one day after a kernel update... (don't ask me which one ;)

Christian Theune (ctheune) wrote :

This also happens to me on a Dell Latitude D820 with kernel 2.6.20-16 on 7.04.

Mike Heath (mheath) wrote :

I too have the same problem with a Dell Latitude D820 (Linux 2.6.20-16-generic, Feisty Fawn)

Henrik Nilsen Omma (henrik) wrote :

Changing kernel task from linux-source-2.6.17 to linux-source-2.6.22 since we want to investigate this in gutsy.

Amit says: "Typically port replicator problems are related to ACPI and hotplug. There has started to exist some mainline kernel support for port replicator/dock stations in 2.6.22 and beyond"

Could someone experiencing this please test with Gutsy? Please follow https://wiki.ubuntu.com/KernelTeamBugPolicies , https://wiki.ubuntu.com/DebuggingACPI and attach outputs to this report. Thanks!

Changed in linux-source-2.6.17:
importance: Undecided → Medium
status: New → Incomplete
Henrik Nilsen Omma (henrik) wrote :

This will be too intrusive to fix for Dapper.

Changed in linux-source-2.6.15:
status: New → Won't Fix
mvisa (mikko-puolikuu) wrote :

Still getting this in fully updated gutsy (19.9.2007). Complete lockup. CTRL-ALT-BACKSPACE does not work, nor CTRL-ALT-F1.

I've attached all (hopefully) necessary logs and command outputs. The logs are taken when the machine was connected to the port replicator.

Hibernate and suspend works ok on this hardware. Worked already in feisty.

.m

mvisa (mikko-puolikuu) wrote :
mvisa (mikko-puolikuu) wrote :
mvisa (mikko-puolikuu) wrote :
mvisa (mikko-puolikuu) wrote :
Christian Theune (ctheune) wrote :

Tried with the current Gutsy Live CD, and couldn't provoke the system to lock up when connection ~ 4 times with the replicator.

I'll try the Feisty Live CD later today.

One note: from the restricted drivers manager I saw that the binary NVIDIA drivers aren't used on the LiveCD.

Matthew Garrett (mjg59) on 2007-09-29
Changed in linux-source-2.6.22:
status: Incomplete → Fix Released
Nighty (nighty) wrote :

I found the problem doesn't appear when I unload the "dock" module.

After undocking, all I need to do is remember to rmmod dock before docking the laptop again. After it's docked, it's safe to load the module again.

Hardware: Dell Inspiron 510m on one of those Dell port replicator docks.

Not a permanent solution, but good enough to tide us over until it gets fixed in the upstream kernel, where I suspect the fault to lie.

Adrian Cox (adrian-humboldt) wrote :

I've got a Dell Latitude D610, and I can confirm the report above about unloading the "dock" module. However, docking without the dock module present seems to leave other systems confused, so this isn't really a solution. This worked perfectly in Edgy - I didn't test in Feisty, as I only used Feisty as a stepping stone towards Gutsy.

I think the "fix released" status of this bug is wrong - it's still happening in up to date Gutsy installs.

Sylvain Bauza (sylvain-bauza) wrote :

Dell Latitude D610 too, kernel 2.6.22-14-generic, and re-docking makes Gutsy hanging.
I will try the "rmmod dock" workaround, but waiting the final fix. Unless "fix released" means it is not yet committed in Ubuntu repositories, I suspect the bug status to be incorrect.

Am Freitag, den 09.11.2007, 13:58 +0000 schrieb Sylvain B.:
> Dell Latitude D610 too, kernel 2.6.22-14-generic, and re-docking makes Gutsy hanging.
> I will try the "rmmod dock" workaround, but waiting the final fix. Unless "fix released" means it is not yet committed in Ubuntu repositories, I suspect the bug status to be incorrect.

I tried `rmmod`ing dock before and it did not work for me.

--
gocept gmbh & co. kg - forsterstrasse 29 - 06112 halle (saale) - germany
www.gocept.com - <email address hidden> - phone +49 345 122 9889 7 -
fax +49 345 122 9889 1 - zope and plone consulting and development

Sylvain Bauza (sylvain-bauza) wrote :

Okay, it actually works using "sudo modprobe -r bay" to ensure all dependencies are shut off.

I don't like so much this ugly hack, so if anyone working on the next 2.6.22 kernels is pacing here, he would be very helpful if he could look at the issue :)

Maor (maor-gm) on 2008-01-18
Changed in linux-source-2.6.22:
status: Fix Released → Confirmed
Maor (maor-gm) wrote :

I've got Dell precision m65, when I'm re docking in makes Gusty hanging.
When removing the bay module I can re dock as many times without being able to repreduce the issue.

Henrik Nilsen Omma (henrik) wrote :

Moving to the 'linux' package which is the 2.6.24 kernel and later. Could those experiencing this please re-test with Hardy (and set to confirmed if found)? Thanks!

Changed in linux:
importance: Undecided → Medium
status: New → Incomplete
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Mike Heath (mheath) wrote :

With the latest Hardy Heron updates (as of Feb. 27, 2008) using my Dell Latitude 810, I can dock the laptop and everything works fine, I undock the laptop and everything still works fine, I dock the laptop a second time and it crashes hard.

Adrian Cox (adrian-humboldt) wrote :

I've just tested with the 2.6.24-15-generic kernel from Hardy, and I can confirm the bug is still there. Lock up within a second of docking.

I've done some other tests, comparing Ubuntu's 2.6.22 kernel with one I built myself: my kernel works, but the bug occurs if I use the .config file from Ubuntu. The testing is a slow process, so I've not narrowed down to the guilty configuration options. I've attached a diff between the config files.

The initial obvious candidate for investigation is CONFIG_NO_HZ, but booting the Ubuntu kernel with "nohz=off" on the command line didn't fix things.

Adrian Cox (adrian-humboldt) wrote :

I've now duplicated this on a mainline kernel (2.6.25-rc8), and got some trace information. I've posted it into the kernel Bugzilla, as it isn't an Ubuntu specific issue:

http://bugzilla.kernel.org/show_bug.cgi?id=10432

Adrian Cox (adrian-humboldt) wrote :

There is now a patch for this in the kernel Bugzilla:

http://bugzilla.kernel.org/show_bug.cgi?id=10431

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

mvisa (mikko-puolikuu) wrote :

I have now tested this with todays (29.8.2008) intrepid including the new .27 kernel. Seems to work ok after first disconnect/connect. After the second time, mouse and keyboard don't work anymore. Third time whole thing locks up. Hardware is exactly the same as in the original report.

Adrian Cox (adrian-humboldt) wrote :

A patch which should fix the problem was recently posted on the linux-acpi mailing list, but it hasn't gone into the kernel yet:

http://marc.info/?l=linux-acpi&m=121988834907742&w=2

Thanks for the pointer Adrian. I'll get the kernel team to take a look.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: Incomplete → Triaged
Changed in linux:
status: Unknown → Incomplete
Changed in linux:
status: Incomplete → Fix Released
Steve Conklin (sconklin) on 2008-11-21
Changed in linux:
assignee: ubuntu-kernel-team → sconklin
status: Triaged → In Progress
Steve Conklin (sconklin) wrote :

This patch is now upstream. I've applied it to a test intrepid kernel, which is available here:

http://people.ubuntu.com/~sconklin/41091/

Is it possible for you to test this and see whether is solves the problem?

Thanks

Mike Heath (mheath) wrote :

This is the happiest day of my whole life. I just installed the kernel that Steve just posted and I docked my Dell Latitude D830, undocked it, docked it again, undocked it, docked it again, and now I'm writing this post. No lock ups.

Steve Conklin (sconklin) wrote :

ok, turns out that that this was already committed to the intrepid tree on Nov 13th as part of some ACPI patches.

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-intrepid.git;a=commit;h=5eb89c4b260f5d8d857f8730980645811861d567

Steve Conklin (sconklin) wrote :

SRU Justification

Impact: Dell Latitude D610 crashes when used with port replicator

Patch Description: Avoid the _STA method if already in progress

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-intrepid.git;a=commit;h=5eb89c4b260f5d8d857f8730980645811861d567

Test Case: See bug description

Steve Conklin (sconklin) on 2008-11-25
Changed in linux:
status: In Progress → Fix Committed

This patch is available in the latest 2.6.27-11.27 Intrepid kernel update. Marking this Fix Released.

Changed in linux:
status: Fix Committed → Fix Released
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.