panic on boot with 2.6.15-18-amd64-generic

Bug #35788 reported by taloche on 2006-03-20
8
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Brian Murray

Bug Description

Shortly after booting, the kernel 2.6.15-18-amd64-generic crashes on my computer. I get the following message:

early exception rip
ffffffff802294d9 error 0 cr2 ffff810040000000 (acpi_table_compute_checksum)
ffffffff8011df9a error 0 cr2 ffffffffff5fd023 (safe_smp_processor_id)

(I looked for the function names in the System.map).

I tried to boot with acpi=off, -noapic, -nolapic and got the same error. The kernel crashes exactly the same way with both the live and the install cd (which is not surprising). I have:

cpu: AMD Athlon 64 3000+
chipset: nvidia CK804 (nForce 4) + AMD k8 bridge
ram: DDR200 1go

I have been running breezy for a while, without a problem. I also tried to boot with the -k8 kernel and got the same result. I'm trying to boot on a custom kernel without smp and acpi.

Ben Collins (ben-collins) wrote :

Can you get me a photo of the screen when it crashes? Also, make sure to remove the "quiet" boot option so that as much output is created as possible.

taloche (laurent-perrin) wrote :

The kernel crashes at the very beginning of the boot. Here exactly what I get on the screen (without the "quiet" option):

  Booting command-list
kernel direct mapping tables upto ffff810100000000 @ 8000-b0000
PANIC: early exception rip ffffffff802294d9 error 0 cr2 fffff810040000000
PANIC: early exception rip ffffffff8011df9a error 0 cr2 fffffffff5fd023
kernel /boot/vmlinuz.old root=/dev/hda5 ro
   [Linux-bzImage, setup=0x1e00, size=0x1662b2]
initrd /boot/initrd.img.old
   [Linux-initrd @ 0x3f93a000, 0x6a5eac bytes]
savedefault
boot
.
Decompressing Linux...done
Booting the kernel.

I disabled SMP and ACPI in the kernel and it booted. So it's possible that the problem is related to that.

taloche (laurent-perrin) wrote :

I also tried with earlyprintk=vga, and it seems that the kernel after mapping the BIOS-provided physical RAM map. I searched about this issue on the web and didn't get much luck, but I noticed some changes in 2.6.16 around SMP. I'll give it a try tomorrow.

Matt Zimmerman (mdz) wrote :

Can you attach a full dmesg from the working kernel? Does the generic kernel boot with nosmp?

Changed in linux-source-2.6.15:
status: Unconfirmed → Needs Info

kernel command line:

/boot/vmlinuz-2.6.15-20-amd64-generic root=/dev/hda5 ro quiet splash nosmp acpi=off

Ben Collins (ben-collins) wrote :

So 2.6.15-20-amd64-k8 doesn't work? Note, this is the kernel I am using on my AMD64-3200, with nvidia4 chipset (not using ATI video like you are though).

taloche (laurent-perrin) wrote :

Yeah, I've just tried again after coming back from work and I still have the same issue with 2.6.15-20, -generic and -k8. Just to be sure, I tried to plug my old nvidia card, with no luck. I have searched on the internet for similar problems, and it seems to be quite rare. With nosmp and acpi=off on the command line, everything works perfectly, though.

I'm experiencing this bug also with the latest 6.06 beta live cd. nosmp and acpi=off work for me.

Adam Skogman (adam-skogman) wrote :

I had the very same problem on an IBM x326m 7969-67Y, which is a dual opteron 275.

Removing the Remote Supervisor Adapter II fixed the boot problem. The card is what IBM calls a Baseboard Management Controller, an MS-9549 PCI card. However, then fan controll stopped working :-(

I seem to be having some problems with iommu too, and when enabling earlyprintk=vga it stops right after having complained about not having an aperture.

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in linux-source-2.6.15:
assignee: nobody → brian-murray
Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in linux-source-2.6.15:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers